locked
Unable to Change Domain Logon Name error with copy of System Admin role RRS feed

  • Question

  • Hi,


    Dynamics user A needs to change user B's domain logon.


    When user A has the System Admin role, everything goes smoothly.


    When user A has a role R that is a copy of the System Admin role (using More Actions > Copy Role), I get the following error :

    Unable to Change Domain Logon Name
    You do not have the necessary permissions to change the domain logon name for this user.

    Does anyone see the logic behind it ?

    I already tried https://astutecrm.wordpress.com/2012/08/27/crm-2011-unable-to-change-domain-logon-name-access-denied-error/ and https://zhongchenzhou.wordpress.com/2012/05/17/dynamics-crm-2011-plugin-error-you-do-not-have-the-necessary-permission-to-change-the-domain-logon-name-for-this-user-access-is-denied-system-unauthorizedaccessexception/ with no result.

    My setup is

    Dynamics CRM 2016 SP1

    On premise

    Thanks

    Monday, November 28, 2016 11:10 AM

All replies

  • There is no obvious logic behind this other than a copy of the System Admin role is always going to be different from the built-in system administrator role. For example, when you create an entity, the System Administrator role automatically has full rights to that entity but a copy won't.

    I was going to mention that it might an Active Directory issue but you state that User A can change the logon when User A has the built-in System Admin role so that really rules out issues outside of CRM.

    You could try enabling tracing on the server in the hope of getting a more useful error message.

    Monday, November 28, 2016 4:31 PM
    Moderator
  • Got the same problem, and I solved it.

    First you need to go to "Information Services (IIS) Manager", click on "Application Tools", then right click on CRMAppTool, "Advanced Settings", next to "Identity", click on "...", select "Custom Account", enter the Account Name and Password you are using in the CRM organization.

    DONE!

    Try again.

    Wednesday, November 1, 2017 6:45 AM