locked
Router overwrite RRS feed

  • Question

  • I have just installed WHS, and is now trying to setup the remote interface.

    When I do that it overwrites my existing settings.

    I have a web and mail server running on my network. They are setup as virtual applications in my dlink router

    so port 80 and 443 is routed to the relevant server.

     

    When I user Windows Home server settings-Remote Access-Router, it change my current settings to the IP of the WHS. I do not want it to do that.

    1. I would like to specify the portnumbers so I could say ext port 81 maps to WHS:80 and ditto for ssl.

    2. I would like to use my own domain name. I would to say:
    http://something.mydomain.net:81 or https://something.mydomain.net:444

     

    Microsoft should not blindly overwrite my router settings, or they should warn me and give me an alternate way to set this up.

    Monday, July 23, 2007 3:52 PM

Answers

  •  

    Ok I can make it work now.

    I think the conclusion is:

    1. If you have other HTTP servers then do not use the WHS console to enable WHS.
    2. you need to manually enter add two new entrie in the router.
      In my case I added ext. port 81 to whs:80
      and ext. 444 to whs:443
    3. the chosendomain.livenode.com and references your own external IP address
      So if you have your own domain you can use that as well, in my case I use www.mydomain.net:444

    I think Microsoft should take this under consideration so it do not come as a surprise.

    My WebServer was unavailable for about 24 Hours before I discovered what was wrong.

    Thursday, July 26, 2007 3:16 PM

All replies

  • When you use the WHS Console to set up your router, it's going to use the default ports for HTTP and HTTPS, because it assumes that there are no servers already using those ports. Remember, the primary target audience is a technically unsophisticated user buying WHS preinstalled on OEM hardware like the HP MediaSmart Server. Enthusiasts are only a secondary market. Given that you're already running mail and web servers on your home network, you're obviously much more knowledgeable than the average user of WHS is expected to be.

    You should manually configure your router and WHS to use the ports you select.
    Monday, July 23, 2007 4:19 PM
    Moderator
  • I am with you so far.

    But I am apperently not knowledged enough. ;-)

    I have set up two extra entries in my router so I map 81 to whs:80 and ditto for 444 to whs:443

    I can see if I ping chosendomain.livenode.com it refers to my own domain.net

    So I should be able to use my own domain.

    and I get the same errors for both addresses.

    If I use http://chosendomain.livenode.com:81/

    it sets up: http://chosendomain.livenode.com:81/home/default.aspx?gotodefault=true

    which gives me a 404

    If I change that to: http://chosendomain.livenode.com:81/home/default.aspx

    it shows me a nice picture and a logon button but clicking on that gives me 404.´

     

    If I use https://mydomain.net:444/

    it sets up: https://mydomain.net:444/home/default.aspx?gotodefault=true

    which gives me a 404

    If I change that to: https://mydomain.net:444/home/default.aspx

    it shows me a nice picture and a logon button and clicking on that gives a logon screen and it work. 

    That is as far as I have managed it to work.

    No success on http but it seems to work on https

     

    I still think that a warning before a possible overwite would be a decent thing to do.

    By setting it up manually I guess I do not need to enable UPnP as well.

     

    Monday, July 23, 2007 4:41 PM
  • You will need to reconfigure IIS for the default web site on WHS to work with the new port settings. You may also have to make a change in the web application settings to support this, but I'm not home to check.

    Let me know if you need any additional information.
    Monday, July 23, 2007 5:28 PM
    Moderator
  •  

    Ok I can make it work now.

    I think the conclusion is:

    1. If you have other HTTP servers then do not use the WHS console to enable WHS.
    2. you need to manually enter add two new entrie in the router.
      In my case I added ext. port 81 to whs:80
      and ext. 444 to whs:443
    3. the chosendomain.livenode.com and references your own external IP address
      So if you have your own domain you can use that as well, in my case I use www.mydomain.net:444

    I think Microsoft should take this under consideration so it do not come as a surprise.

    My WebServer was unavailable for about 24 Hours before I discovered what was wrong.

    Thursday, July 26, 2007 3:16 PM
  •  

    Is it possible to have 2 WHS servers running their own livenode address on one router??

    The reason I ask, is I have my personal WHS which I love, and then i am trying to get another to use that I will be hosting basically for a networking group of friends.  Mainly for them all to be able to upload pictures of various events.  We see eachother once a week, so an upload would be easier, plus I would like to keep it seperate from my home, personal server.

     

    I hope ppl understand what I'm asking.

    any ideas?

    Tuesday, July 31, 2007 11:16 PM
  •  

    I would say yes.

    setup your router so when a request come in on a given port route that the whs

    Ex.

    in the router you setup so port 444 points to WHS1:443

    and so port 445 points to whs2:443

    This should do the trick.

    You need to enable web access in the WHS settings.

    But you do not need to set remote access, which will try to configure your router

    that will not work for the above.

     

    After this you should be able to access the two whs machine using:

    https://yourdomain:444/home/default.aspx  -> whs1

    https://yourdomain:445/home/default.aspx  -> whs2

     

    444 and 445 are just examples, pick your own

    Wednesday, August 1, 2007 4:58 PM