locked
Default SMTP router RRS feed

  • Question

  • How do I setup a default email router just for sending SMTP? I am running windows server 2008 and IIS 7. I don't have an exchange server. I just want to configure CRM to send from local. Thanks.
    Wednesday, December 16, 2009 4:18 PM

Answers

  • You have to install SMTP Server on the CRM server. To do it on Windows 2008 you need to go to the Server Manager -> Add features -> SMTP Server. Later in the EER (Exchange Email Router) you have to choose SMTP server.


    My Dynamics CRM Blog: http://bovoweb.blogspot.com
    • Proposed as answer by kgorczewski Wednesday, December 16, 2009 5:48 PM
    • Marked as answer by xxjt123xx Saturday, December 19, 2009 7:32 AM
    Wednesday, December 16, 2009 5:48 PM

All replies

  • You have to install SMTP Server on the CRM server. To do it on Windows 2008 you need to go to the Server Manager -> Add features -> SMTP Server. Later in the EER (Exchange Email Router) you have to choose SMTP server.


    My Dynamics CRM Blog: http://bovoweb.blogspot.com
    • Proposed as answer by kgorczewski Wednesday, December 16, 2009 5:48 PM
    • Marked as answer by xxjt123xx Saturday, December 19, 2009 7:32 AM
    Wednesday, December 16, 2009 5:48 PM
  • I have done that. I am looking for the specifics inside the email router and what I need to put for the values, and am I going to need to define a rule so everyone uses that default smtp router after and what will I need. Steps or an example would help. Thanks.
    Wednesday, December 16, 2009 6:09 PM
  • I have done that. I am looking for the specifics inside the email router and what I need to put for the values, and am I going to need to define a rule so everyone uses that default smtp router after and what will I need. Steps or an example would help. Thanks.


    First go to the users and change values E-mail access type Outgoing to E-mail router. Later log as user and go to Personalize Workplace (you will see it when you will be in Workplace area). In the tab E-mai you will have new checkbox (Allow E-mail Router ...) mark it and put credetentials.
    Next go to EER and in the General Tab choose Direction: Outgoing and Email Server Type: SMTP. In Location Type SMTP Server Name and creditencials. In second tab (not remember name) fill all information regarding CRM server and put administrator username/passoword.

    http://blogs.msdn.com/crm/archive/2008/01/29/what-s-new-in-microsoft-dynamics-crm-4-0-e-mail-integration.aspx
    http://blogs.msdn.com/crm/archive/2008/02/07/crm-4-0-e-mail-integration-overview.aspx


    My Dynamics CRM Blog: http://bovoweb.blogspot.com
    Wednesday, December 16, 2009 6:21 PM
  • I will try that. Thanks.

    You wouldn't be able to help out with these would you?

    http://social.microsoft.com/Forums/en-US/crmdeployment/thread/fcde28ad-75bd-47cb-8e4f-df2ef4c3a848
    http://social.microsoft.com/Forums/en-US/crmdeployment/thread/29a6cc77-9adc-4094-80f3-077812ca0cc2
    Wednesday, December 16, 2009 8:16 PM
  • I tried those and it still didn't seem like it was working. Do you know of a way to trace it so I can make this less of a black box. It could be a bunch of things at this point. Bad configuration in IIS, CRM still not setup correctly with email, or some sort of firewall blocking the email, or the domain not allowing relaying.

    I followed the instructions and setup a default smtp with the crm email tool and then went into the user accounts and set the outgoing the way the article said to. I am still not getting any email coming in though.
    Thursday, December 17, 2009 5:10 PM
  • Hi,

    Sad to hear:

    Here you have CRM Exchange Logger: http://blogs.msdn.com/benlec/archive/2008/07/02/crm-4-0-e-mail-connector-logger-tool.aspx
    Here is troubleshooting guide for EER: http://rc.crm.dynamics.com/rc/regcont/en_us/op/articles/tshootrouter.aspx

    When you're try to test it is working ? Need more information where is a problem (check event viewer).
    My Dynamics CRM Blog: http://bovoweb.blogspot.com
    Thursday, December 17, 2009 6:34 PM
  • Hi,

    Can you post any errors logs raleted with the issue? they are in the event viewer as CRMEmailService..

    Can you tell more in detail what you need???
    I assume that you are trying send email to registerd users of your local network,... if this users are conected to a exchange server or other mail server you have... you must configured to permit relay from Server where you install CRMEmailrouter Service...


    Can you load the users in the CRMemailrouter config wizz?
    When you test the outgoing profile form Wizzard, what is the message that you see?
    Try to post the CRMEmail log in the event viewer.

    It could be an credentials problems....

    In CRMEmail router Configuration Wizz You must configure the Outgoing profile with an account that have right to send email by ex: user@domain.com.
    Then in the deployment tab.. you must configure the crm implementation that you need to configure using local credential. then you must load the users and test the outgoin profile and publish the changes..
    Thursday, December 17, 2009 7:12 PM
  • I will try and get more information using tracing and event logs. I am configuring this not for exchange users, but just generic email accounts to send to and one to send from. I am able to load and see the user on the last tab of the email router wizzard.

    1) I think I need to add the from user accounts domain to allow relaying.
    2) I need a mock example of setting up non exchange users to send to what I need to do in IIS and in the email router. All this as an example would really help. IE: In email router set server = "localhost"; then click publish; then set users outgoing email = "email with router".
    Thursday, December 17, 2009 7:25 PM
  • I did need to install the smtp router. I am not used to how iis 7 has that . I then had to make sure the firewall was not blocking that port. I also had to make sure the email server would allow relaying.
    Saturday, December 19, 2009 7:34 AM