locked
CRM 3.0 : the selected object could not be found. verify that the object exist in both the data base and active directory RRS feed

  • Question

  • Hi All,

    we have got CRM 3 System and we are trying to create new user account (refer attache screen http://drop.io/flesdtf/asset/err1-bmp)

    we get the user details from our domain server. (user exists on both Active Directory and CRM database)

    But then when we click Save and Close to confirm the changes we get error:

    the selected object could not be found. verify that the object exist in both the data base and active directory  (refer attached screen http://drop.io/k10fpal/asset/err2-jpg)

    can any one please help us out here??
    Tuesday, May 5, 2009 4:11 PM
    Answerer

Answers

  • I have seen this issue in the case where you are adding users from a trusted domain but it's not fully bi-directional.
    It can find the user from AD, but it can't write that user to the AD CRM User Group.
     
    Try going in to AD Users and computers and manually adding the user as a member of the User group for CRM.  Then go to CRM and you should be able to add the user.
    "MayankP" wrote in message news:1784afe9-50c0-405 9-b521-0b3f079c03d9...
    Hi All,

    we have got CRM 3 System and we are trying to create new user account (refer attache screen http://drop.io/flesdtf/____ et/err1-bmp)

    we get the user details from our domain server. (user exists on both Active Directory and CRM database)

    But then when we click Save and Close to confirm the changes we get error:

    the selected object could not be found. verify that the object exist in both the data base and active directory  (refer attached screen http://drop.io/k10fpal/____ et/err2-jpg)

    can any one please help us out here??
    Tuesday, May 5, 2009 5:06 PM
    Moderator

All replies

  • Do you have any customization, javascript or other code running on the form?  If so, disable or remove the code and try again. 

    If the above does not work try adding a test user to AD and see if you can create a user record for that user.  Also, what error do you have in the event viewer? 
    Best Regards, Donna
    Tuesday, May 5, 2009 4:50 PM
  • I have seen this issue in the case where you are adding users from a trusted domain but it's not fully bi-directional.
    It can find the user from AD, but it can't write that user to the AD CRM User Group.
     
    Try going in to AD Users and computers and manually adding the user as a member of the User group for CRM.  Then go to CRM and you should be able to add the user.
    "MayankP" wrote in message news:1784afe9-50c0-405 9-b521-0b3f079c03d9...
    Hi All,

    we have got CRM 3 System and we are trying to create new user account (refer attache screen http://drop.io/flesdtf/____ et/err1-bmp)

    we get the user details from our domain server. (user exists on both Active Directory and CRM database)

    But then when we click Save and Close to confirm the changes we get error:

    the selected object could not be found. verify that the object exist in both the data base and active directory  (refer attached screen http://drop.io/k10fpal/____ et/err2-jpg)

    can any one please help us out here??
    Tuesday, May 5, 2009 5:06 PM
    Moderator
  • I have seen this issue in the case where you are adding users from a trusted domain but it's not fully bi-directional.
    It can find the user from AD, but it can't write that user to the AD CRM User Group.
     
    Try going in to AD Users and computers and manually adding the user as a member of the User group for CRM.  Then go to CRM and you should be able to add the user.
    "MayankP" wrote in message news:1784afe9-50c0-405 9-b521-0b3f079c03d9...
    Hi All,

    we have got CRM 3 System and we are trying to create new user account (refer attache screen http://drop.io/flesdtf/____ et/err1-bmp)

    we get the user details from our domain server. (user exists on both Active Directory and CRM database)

    But then when we click Save and Close to confirm the changes we get error:

    the selected object could not be found. verify that the object exist in both the data base and active directory  (refer attached screen http://drop.io/k10fpal/____ et/err2-jpg)

    can any one please help us out here??
    Tuesday, May 5, 2009 5:06 PM
    Moderator
  • Thanks!! it worked!!
    Wednesday, May 6, 2009 11:45 AM
    Answerer