none
Add-In not getting loaded in Windows 10 and Office 2016. RRS feed

  • Question

  • We have a excel add-in and it works fine for windows 7 users and Windows 10 users who upgraded from Windows 7.

    Some of our clients who have got fresh windows 10 machines are able to install the add-in (.VSTO) succesfully, however when they open Excel 2016 add-in is not loaded.

    That add-in is neither in inactive or disabled add-in nor registry entry is created for the add-in at HKEY_CURRENT_USER\Software\Microsoft\Office\Excel\Addins

    Any pointers would be really useful.

    Have installed VSTO on Windows 10 machine.


    Tuesday, June 26, 2018 11:07 AM

All replies

  • Hello Varsha,

    Is your add-in listed in the COM add-ins list in Excel 2016?

    Looks like something is wrong with your installer. Make sure that you did all steps described in the Deploy an Office solution by using Windows Installer article. 

    Also you may find the Troubleshoot Office solution deployment article helpful. 


    profile for Eugene Astafiev at Stack Overflow, Q&A for professional and enthusiast programmers

    Tuesday, June 26, 2018 1:33 PM
  • Hi Eugene,

    Thank you for your reply.

    My add-in is not listed in COM add-ins list in Excel 2016. We have used Wix for installer project and we have used Visual Studio 2010 for development. 

    We have installed .NET framework 3.5 on Windows 10 as it pre-requisite for installing add-in.

    Will check office solution deployment link provided by you. Meanwhile let me know if you have any other pointers.

    Thanks & Regards,

    Varsha Hangire


    Wednesday, June 27, 2018 5:19 AM
  • Hello Varsha Hagire12,

    >>We have used Wix for installer project..

    Since Wix is a third part application so I will move the thread to Off-Topic forum. 

    For you issue, I would suggest you refer to the steps in the Deploy an Office solution by using Windows Installer article.  If you still have issue after deploying the add-in by using the windows installer. You could post new thread to detail your issue to let us know.

    Thanks for understanding,

    Best Regards,

    Terry


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, June 29, 2018 7:47 AM