locked
Restore from WHS halts during 'view files' RRS feed

  • Question

  • Trying to restore a file to a Win7-32 laptop from WhS. When I click the restore/view files for the backup set I want to view, the progress bar runs to 81% (same place each time) and halts. At that time the display on the server console changes the status of all clients from "Backed up" to "Unknown" and the backup display reports 'Cannot mount the backup'.

    This happens on 2 different computers and on all attempts to view the backed up files. Always at 81%.

    I've reset the WHS and both PCs. Also when the backup is halting, I get a popup that "backup server is not  running". I can't tell if its a network error, file/disk error, or just overextending the processor/ram on the WHS device.

    Any help would be appreciated.

    Saturday, February 18, 2012 8:13 PM

All replies

  • Have you looked at the FAQ section of this forum? Try here:

    http://social.microsoft.com/Forums/uk/whsfaq/thread/785bc097-b7b0-4268-bd9f-cc802c5eb355


    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.

    Saturday, February 18, 2012 8:25 PM
  • After running WHS v1 for over two years  and never having a problem, when I needed  my backups most I experienced the dreaded  81% bug. I searched and searched for a  solution and finally stumbled upon the  solution below. Hopefully my instructions  below will help someone who has been  disappointed by their WHS backups.

    This solution worked for me:

    Whoever built this app deserves a medal.  Download his app at the website below:

    http://blog.whssafebackup.com/2009/09/whsdbdatadump-100-build-2-beta.html

     

    Quick and dirty way to get your files  back:

    1. Attach an external USB drive to your  home server

    2. Extract and copy whsdbbackup.exe from  the link above into your backup database  folder (in my case is was D:\folders \{00008086-058D-4C89-AB57-A7F909A47AB4}  (You can also modify your system path to  include this folder, but as I said this is  the quick and dirty way)

    You'll know you have the right folder if  you see files with the names of your  computers in them. For example  HOMEPC.C.Volume.dat

    3. Open up a command prompt in your backup database folder and type the  following command:WhsDbDataDump.exe  /ntfsdump="c:\WhsBackup"

    Replace c:\WhsBackup with the path to your  external USB drive. Make sure you include  the quotes in the command.

    4. You will be presented with a list of  your computers that have been backup up.  Select the number of the computer you want  to extract the files from

    5. You will be presented a list of backup  sets. Select the number of one you want

    6. You will be presented a list of the  volumes that are in that backup. Select  the number of the one you want.

    7. The application will build an index  cache (this takes a little while, be  patient) and then build a volume cache  (this take a while, too)

    8. The application will start dumping the  individual files from the backup to your  external drive. The resulting disk won't  be bootable, but if you just need your  data back like I did this is absolutely  awesome!

    9. Once it's finished celebrate having  your files back and then start looking for  a backup solution that will not let you  down!!

    Good luck

    -Gary

    Saturday, February 25, 2012 4:15 PM
  • Hi Gary,

    I tried your solution on my WHS V1 system and each time I receive a divide by zero error whenever the data files are starting to extract and be written to the destination.

    Any ideas what might be going on?

    -Bill

    Sunday, December 1, 2013 2:13 AM