locked
CRM 2013 SP1 - RemoveFromQueueRequest fails RRS feed

  • Question

  • It seems to be very simple to use the newly added RemoveFromQueueRequest (which was added to the CRM 2013 SDK with SP1). It only takes a single property called 'QueueItemId', which according to the instructions should indeed be the id of queue item, which one would like to remove from (I guess) whatever queue it is assigned to.

    However, when executing the request it fails with the error message: The 'RemoveFromQueue' method does not support entities of type 'queueitem'. I have tried to put in the id of the referenced activity on the queue item, but this returns the same error.

    Anybody have any idea as to how to use this new (and apparently not so simple) request?

    Thanks :)

    Thursday, June 19, 2014 8:01 AM

Answers

  • Somehow this was resolved on it's own. I have no clue, what caused it in the first place, but a few weeks ago I tried to implement the same code in another development environment and it worked fine there. It has later been moved through the environments all the way to production without errors. 

    So apparently this was a local issue. 

    • Marked as answer by Dennis Moesby Monday, August 11, 2014 9:08 AM
    Monday, August 11, 2014 9:08 AM