locked
Where is my storage?? RRS feed

  • Question

  • I just installed a fresh installation of RC1 to my Server.  I removed all drives but the primary.  I then added 2 250GB internal drives.  It shows I have over 500GB available free space.  However, when I try to copy my video and Music files onto the Server (from a remote computer) I get an error that there is not enough room to copy the files.  It is only allowing me access to the Primary drive.  This never happened to me in the previous versions.  I have all of my data on external My Books and I really would like to get this copied back to the Server.  Please Help.
    Saturday, June 16, 2007 9:56 PM

All replies

  • OK. So I mapped my external drive from onother computer to the Server.  I am able to copy the files onto the Server folders from the Server itself.  My question is, Why can't I do this from a remote connected computer?  All of my computers are located on the same wired network.  I just do not understand what has changed.  Please help.
    Saturday, June 16, 2007 10:21 PM
  • Can you copy anything at all, or just a few files before you get the error? It might be something as simple as the remote user not having write access to the media shares.
    Saturday, June 16, 2007 10:46 PM
  • I am having the same issue.  Only difference is I get an red alert saying my system drive has only 5gig left and I need to install another drive.   The files were also going to my video folder and I was trying to do it from the "shared folders" folder on my remote desktop.  The shared storage says I have almost 40gig of space.
    Saturday, June 16, 2007 11:02 PM
  • I have Full read and write access for all users on the network.  It will allow me to copy files, but only up to 50GB (the remainder on my primary drive).  It is like I can only copy to the primary from another computer.  I did NOT have this issue with any of the previous versions.  I am able to copy to the other drives, but ONLY from the server itself.  From any other terminal, I only have about 50GB accessible.  I have a 80GB primary, 2x 250GB internal secondary drives, and I will add 3 500GB external My Books as I copy the data off of them to the server.  I would really like to correct this problem since I have friends and family that upload data from remote locations.  I also would prefer to control the server from my primary computer in my office instead of in the basement where the server is kept.  Any help would be appreciated.
    Sunday, June 17, 2007 1:21 AM
  •  DaveB99 wrote:
    I am having the same issue. Only difference is I get an red alert saying my system drive has only 5gig left and I need to install another drive. The files were also going to my video folder and I was trying to do it from the "shared folders" folder on my remote desktop. The shared storage says I have almost 40gig of space.


    In addition to what I described here, http://forums.microsoft.com/WindowsHomeServer/ShowPost.aspx?PostID=1743942&SiteID=50 , I'm now getting the same "Error: System Hard drive has less than 5GB free space. Please add a hard drive to your server storage or delete some files." error that you're seeing. The ironic thing is that I have nearly a terabyte of free space in the storage pool. Over 250GB of transferred files seem stuck on my system drive (D:\DE\shares\foo). The demigrator.exe process is going full-bore but it doesn't seem to be migrating files over to the storage pool space.
    Sunday, June 17, 2007 1:51 AM
  • As per Ken Warren, I ran a Talq upload and gave the number on the other thread I referenced.  For further visibility, I'll post it here, too.  Thanks.

    CAB 350663516
    Sunday, June 17, 2007 3:17 AM
  • The WHS Team says the only way to copy files to the server is to a shared folder - the ones in the shared folder on your desktop.

    Have you tried that?

    Sunday, June 17, 2007 3:24 AM
  • You need a larger primary drive. Files are copied first to the primary and then eventually to the others. So, with your 80GB primary, less 20GB for WHS, that leaves not much more than 50GB before you start to run out of room. Per the Getting Started .pdf file,
    The primary (system) hard drive should be as large as possible to ensure that you can copy a large number of files or multiple large files to your home server at the same time.


    Sunday, June 17, 2007 3:43 AM
  •  Courtney123 wrote:

    The WHS Team says the only way to copy files to the server is to a shared folder - the ones in the shared folder on your desktop.

    Have you tried that?



    These files are from a HDD connected directly to the WHS and copied  to the WHS via the \\server\foo\ paths.  The intent is to copy the files to the storage pool and add this drive to said pool.  This is exactly how I built and added files to the CTP version (without this problem).
    Sunday, June 17, 2007 3:44 AM
  • Is this something new?  I never ran into this before. 

     

    Also, If I copy enough data from a remote lacation to the server to fill the remainder of the primary, I cannot copy anymore.  It is as if it can ONLY access the Primary to copy to.  I understand what you are saying, but I would prefer to use the 80GB as the primary since it is the most stable drive.  The 2 internals are Maxtors and have a higher failure rate.  All other drives are externals.

    Sunday, June 17, 2007 4:27 AM
  • Misunderstood your question.

    Sorry.

    Sunday, June 17, 2007 4:30 AM
  • I too am copying to a shared folder.  I am copying to the Videos and Music folders on the server.  Like skwire, I never had this issue with beta 2 or CTP.  I do not think this is due to having a 80GB primary unless MS changed something poorly for the RC1 release.  At this point I prefer the former releases.
    Sunday, June 17, 2007 4:30 AM
  • My q_de.log file is filled with entries like:

    Code Snippet

    CORE: 06/16/2007 23:33:07:828: Deleted Shadow path D:\DE\shares\Music\M\Mannheim Steamroller\[1984] Christmas\10 - God Rest Ye Merry, Gentlemen.mp3 FileID 281474976874831
    CORE: 06/16/2007 23:33:07:828: TryDeleteFile called from RebalanceToAnotherSecondaryD:\DE\shares\Music\M\Mannheim Steamroller\[1984] Christmas\10 - God Rest Ye Merry, Gentlemen.mp3 FileID 281474976874831
    CORE: 06/16/2007 23:33:38:375: Deleted Shadow path D:\DE\shares\Music\M\Mannheim Steamroller\[1984] Christmas\11 - Stille Nacht.mp3 FileID 281474976874832
    CORE: 06/16/2007 23:33:38:375: TryDeleteFile called from RebalanceToAnotherSecondaryD:\DE\shares\Music\M\Mannheim Steamroller\[1984] Christmas\11 - Stille Nacht.mp3 FileID 281474976874832



    The odd thing is that these music files already exist in the pool. As in, they're accessible from the \\server\music\ path. I wonder if that's causing the conflict.
    Sunday, June 17, 2007 4:36 AM
  •  RToudouze wrote:
    I too am copying to a shared folder. I am copying to the Videos and Music folders on the server. Like skwire, I never had this issue with beta 2 or CTP. I do not think this is due to having a 80GB primary unless MS changed something poorly for the RC1 release. At this point I prefer the former releases.


    Based on what I know, with an 80GB primary, you will only be able to copy up to 50GB chunks of data at a time the WHS. However, this does not reflect the total amount of data you can store in your pool (2x250GB drives according to your first post). Make sense? This is why Microsoft recommend you use one of your larger drives as the primary. For instance, my primary is a 300GB drive so I should, all things being equal, be able to copy over up to 260GB worth of files at a time.
    Sunday, June 17, 2007 4:41 AM
  • This makes sense.  However, I do not think that is my problem.  It doesn't seem to be a matter of over 50GB at once.  It seems to be over 50GB total.  Once I have copied over that many files, I am unable to copy anymore from any terminal except the server itself.  At this point I have over 1.5TB of total space with over 1TB free and I still cannot copy a single 10gb file from my office computer.  I guess this isn't a HUGE issue, but it is frustrating.  Hopefully this will get worked out before the RTM.
    Sunday, June 17, 2007 4:49 AM
  • I started tailing that q_de.log file and it kept trying to process the "stuck" files in the d:\DE\shares folder so here is what I did:

    1) Stopped the 'Drive Extender Migrator Service' via the Services applet.
    2) I copied out everything in the d:\DE\shares folder back over to a connected HDD that wasn't part of the storage pool.
    3) I then deleted everything under d:\DE\shares and rebooted the server.
    4) Verified that I had my expected 259GB of available transfer space in \\server\<anypath>
    5) Checked the q_de.log file and nothing seemed amiss.
    6) Checked the d:\DE\shares folder and verified that it was empty.
    7) Attempted to transfer from the connected drive (H:\) to \\server\videos whilst watching the d:\DE\shares space.
    8) At this time, transfers seem to be going perfectly. I'm also noticing no files getting stuck in the d:\DE\shares folder either.

    It seems to have worked for me but, obviously, attempt at your own risk.
    Sunday, June 17, 2007 7:15 PM
  • Thanks,

    I will give this a shot.

    Monday, June 18, 2007 1:36 PM