locked
FIOS blocks port 80 and port 443 RRS feed

  • Question

  • I was excited to get my Windows Home Server up and running and after hours of troubleshooting of why I could not get in from the internet for remote access I found out that Verizon FIOS blocks port 80 and port 443.  Does anyone know a way around this?  Is there anyway to configure WHS to use different ports?  Please help!

     

    Thanks!

     

    John

    Saturday, April 21, 2007 1:30 PM

Answers

  • If it's possible, you should look at mapping different ports through your broadband router. You'll have to refer to your router's help pages or manual to determine exactly how to do that, but many routers let you translate an external port (81 for example) to a different internal port (80) for incoming requests.

    However, you may find that Verizon doesn't actually block specific ports. They may block all incoming ports except a couple. In that case, you can either try to get Verizon to allow you additional ports (which may be possible, if you pay for a business service) or just live with no remote access.
    Saturday, April 21, 2007 1:52 PM
    Moderator
  • I am on FIOS and they only block 80 for me.  I can use SSL on 443 to connect.  Just be sure to add the https.
    Saturday, April 21, 2007 6:36 PM

All replies

  • If it's possible, you should look at mapping different ports through your broadband router. You'll have to refer to your router's help pages or manual to determine exactly how to do that, but many routers let you translate an external port (81 for example) to a different internal port (80) for incoming requests.

    However, you may find that Verizon doesn't actually block specific ports. They may block all incoming ports except a couple. In that case, you can either try to get Verizon to allow you additional ports (which may be possible, if you pay for a business service) or just live with no remote access.
    Saturday, April 21, 2007 1:52 PM
    Moderator
  • I totally agreed with Ken. My ISP blocks port 80 and 443, and my router does not support port mapping from WAN to a different LAN ports. So I had to download a 3rd party FW. In the Beta 2, I start messing around with the default IIS ports 80 and 443, and wow.... gave me many many problems with connector and other issues. If all possible, best not to change the default ports.
    Saturday, April 21, 2007 6:02 PM
  • I want this to work!  What 3rd party FW allowed you to get around this?
    Saturday, April 21, 2007 6:19 PM
  • I am on FIOS and they only block 80 for me.  I can use SSL on 443 to connect.  Just be sure to add the https.
    Saturday, April 21, 2007 6:36 PM
  •  Jruck wrote:
    I want this to work!  What 3rd party FW allowed you to get around this?

     

    I have a linksys wrt54gs ver 2.0. I tested few FW, and by far the one that absolutely gives me no problem is tomato. As awlays, flashing FW, use at your own risk.

     

    In addtion have a look at dd-wrt. They support few brands there. Tons of features. It was too much for me, plus my wirelss clients kept on dropping.

     

    Another is openwrt

    Saturday, April 21, 2007 9:05 PM
  • I tried https: to my home server and that didnt work for me.  these sites to flash over my router seem dangerous.  I have a belkin wireless g router.  it seems changing the internal ports on the whs server would be the best.  maybe MS can put that in a later version since this will effect so many people and this is one of the selling points of this server.
    Sunday, April 22, 2007 2:10 AM
  • Yes there is a chance you can brick your router.

     

    You can change the ports. It's under IIS. Let's say your change your ssl port from 443 to 500. Then to access your WHS... https://youripaddress:500

     

     

    Sunday, April 22, 2007 3:20 AM
  • Using https worked for me.  I just didnt know it because I was out of town while trying and when I returned, found out we had lost power and the machine had shut down.

     

    Port redirection using the virtual server settiing in my Dlink DI-624 router also worked to send wan port 81 to lan port 80.

     

    I am also configured using a free account from www.no-ip.com to redirect a url to port 81 at my IP address which gets automatically updated by the no-ip local software I downloaded.

     

    Thanks to everyone's help!!!

     

    John

    Monday, April 23, 2007 1:08 AM
  • How do I change the ssl port from 443 to 500 under IIS?  Thanks.
    Saturday, November 29, 2008 8:24 PM
  • I was having the same problem and could not get my website and remote access set up on the home server. I have fios and messed with the router for hours trying to get the the domain and router configured from the home server, kept getting the error that port forwarding was not enabled, even though it was and I did it manually as well. I finally broke down and started RDP session to my server and checked out the windows firewall advanced local area connection settings. I noticed that allow http & https were not checked off. Checked the boxes, then ran the configure my router from the home server console and TADA all is well.

    Hope this helps!

    Wednesday, December 3, 2008 4:55 AM