locked
Office Communicator hangs on video call RRS feed

  • Question

  •  

     

    I have Office Communicator 2.0.63.62.0 installed on XP SP2, i have a webcam installed that seems to work fine, in Communicator when i go to Tools \ Set up Audio and Video   the mic and speakers and camera work fine and i can see the webcam working fine and it lets me adjust all the options. I can also see other Communicator contacts and make an audio call. However, whenever i make (or recieve) a video call then Communicator hangs. The Communicator program cannot be shut down from the Task Manager and i have to physically reset the PC to restart.

     

    I have turned on tracing, i have the whole tracing file but i think this is the bit (below) when i tried to recieve a video call and it crashed

     

    Any ideas ?

    Many thanks

    Alistair

     

    01/17/2008|09:23:51.639 AF0:C38 INFO  :: End of Data Received - 172.16.16.188:5061 (To Local Address: 10.1.50.141:1118) 620 bytes
    01/17/2008|09:23:51.639 AF0:C38 INFO  :: SIP_MSG_PROCESSOR::GetChallengeListForPlatform ProtocolsFromPlatform=0xf
    01/17/2008|09:23:51.639 AF0:C38 TRACE :: SIP_STACK::UpdateProviderSAContextAndSetAuthProtocol adding SA with TargetName: sip/ge-ham-ocs.germany.evotecoai.com Auth: 8 to provider at index 0
    01/17/2008|09:23:51.639 AF0:C38 TRACE :: SIP_STACK::AddSAToProvider SA addedTongue Tiedip/ge-ham-ocs.germany.evotecoai.com-000F42F0 list entry 01B78350, this 01A6F860
    01/17/2008|09:23:51.639 AF0:C38 TRACE :: SIP_STACK::FindProviderSAContext SA_CONTEXT foundTongue Tiedip/ge-ham-ocs.germany.evotecoai.com- 000F42F0, SA list entry 01B78350, this 01A6F860
    01/17/2008|09:23:51.639 AF0:C38 TRACE :: SIP_MSG_PROCESSOR::GetSAListEntry- SA not found for TargetName: sip/ge-ham-ocs.germany.evotecoai.com Auth: 8, this 01A64060
    01/17/2008|09:23:51.639 AF0:C38 WARN  :: SIP_MSG_PROCESSOR::AddSAToList cannot find SA [000F42F0] in list, inserting list entry [01B78338] into list, TargetName sip/ge-ham-ocs.germany.evotecoai.com, Auth: 8, this 01A64060
    01/17/2008|09:23:51.639 AF0:C38 TRACE :: SIP_STACK::FindProviderSAContext SA_CONTEXT foundTongue Tiedip/ge-ham-ocs.germany.evotecoai.com- 000F42F0, SA list entry 01B78350, this 01A6F860
    01/17/2008|09:23:51.639 AF0:C38 TRACE :: SIP_MSG_PROCESSOR::GetSAListEntry SA [000F42F0] targetname sip/ge-ham-ocs.germany.evotecoai.com, auth 8, this 01A64060
    01/17/2008|09:23:51.639 AF0:C38 TRACE :: SIP_STACK::FindProviderSAContext SA_CONTEXT foundTongue Tiedip/ge-ham-ocs.germany.evotecoai.com- 000F42F0, SA list entry 01B78350, this 01A6F860
    01/17/2008|09:23:51.639 AF0:C38 TRACE :: SIP_MSG_PROCESSOR::GetSAListEntry SA [000F42F0] targetname sip/ge-ham-ocs.germany.evotecoai.com, auth 8, this 01A64060
    01/17/2008|09:23:51.639 AF0:C38 TRACE :: Async work item posted for Init-SA: 0
    01/17/2008|09:23:51.718 AF0:C38 ERROR :: SIP_MSG_PROCESSOR::CompleteSAProcessingAndGetAuthHeader InitializeSecurityContext failed: 0x80090303

    01/17/2008|09:23:51.765 AF0:C38 ERROR :: SIP_MSG_PROCESSOR:SurprisenSAInitComplete - CompleteSAProcessingAndGetAuthHeader failed 80ef0191
    01/17/2008|09:23:51.812 AF0:C38 TRACE :: CUccServerEndpoint::UpdateEndpointState - Update state from 1 to 0. Status 80EF0191. Status text (null).
    01/17/2008|09:23:51.812 AF0:C38 INFO  :: Function: CUccServiceOperationManager:Big SmileisableServManager
    01/17/2008|09:23:51.812 AF0:C38 ERROR :: Condition failed with 80ee0061: 'm_fServMgrEnabled'
    01/17/2008|09:23:51.812 AF0:C38 INFO  :: Function: CUccServerEndpoint::UpdateEndpointState
    01/17/2008|09:23:51.812 AF0:C38 ERROR :: HRESULT API failed: 80ee0061 = hr. DisableServManager
    01/17/2008|09:23:51.812 AF0:C38 INFO  :: Function: CUccOperationProgressEvent::get_StatusText
    01/17/2008|09:23:51.812 AF0:C38 ERROR :: Condition failed with 00000001: 'm_swszText != 0'
    01/17/2008|09:23:51.922 AF0:C38 TRACE :: SIP_STACK::FreeProviderSAList deleting SA list entry [01B78350] with SA [000F42F0] from provider
    01/17/2008|09:23:51.922 AF0:C38 TRACE :: SIP_STACK:Big SmileeleteProviderProfile freed profile at index 0

    Friday, January 18, 2008 1:22 PM

All replies

  • Hi Alistair,

     

    Not that I am an expert but I don't really see anything out of the ordinary in the log file, those "Condition failed... m_fServMgrEnabled' errors occur often, even in my current log I see a few of them.

     

    Is MOC hanging on all the PC's in your environment when you initiate/receive a video call?  Or just the one you captured the log file on?

     

    Carlos

     

     

    Saturday, January 19, 2008 7:05 AM
  •  

    Thanks for the response Carlos, it only happens on the one PC that i captured the log file from. Other PCs using the same MOC version and webcam are fine. My PC is slightly older but meets the min spec, and it runs on a different (trusted) domain, but MOC seems fine with audio calls so i don't think it's a domain problem.

     

    Thanks for any advice

    Alistair

    Monday, January 21, 2008 11:06 AM
  • Bit more info, i managed to run an audio call ok, but during the call when i attempted to select the tools menu item from the MOC gui, it hung MOC. I'll try re-installing MOC and see if that helps :-(

     

    Thanks

    Alistair

     

    Tuesday, January 22, 2008 9:12 AM
  • If this is the only machine having an issue it does isolate the problem.  Yup, reinstalling MOC is a good option, not sure what software you are running but maybe shutting down all the processes that are not required, maybe unplug any USB devices, if that does not work maybe reinstalling the machine?  A bit of work but sometimes faster than debugging.

     

    Carlos

    Tuesday, January 22, 2008 5:24 PM