none
Strange/Inconsistent Problems with WHS Backup (backing up itself) and clr20r3 error RRS feed

  • Question

  • Hello everyone,

    I've been having an issue with my WHS box, an Acer EasyShare H340.  I've been searching the web for a similar report, but none quite fit what's been happening to me.

    I have several shares on my WHS, but I'll use two in my example.  Music, and Programs.  Both are over 100 GB, both roughly the same size, and I am trying to back them up.  To be clear, I am NOT backing up a computer over my network to my WHS (seems most backup related discussions relate to this).  I am using an attached drive to the box to back up the WHS itself.

    If I plug in one of my externals, and set it to backup just the Music share, everything goes great.  Or, if I tell it to back up both shares, the entire music share will copy fine.  But no matter how I approach it, at random portions while backing up my Programs share, the Console software will disconnect, or, moreso, it will say "Connection to server lost" if the console is running on a remote machine.  I got the smart idea of using a Remote Desktop connection to run the console locally on the box, which didn't solve the problem, but gave me a new perspective.  Instead of losing the connection, the console vanishes (crashes, I imagine), and the event log indicates that error clr20r3 has occurred with the Console software.

    As stated above, this only seems to happen when copying from one share.  If I restart the backup job, it will go through the linking process then resume copying, then a few minutes later (in extreme cases, it literally happens every 5-10GB) the console will crash again.  I'm pretty sure if I keep restarting the backup, inevitably I can hold it's hand until it's done, but it's extremely frustrating and troubling for me.

    My questions are:
    1) Has anybody had something like this happen?
    2) How does clr20r3 (a .NET error searching seeme to tell me) factor in.
    3) If there is some sort of crash happening in the console, as the error above would suggest, why is it happening everywhere/at random points in one share, but never in the other?
    4) If I need t reinstall WHS, will my shares still be there?  Because I'm having a bit of a backup issue...heh

    Thank-you in advance for any advice you can offer.
    Wednesday, January 27, 2010 5:03 AM

Answers

All replies

  • Try running chkdsk on all the drives in your server .
    I'm not on the WHS team, I just post a lot. :)
    Wednesday, January 27, 2010 1:10 PM
    Moderator
  • Ran it... I'm not 100% sure of what to look for, but it didn't find any errors or bad sectors.  Ran it to check, then also ran it with /F to fix anything.  Nothing in each case :/ (well, I mean, I guess it's good my drives don't have errors, but...).
    Thursday, January 28, 2010 6:32 AM
  • If you read the FAQ I linked, you'll see it tells you how to find reports from chkdsk in your server's event log, and the batch file provided will take care of using the correct parameters to automatically find and fix any errors.
    I'm not on the WHS team, I just post a lot. :)
    Thursday, January 28, 2010 12:49 PM
    Moderator
  • Hi wwWizard2k,

    I seem to have the exact same issue with my H340 as well.
    The external drive is a 500Gb USB drive.
    Half way, the server backup crashes in the same way as you noted above.

    I had the idea the USB was disconnecting somehow.
    I have seen this happen in other situations where the USB power is to low.
    This would break the connection for the USB drive and then in turn could 'crash' the console.
    So I applied an extra power supply, by using a Y-USB cable and connecting a second USB port.
    However, same issue.

    So I set the console to backup 1 folder and run the backup. Works oke.
    Then include a second folder and re-run the backup.
    It starts the linking process, switches to copy-ing and then randomly crashes.
    I repeated the backup over and over again and now it passes with only linking the existing files.
    So eventually it will get there, but with 10 more shares to go, this is a redicilous method.

    If you have any extra inside on this I would be very pleased to work together and see if we can fix this.
    For now I will also run a chkdsk on all my brand new drives.

    edit:
    The last line from the console log file when it crashes:

    [8]100128.213651.3281: Error: Backup percentage is -2147483648
    [11]100128.215514.7031: Error: Exception thrown
    System.ArgumentOutOfRangeException: Index was out of range. Must be non-negative and less than the size of the collection.
    Parameter name: index
       at System.ThrowHelper.ThrowArgumentOutOfRangeException(ExceptionArgument argument, ExceptionResource resource) in mscorlib.dll
       at System.ThrowHelper.ThrowArgumentOutOfRangeException() in mscorlib.dll
       at Microsoft.HomeServer.HomeServerConsoleTab.WHSInfo.HomeServerTabExtender.ListenrFTV(Object o) in HomeServerConsoleTab.WHSInfo.dll
       at System.Threading._TimerCallback.TimerCallback_Context(Object state) in mscorlib.dll
       at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state) in mscorlib.dll
       at System.Threading._TimerCallback.PerformTimerCallback(Object state) in mscorlib.dll
    Sender: Name:HomeServerConsole.exe
    There are no context policies.


    And the event id:

    Event Source: .NET Runtime 2.0 Error Reporting
    Event ID: 5000
    Computer: HOMESERVER
    Description:
    EventType clr20r3, P1 homeserverconsole.exe, P2 6.0.0.0, P3 4acceb5f, P4 whscommon, P5 6.0.0.0, P6 4accead8, P7 334, P8 1b, P9 system.argumentoutofrange, P10 NIL.


    Arno

    Thursday, January 28, 2010 8:50 PM
  • Some experementing I have done:
    - Reformattted the backup disk.
    - Ran a checkdisk on all the drives.
    - Disabled all plug-ins.
    - Removed Firefly, iTunes bonjour and WiDMV completly from the system.
    - For now and to check interference, I removed the virusscanner.
    - Connected another USB drive.
    - Tried changing aspnet.config setting (Symantec BackupExec has a same sort of issue with system.argumentoutofrange error)

    So far no result or clue.
    Anyone else got some idea's??
    Saturday, January 30, 2010 8:57 AM
  • Oke,
    So today I found a workaround on this forum:
    http://forum.home-server-blog.de/viewtopic.php?f=28&t=5478&start=30

    Basicly it has to do with the health plug-in from Acer.
    By changing a setting in the update frequenty to something beyond the time needed to do the backup we can make sure the backup passes.
    But there is a catch. By doing this the health plugin in the console will not update frequent enough to display steady data.
    I'll try to contact Acer about this and see what they can come up with.


    - Close the console
    - Open this file in notepad: %windir%\system32\whsinfo.xml.
    - Change the parameter distancetime to 10000
    - Save the file
    - Open the console and run the server backup

    With thanks to our German friends ;-)

    Arno
    Saturday, January 30, 2010 4:36 PM
  • Any luck with Acer Technical Support? I know I had none. Very Frustrating in fact.
    • Proposed as answer by rcturnock Thursday, September 9, 2010 10:00 PM
    • Unproposed as answer by kariya21Moderator Wednesday, September 15, 2010 2:29 AM
    Tuesday, May 11, 2010 1:35 AM
  • Oops, I accidentally proposed an answer.

    I solved this problem on my WHS.

    Quick answer - Firewall was off, so I turned it on

    Long answer - I tried using the computer to a VPN router although I eventually gave up. At some point I was asked if I wanted connection sharing (ICS) and I said no. But saying no to ICS disabled the firewall. After a few hours turning on the firewall instantly solved the problem. I guess they're right when they say not ot mess with the OS on WHS.

    Thursday, September 9, 2010 10:03 PM
  • Dear Arno!

     

    Your workaround works perfectly! I had exactly the sam issue with backup and crashing WHS console.

    Thanks a lot!

    Greetings from Austria,

    Werner (former MS empl.)

    Tuesday, July 12, 2011 4:12 PM
  • Arno,

    Thanks a million!  And double points for translating from the German.  :-)  I know it's been a few years, but my WHS v1 is still chugging along - except for this backup problem.

    If you (or anybody) is still monitoring this thread, do you know why the Hardware Health and Performance Monitor plugin is causing this problem?  The default refresh rate is 5 seconds, which means that no backup would ever complete in time.  The problem doesn't occur in the first 5 seconds, but later in a longer backup.  A memory leak?  Some kind of buffer overrun?  Just curious.

    Would it be just as well to stop or pause the Windows service ("Home Server System Monitor Service") while running a large backup?

    BTW, you can easily reset the HHPM refresh rate in the Settings section of the console.  Available options are 1, 5, and 10 seconds.

    Neil

    Wednesday, October 7, 2015 12:38 PM