locked
CRM Users Cannot Log In RRS feed

  • Question

  • Hi. I have created user accounts in Dynamics 4.0, but none of them can log in. They all have active directory accounts, but cannot log in to Dynamics. Is there a particular group that they have to be a part of? The only account that can log in is the administrator account.
    Thursday, January 7, 2010 2:07 PM

Answers

  • Hi, please answer some questions
    can users log on into their own machines?
    is the "change passwd at first log on" checked for the users accounts in AD?.
    regards
    • Marked as answer by ShawnHarrison Thursday, January 7, 2010 9:06 PM
    Thursday, January 7, 2010 6:50 PM

All replies

  • Hi,

    has you assigned a role to the new created user in CRM?
    Viele Grüße

    Michael Sulz
    axcentro GmbH
    MVP für Microsoft Dynamics CRM
    Thursday, January 7, 2010 2:08 PM
  • Yes. They all have assigned security roles in CRM.
    Thursday, January 7, 2010 2:13 PM
  • What error does the user receive when they try to log in?  When you add a user to CRM, the AD account automatically gets updated with the needed rights.  However, you can check the Sys Admin account in AD and compare it to the other user accounts to see if there is a difference.
    Best Regards, Donna
    Thursday, January 7, 2010 2:26 PM
  • After trying their login a few times, they get the 401 error. I started comparing the admin account and not seeing any difference. Another thing I tried was looking at the MSCRM_CONFIG database and checked the SystemUsers table. I noticed that there is an ID for all the users I have created, but the Name field is NULL for all users except the admin account.
    Thursday, January 7, 2010 2:31 PM
  • Hi, please answer some questions
    can users log on into their own machines?
    is the "change passwd at first log on" checked for the users accounts in AD?.
    regards
    • Marked as answer by ShawnHarrison Thursday, January 7, 2010 9:06 PM
    Thursday, January 7, 2010 6:50 PM
  • I'd encourage you to not attempt to make changes to the database directly - that will likely create more problems or complicate the solution.

    Open one of the newly created user records in CRM and verify that it's active and that it did receive the role assigned to it that you intended. The save the record and you can verify in the systemuser table if the name gets populated then. - (that shouldn't be the problem, but it's curious.)

    Also - are all of thes users on the same domain as CRM? - I assume so, but with a new installation, there might be some confusion as to how authentication works.


    Scott Sewell, CustomerEffective | http:\\blog.CustomerEffective.com | Twitter:@ScottSewell
    Thursday, January 7, 2010 7:29 PM
    Moderator
  • Did you add the users to CRM through the standard method provided in the application ~~> go to Settings, Business Management, Users, Add User?  If so, then ensure the users are logging into their computer using their AD user name, password and have specified the correct domain.  If users are accessing CRM remotely (not connected to the domain), then you need to configure CRM for Internet Facing Deployment.
    Best Regards, Donna
    Thursday, January 7, 2010 7:38 PM
  • Sorry for the delay in repsonse. I have been handling fires all day.

    It turns out the option to change password at first login was checked. I removed it and all is well. Thanks for all your help.

    Thursday, January 7, 2010 9:06 PM