none
Presence Unknown on Random Contacts

    Question

  • Hello All,

    I am hoping you can shed some light on an issue with are having with interaction between our OCS client and Microsoft Outlook 2007 running on both Windows XP and Windows 7.

    When we hover over a username on an email, the odd one will show as presence unknown. This does not occur on our sharepoint site (presence works as expected). After a couple of weeks searching the internet, I have tried the following:

    I have installed the new update at:

    http://support.microsoft.com/kb/978564

     

    Office Communicator Presence does not display in Office Outlook or SharePoint

    ISSUE:  Office Communicator presence is not displayed in Office Outlook or Office SharePoint.
    RESOLUTION:  Set the following registry keys to make Communicator the default application for Presence within Office applications.
    "REG_DWORD HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Common\PersonaMenu\RTCApplication=3"
    "REG_DWORD HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Common\PersonaMenu\RTCApplication=3"

    Stale Presence in Office Outlook

    ISSUE:  When a user signs out of Office Communicator, contacts in the Communicator Contact List could show presence information that is out-of-date.
    RESOLUTION:  Restart Office Communicator or restart Office Outlook.

    No Presence in Office Outlook

    ISSUE:  When a user signs out of Office Communicator, contacts in the Communicator Contact List could show presence information that is out-of-date.
    RESOLUTION:  If a user shuts down Office Communicator and navigates between e-mails within Outlook while Communicator is shutting down, Outlook may disconnect from Communicator and show no presence, even if Communicator is restarted.

    Presence Unknown for certain contacts in Office Outlook

    ISSUE:  If a user’s e-mail address, as entered into an Outlook e-mail, cannot be resolved to a SIP address in the Outlook Address Book or through Office Communicator, then presence cannot be retrieved for that user.
    RESOLUTION:  Set the SetOnlineStatusLevel registry key to allow Outlook to make a call to Microsoft Exchange to help resolve the SIP address for users. Setting this key can help particularly when the user’s Exchange address (x400/X500) is in the e-mail.
    "HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\12.0\Outlook\IM] "SetOnlineStatusLevel"=dword:00000003"

    The issue is still there. Any ideas?

    Thanks in advance,

    Paul Sanders

    Friday, April 16, 2010 12:51 PM

All replies

  • Please can a moderator move this to the correct forum? It should live in Forums Home > Office Communicator Forums >Presence .

    Thanks :)

    Friday, April 16, 2010 12:53 PM
  • I was wondering if any one can explain the below registry key and why it would work?

    [HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Common\PersonaMenu]
    "QueryServiceForStatus"=dword:00000003

    After looking on the Microsoft website, there should only be 3 options available, 0, 1 and 2. However I accidently added 3 and now the presence works. My only worry is this is a debug mode that may be causing other issues with other applications?

    Thanks

    Friday, April 16, 2010 2:58 PM
  • This is the Windows Live Writer Forum; for topics pertaining to 'Windows Live Writer'. This forum is meant to be a resource for those who are looking for more information about Writer or want to start a discussion with the Writer team and other people using Writer.

    Unfortunately, you've submitted a query to the wrong forum; but perhaps you can find the right forum(s) here.

    Reference Link(s):

      For everything Windows LIVE [apps and services]
          https://support.live.com/
          http://windowslivehelp.com/

    OR

      For General Microsoft topics...
          http://support.microsoft.com/
          http://support.microsoft.com/search/

    Hope this helps.
    • Proposed as answer by lehenryjr Friday, April 16, 2010 8:29 PM
    Friday, April 16, 2010 8:29 PM

  • Hi Lehenryjr,


    I know its the wrong forum, not quite sure how it ended up in here :S hehe. I have now reposted it in the OCS Presence forum.

    Thanks,

     

    Paul

    Saturday, April 17, 2010 8:15 AM
  • mm....I just finished one troubleshooting earlier.

    Description: all contacts shows "presence unknown"

    I read through and there was something about office com. server default size is 200, so thats not my issue as the supported user I did has only 30 contacts.

    I tried to remove the profile  by cut and paste the OCS profile to somewhere else and restart the PC and Viola!!

    1. Click Start>Run.

    2. Type %appdata% then Enter

    3. double click on Microsoft and access to OCS, move the file Profile somewhere that you can easily recall.

    4. Restart the PC and launch OCS again, VIOLA!!

    Let me know if that helps you

    Thursday, July 07, 2011 4:04 AM