locked
Client backup to WHS 2011 VERY slow RRS feed

  • Question

  • Compared to my old WHS v1, client backups to the new WHS 2011 seem to take foreever. The (not initial) backup of a client with 2x1TB hard disk ran ~24h, without much updated data. Another backup of a laptop with 500GB hard disk run ~8h. Currently there's a backup of a laptop with 750GB hard disk at 58% after ~5h. Why is the new WHS 2011 that slow? There seems to be a difference between WHS v1 and WHS 2011 in how backups are performed. The old v1 did a full scan for changed clusters of a volume, than reorganized the cluster tables on the server and finally transfered the changed clusters to the server. The new WHS 2011 seems to reorganize and transfer changed clusters not in one operation, but does split it to multiple operations/passes per volume. Sadly, the most time consuming part of the game is the reorganization on the server itself. On my system, that reorganization step takes about >30min. During that 30min, according to the procmon.exe of the sysinternals suite, data is copied within the file GlobalClusters.4096.dat, with only 8 to 25 MB/sek (sum of read + write). Read and write operations are blocks of exactly 256KB, with the flag "non-cached"(!) set. The size of GlobalClusters.4096.dat is about 36GB alone. When runnig a defrag operation on the volume containing the client backups, data is transferred at up to 200-300MB/sec. The volume is a RAID5 with 5x 2TB WD20EARS/WD20EARX on a RocketRAID 2720, stripe size is 64KB. Write caching is enabled, as the system is connected to a UPS. An clues how to improve backup performance? Why is the non-cached flag used? Why are read and write operations 256KB only? Is there a (hidden) way to tune those parameters? Can the interval, at which reorganize operations are performed, be raised? Backup to non-RAID volumes is useless, unless some sort of drive extender is available. I did not try the builtin software RAID feature of WHS2011, because it requires dynamic discs, which do not support bitlocker. Using a hw/host RAID solution does support bitlocker. Components of my WHS2011: http://skinflint.co.uk/eu/?cat=WL-108603 (only 4GB RAM, not 8GB) Server & clients do all have GBit NICs. Edit: why does that stupid forum software delete all my newlines/formatting?!?!
    • Edited by Max Rower Sunday, February 5, 2012 11:27 AM formatting
    Sunday, February 5, 2012 11:24 AM

All replies

  • Similar story here:

    • First backups are very slow, about 2-6x slower than WHSv1, with Core i7 CPU barely doing anything, under 5% on average, basically idle.
    • Only about 1.5MB/sec of bandwidth is used, from backup client to server.
    • Yet network share file transfers from SSD (on same backup client) to same disk used for PC backups on the backup server easily exceeds 70MB/sec.
    • Wondering if there's throttling going on somewhere, since I also see no obvious processes spiking or other software bottleneck signs, at client or server.
    • I noticed the recent Update Rollup 2 didn't actually touch the backup engine, and backup speeds didn't change.
    • Meanwhile, even a temporary workaround or hotfix, or even just a registry tweak or a temporary priority boost to the relevant processes would be decent options.

    It almost seems like an intentional software effort was made to minimize the impact of backups going on in the background, but that "tuning" was far to aggressive.
    The really good news is that all subsequent backups are looking to be about 4-5x faster than WHSv1. Well, so far anyway, admittedly, I won't know until about a month from now, when I get all those first backups done, totaling about ~3TB (10 PC backups).

    Meanwhile, any ideas?


    • Edited by tinkererguy Saturday, February 25, 2012 5:16 AM
    Saturday, February 25, 2012 5:01 AM
  •   I am having the same problem. Backups will start to run then after many hours they to get to a point
    somewhere about 50% where they fail to complete. Only one computer with a 125
    gig disc that doesn’t hold much data has been successful so far (it uses a Wireless-N
    Connection). None of my systems is particularly large and my network isn’t busy.
    The network has a mix of hard wired and Wireless N computers.  Last night I tried to do manual backups of 3
    systems and was successful with only one, after midnight it tried to automatically
    backup just one client system and failed after which it didn’t try to back up
    any other systems because it said the “Backup Repair Tool” needed to be run
    before it could do any more backups.

      A manual backup of my Weather Station which has 80 gig of used disc space has taken 1 hour to get
    to 18%. That is way faster than yesterday when it failed after several hours
    and only got to 49%. This system is plugged directly into the network as is the
    server. After 2 hours it got to about 30% and then failed without giving me
    enough data to use to troubleshoot the problem. (Backup did not succeed. An
    unknown error prevented backup from completing successfully.)

    Help!

      I have had to clear the backup area several times and run chkdsk –r several times (on all server drives, no errors found)
    then run the Backup Repair Tool to get to this point. I am still trying to get
    an initial backup for each of my four Windows 7 systems. So far, after 5 days of
    trying I have only successful backed up one (Non Crucial) computer.

     My old WHS 2003 machine did all of the backups for all four of my other systems in less than 4
    hours. Is it just me or was the old WHS more stable than the new WHS 2011? I
    like that it is compatible with all of my Windows 7 systems and that it can
    join my Home Group. I think it has lots of really great features but it needs to
    be reliable and a lot quicker in order to be a useful tool.

    I would be happy if I could get the server to successfully backup all of my systems just once.

      Before setting up WHS2011 I reset my router (Linksys WRT610Nv2) to clear any settings from my old WHS. On each system I
    removed all of the software associated with the old WHS and removed all of the
    Media Center settings/sharing software so that wouldn’t interfere with the new
    server setup. I have all of the current updates from Microsoft Update installed
    on the server except for one “Recommended” update, KB2468871 (Microsoft .NET
    framework 4) which won’t install no matter what I do. This update has known
    issues with its installation. One wireless system has been successful and one
    wireless system hasn’t. Both of my wired computers have been unsuccessful. So
    far the Forum’s haven been much help. Does anyone have any fresh ideas?




    Tuesday, March 13, 2012 3:07 PM
  • Just for another take on this, I had this problem (backups very slow and failing) also but managed to get past it by doing two things.

    First, I discovered a speed problem on a wired circuit between the server and one client by manually moving large amounts of data around. Turned out I had a flaky 8-port switch in the line. On replacement, the problem completely disappeared and all subsequent backups were quite fast. Make sure the network connection is at rated speed and even then, don't take them at face value. Test 'em.

    Next, on another client via the systems logs, I found VSS apparently failing to complete on a partition because of insufficient disk space. Make sure more than 10% space is available on each client partition.

    I've also read certain types of partitions won't work properly, my successful experience in WHS 2011 is only with NTFS partitions. RAID may be tricky.

    Still have one client that spits out a message I can't find any information about, as it fails. I'm at 4/5 clients working fast and well. Could be worse!

    Anyway, hope something here can help! Thanks for reading!

    Rich


    Rich

    Wednesday, March 14, 2012 1:21 AM
  • Max sorry for hijacking this thread a little bit.

    In your post you tell that you use a Highpoint RocketRaid 2720 with WD20EARX disks.

    Did you do anything special with the disks? I have exactly the same 2720 and 8 WD20EARX disks but the 2720 refuses to detect them (says No suitable disks found for all of them). I use the proper forward breakout adapter 1 mini SAS to 4x SATA (SFF-8087).

    Would you please be so kind to help me.

    Thanks a lot.

    Ken

    Thursday, March 22, 2012 7:28 AM
  • Hi there

    I have two external USB2 HDD's, connected to my Client PC.
    On my HP Media Smart Server EX490, WHS 2011 is running.

    I know that a backup of the Client PC need time, but currently it's running over 3 days non stop. This can't be normal!!!!!

    I have around 650GB to backup. What the hell is going wrong? It can't be possible that the backup needs more than 3 f..... days!!!!

    Does anyone faces the same issues?

    Thanks in advance.

    Tuesday, May 22, 2012 6:17 PM
  • I have the same problem...extremely slow client PC backup - Win7 64.  I just installed WHS 2011 and cannot get through my initial backup...I have 2 TB drives, each approximately 50% full for a total of about 2TB of data.  Yesterday I tried to do a manual backup but it failed when the automatic backup started at 1230am...I have a Gigabit network (switch and router), but my WHS system is only 100MB (older EX490 upgraded with 6400 CPU and 4GB).  This seems to be an issue for a lot of folks...
    Thursday, June 14, 2012 2:45 PM
  • If your EX 490 is only reporting a 100 Mbit connection, you have a networking issue, because the entire MediaSmart server line included gigabit Ethernet. A reported 100 Mbit connection menas that something, somewhere between your server and your router, is degrading your connection, causing Windows to step back from gigabit speeds in favor of reliability. 

    I'm not on the WHS team, I just post a lot. :)

    Thursday, June 14, 2012 5:01 PM
  • After weeks of frustration I did a little research on this and found that a few people noticed this only happened with Windows 7 64bit editions, and mentioned the 64bit connector was to blame.

    I have several computers and all are backing up fast - except this laptop, that has Windows 7 Ultimate 64bit - 1gbit connection straight to server - and when I had Vista Ultimate 64 bit it worked fine.

    I haven't really done anything about it, if I recall it would not let me install the 32bit connector, but I did not try the compatability.

    Hope this guides you in the right direction

    Monday, July 16, 2012 1:00 AM
  • See Ning Kuang's comments here:

    http://social.technet.microsoft.com/Forums/en-US/winserveressentials/thread/765a74e2-56b9-4d20-b4f8-209d7b722f5d/#a64979f4-ebb5-4b7e-a61f-d9fe5e5ac16f

    stating:
    We were able to improve the performance by increasing the data size of the disk I/O operations

    It appears they've fixed this long standing speed issue in Windows Server 2012 Essentials (initial testing I've done with the beta has gone very well, will be interested to see how things go once I get to 3TB of daily PC backups on the RTM version).



    • Edited by tinkererguy Thursday, August 2, 2012 1:30 PM
    Thursday, August 2, 2012 1:29 PM