locked
Storage pool says hard drive is missing but it's connected and is working RRS feed

  • Question

  • Recently i had some problems with the hard drives in my server so i removed them(were failing because of bad PSU, replaced it now and the remaining ones pass all tests) and put all of them into my PC. Now it's all working and i've put them back in the server again(didn't modify anything on them, couldn't even access them in Win7). Now in the dashboard it says my 2tb WD green drive is missing. The OS is installed on this drive and the drive appears in the dashboard but it isn´t connected to the storage pool somehow even though it is... there.

    To put it bluntly, this is my problem: http://img291.imageshack.us/img291/2513/whsproblem.jpg

    As you can see there, the drive appears under "Hard Drives" but the storage pool says it's missing. I've tried to plug the drive into different sata ports on my motherboard but it didn´t make any difference. When i tried to repair the storage pool i just got BSOD because of the file DEVolume.sys. Even if i try to add the drive to the storage pool it just gives me an error and says there isn't enough space on the drive.

    Does anyone know if i can fix this problem somehow or if i can access the data on the drive somehow so i can move it and format the drive ?

    Thanks in advance.

    Friday, October 8, 2010 11:05 PM

All replies

  • Please submit a bug report on Connect.
    I'm not on the WHS team, I just post a lot. :)
    Friday, October 8, 2010 11:40 PM
    Moderator
  • I'm am just curious as to whether or not a bug report was submitted for this or not, as I'm experiencing the same exact problem.

    What I did before the problem occurred was very similar. I took out all of the WHS drives, and tried moving them to another machine, hoping I could just update some drivers and move my Home Server to a new MoBo... Sadly it did not boot, but instead BSOD when loading windows.  (I figured it would, but thought it was worth a try before going through the long process of getting all of my data back off of the server, and then putting it back on again.)  I put them back into the original machine, and now my DE Disk partition on the primary drive is now "missing".

    I thought that maybe WHS Vail was just looking for the DE volumes at certain physical mount points, but I tried every possible combination of my drives to no avail.  Everything else works fine, no matter what SATA port they are plugged into.  Just the DE Disk partition on the primary drive is missing / not being mounted.  The Event Logs are full of the system error: "Filter Manager failed to attach to volume '\Device\DriveExtenderVolume5'.  This volume will be unavailable for filtering until a reboot.  The final status was 0xc000014f."  The 5 in DriveExtenderVolume is just whatever SATA port I have it on.

    I'm going to try and create a new installation of VAIL on another hard drive, and see if I can view the partition that is giving me trouble.  I'll let you know if it works, and if anybody has any better ideas please let me know!

    Thanks.

    Sunday, October 10, 2010 9:31 AM
  • I haven't submitted a bug report yet but i plan to do so. Let me know how it works out for you since we seem to be having the exact same problem.
    Sunday, October 10, 2010 11:23 PM
  • Just an update.  No luck on getting the info off of the DE Disk Partition yet.  A fresh installation of "Vail"  on a different hard drive, recognizes the old disk and mounts it, but it only mounts the ~30MB FAT32 part of the DE Disk partition.  If I only knew how WHS Vail is looking for the missing drive, I could direct it to the partition. Which should be an option the developers might want to consider adding.
    Monday, October 11, 2010 7:15 PM
  • Have you submitted a bug report?
    I'm not on the WHS team, I just post a lot. :)
    Monday, October 11, 2010 7:16 PM
    Moderator