locked
Could Not Initialize UI Subsystem - Hope Springs Eternal RRS feed

  • Question

  • I have tried all suggestions relative to this problem:

    1. Unplugged devices

    2. Burned with ImgBurn

    3. Etc.

    With the RC code I hoped that this problem would have gone away.  It has not and it appeared exactly the same place, e.g., before any actaul installation starts.

     

    My system has successfully installed Windows XP, Windows XP MCE2005, Many vista beta, Vista Home Premium and Longhorn.

     

    I have found no additional help in this forum, so decided to start yet another thread on the topic, to see if some RC help can be generated.

    Tuesday, June 12, 2007 7:56 PM

Answers

  • Don't waste your time. THe documentation clearly states RAID is not gonna work. You must use the SERVER STORAGE functions in the HOME SERVER CONSOLE.

     

    Start with one drive and setup Home server, then add drives and useing the SERVER STORAGE  FUNCTION, add the hard drives there. Works like a charm.

    Friday, January 23, 2009 12:07 AM

All replies

  • I signed up for the beta of WHS the day it was announced but sadly due to time constraints, plus the fact I didn't get the machine I had planned to use built, I was unable to play with it.  When I finally got it installed it was the CTP and only within a virtual machine (running under Virtual Server 2005 R2 SP1 [beta]) and was totally amazed that I immediately regretted not making the time to play around with it and really get involved with the beta process.

     

    That experience was enough to get me ordering new hardware which I quickly put together and went about installing the CTP on the new machine.  Immediately I was hit by this error and after spending hours re-configuring drives, DVD-reader, running memory checks, re-downloading the CTP, checking CRC's, installing off the DVD into another virtual machine and then using that DVD burn to install onto the new machine I was about ready to give up.  Today I upgraded the BIOS on the motherboard and at the first attempt the CTP of WHS installed without a glitch.

     

    Trust me, I was convinced that this was a bug in WHS and that MS had a massive problem on there hands but when I stopped and thought about it logically I realised it must be me.  There are over 100,000 beta testers of WHS so if this really was a problem they would have found it.  If it helps here is my hardware:

    • Intel Celeron 347 3.06Ghz 533/S775
    • Corsair TWINX 1GB DDR2 6400
    • Asus P5LD2VM-C S775
    • 2 x 500G Seagate SATA2 ST3500630AS
    • Aspire uATX case 420W XQPack
    • Pioneer DVR112DB x18 BLACK

    Remember that you are using WinPE 2.0 (which I know Vista uses and you have said this installs) but its also built on Windows 2003 Server which is totally different to a client operating system.  Please look again at your setup, try the media in a virual machine if you can to totally erradicate any hardware conflicts, update your computers BIOS if there is one and maybe as a last resort try a different DVD reader.

     

    I'd read all the threads about this error and I strongly believe this isn't a bug in the WHS software.  You also need to remember that WHS is aimed at very basic setups, no RAID (WHS is designed to provide data duplication within the OS), no top of the range chipsets, just nice cheap bare bones hardware to keep the costs down to encourage take-up.  I do hope you overcome the issue with your hardware.  Good luck.

    Tuesday, June 12, 2007 8:57 PM
  • I agree it must be some kind of user side problem ... however, if there are so many having this user side problem, surely there is some kind of conflict.

     

    Don't go telling me that this is intended to be a new release for "DUMMY" users when there are so many people here who can't get it to work.  I am pretty technical and can do pretty much most things, hardware and software related.  DUMMY's are simply not going to go around upgrading their BIOS, they will just take the software back to the place they bought it and buy something else.  If this is supposed to work on the most basic of machines, why is it so fussy!!??  Surely it should work first time every time no matter what hardware or dvd drive etc is being used!!!  Come on guys ... there must be a sensible logical explanation for this.

     

    Like the user who posted above, I have never had an issue installing XP or anything else on this machine.  It has been 100% and has never ever even blue-screened me or crashed ... an ultra solid desktop, yet, I am struggling to get passed the Could not initialist UI error.

     

    My 2c worth

    Cheers

    Sulley

    Wednesday, June 13, 2007 4:27 AM
  • I think you need to keep in mind that technical people like us will build machines for WHS but the majority of people, especially the ones this is aimed at, will be buying OEM kit with WHS pre-installed.  WHS, as I understand things, isn't exactly designed like XP, Vista, etc, in that they expect a fairly limited exposure to different hardware.  In my experience this error was resolved by a BIOS upgrade and if technical people are hitting this issue then they should have no problems troubleshooting it.  Building your own systems is hard work sometimes, but its a great achievement to have done it which is why so many of us try.

     

    Good luck with installing the WHS.  You might try installing into a VM and then using Ghost, Drive Image, or the Achronis one (can't remember the name) to then clone the install and then restore onto your main box.  You might have to go through some hardware detection but it could work.  Just remember that the reason you couldn't do a simple install will be waiting to bite you at some point.

    Wednesday, June 13, 2007 7:01 AM
  • Want to report the same error and how I got around it. Here is my setup:

     

    HW: Stock Dell Dimension N520 (same as E520 but without an OS). All fmw upgraded to the latest and greatest off Dell site (bios is dated as end of March). Bios settings were all default. HD and DVDRom are SATA - HD on 0 and DVD on 1. The rest is not occupied. Video is Intell onboard. As I said - stock configuration.

    Previously installed Win 2K3 w/SP1 and Vista without a single hitch.

    On a WHS install would receive "Could Not Initialize UI Subsystem" on 5th bar.

     

    Resolved by going into BIOS and setting SATA raid operation from ON (default setting) to AUTO/ATA. WHS Install proceeded as advertised Smile

     

    So I guess WHS and RAID do not like each other. Once install is finished - I am planing to try to make RAID work.

    Thursday, June 14, 2007 9:04 PM
  • I can confirm the same as above.  I have just went through this very issue and it's RAID and always RAID......Vista wouldn't run without RAID yet, WHS wouldn't run with it.  Funny.

     

    Thursday, July 24, 2008 12:26 AM
  • Don't waste your time. THe documentation clearly states RAID is not gonna work. You must use the SERVER STORAGE functions in the HOME SERVER CONSOLE.

     

    Start with one drive and setup Home server, then add drives and useing the SERVER STORAGE  FUNCTION, add the hard drives there. Works like a charm.

    Friday, January 23, 2009 12:07 AM
  • Solution: 

    There are a lot of systems out there where the special, "friendly" installer for Windows home server will crash before it even gets to an option to install drivers.  Yes, I was able to get it to run ok by setting my disk configuartion to AHCI isntead of RAID, but there is no excuse for not supporting RAID on a server system, when it works fine on Client machines.  Bad Microsoft, bad!

    Here is how you get around this.  We are going to bypass the "friendly" installer, and go straight to the real Server 2003 installer. 

    Using a working computer (not the WHS one),   Copy the Server2003 folder on your WHS DVD to your computer's hard drive.  Download Nlite from their website www.nliteos.com which is a free tool for customizing your windows installation. 

    Run Nlite and tell it to use the folder you copied in the last step as it's source. 

    Don't import any sessions, click next. 

    Choose options 3 and 8 which are "Drivers" and "Bootable ISO".  Click next

    Click "insert" and point it to the raid driver for system.  These shoudl be on your motherboard CD and have a file called txtsetup.oem.  If your driver folder does not have a txtsetup.oem file, you need to extract the driver (perhaps using 7zip) or use the "make a floppy" utility from your RAID card manufacturer.  There is a great virtual floppy drive program that will let you do this without a real floppy drive.  I used Virtual floppy drive 2.1 as obtained from softpedia. 

    Once your drivers are done, click next and burn the CD or save the iso file for later burning.  Use this cd to boot your new WHS box and it will load, see your drives in their RAID configuration, and no more blue screens!  You do not need to press f6 because the drivers are already embedded into the setup files.

    Monday, January 26, 2009 9:51 PM