locked
Automatic configuration problem when using Microsoft.Crm.Client.Config RRS feed

  • Question

  • Greetings,

    after a long research I found a possible way to automagically configure my clients for my CRM-Deployment. It seem´s, the following command should do the trick:

    Microsoft.Crm.Client.Config /Q /config \\crm\crmconfigxml$\client.xml /l h:\CRM_%username%_install.log 
    

     

     The content ofthe client.xml looks like this:

     

    <?xml version="1.0" encoding="utf-8"?>
    <CRMConfiguration>
      <Client>
        <ServerUrl Type="OnPremise" ShowUser="True">http://crm</ServerUrl>
        <ExtranetServerUrl>http://crm</ExtranetServerUrl>
        <Organization>MyOrganisation</Organization>
        <CEIP option="False" />
       </Client>
    </CRMConfiguration>
    

     

    When I run the command, nothing happens (as wanted because of /Q), but the installation fails. The Log-file tells me the following:

    17:44:37|   Info| === Managed setup logging started: 03.01.2012 17:44:37 ===
    17:44:38|Verbose| Method entry: Microsoft.Crm.Config.Client.ClientConfig.Initialize
    17:44:38|Verbose| Method entry: Microsoft.Crm.Setup.Common.SetupBase.Initialize
    17:44:38|Verbose| Method exit: Microsoft.Crm.Setup.Common.SetupBase.Initialize
    17:44:38|Verbose| Method exit: Microsoft.Crm.Config.Client.ClientConfig.Initialize
    17:44:38|Verbose| Method entry: Microsoft.Crm.Config.Client.ClientConfig.Run
    17:44:38|Verbose| Method entry: Microsoft.Crm.Setup.Common.SetupBase.Run
    17:44:38|Verbose| Method exit: Microsoft.Crm.Setup.Common.SetupBase.Run
    17:44:38|Verbose| Installing version component: C:\Program Files (x86)\Microsoft Dynamics CRM\Client\ConfigWizard\..\bin\crmverclient.dll
    17:44:38|Verbose| Installing version: 4.0.7333.3
    17:44:38|Verbose| Installing lcid: 1033
    17:44:38|Verbose| Existing version: 4.0.7333.3
    17:44:38|Verbose| Existing lcid: 1033
    17:44:40|   Info| No change to server URL or organization.  Setting ConfigType.Refresh.
    17:44:40|  Error| Microsoft.Crm.Setup.Common.SetupException: Data ConfigInfo.SqlServerName is not available.
       bei Microsoft.Crm.Setup.Common.PropertyBag.GetPropertyValue(String propertyName)
       bei Microsoft.Crm.Config.Common.ConfigInfo.get_SqlServerName()
       bei Microsoft.Crm.Config.Common.DatabaseInstaller.DoesDatabaseQualifyForReuse(ConfigInfo configInfo, String databaseName, Version& databaseVersion)
       bei Microsoft.Crm.Config.Client.DatabaseInstaller.IsDatabaseAvailableForReuse(ConfigInfo configInfo, Version& databaseVersionFound)
       bei Microsoft.Crm.Config.Client.ClientConfig.GetCorrectCreateDatabaseFlag(ClientConfigInfo configInfo)
       bei Microsoft.Crm.Config.Client.ClientConfig.SetSilentConfigurationSettings(IDictionary data)
       bei Microsoft.Crm.Config.Client.ClientConfig.Run()
       bei Microsoft.Crm.Config.Client.ClientConfig.Main(String[] e), Error, OK, Option1
    17:44:40|   Info| InputResult: NoInput
    17:44:40|Verbose| Method entry: Microsoft.Crm.Config.Client.ClientConfig.Terminate
    17:44:40|   Info| Exit code: Default
    17:44:40|Verbose| Method exit: Microsoft.Crm.Config.Client.ClientConfig.Terminate
    17:44:40|   Info| === Managed setup logging stopped: 03.01.2012 17:44:40 ===

     


    I´m not shure what to change in the xml, can someone point me to the error?

     

    Additionally, I´ve set a GPO to configure Outlook 2010 automatically (by primary SMTP-Adress). This combination seems to make problems too.

    I´d highly appreciate if somebody could show me a way to configure Outlook 2010 AND CRM (4.0) plugin (just online) automatically.

    Regards

    Johannes



    //Edit: I tried to run the command by hand after let Outlook create the profile automatically. didn´t work either.
    Tuesday, January 3, 2012 4:58 PM

All replies

  • Try adding the INSTALLLEVEL=2 parameter after your command. This is the parameter to install the online client (meaning the Outlook client that must have a connection to CRM, not able to go offline).

    (See here: http://msdn.microsoft.com/en-us/library/dd979402.aspx)

    Microsoft.Crm.Client.Config /Q /config \\crm\crmconfigxml$\client.xml /l h:\CRM_%username%_install.log INSTALLLEVEL=2


    Matt Wittemann, MVP for CRM (http://icu-mscrm.blogspot.com)
    Wednesday, January 4, 2012 3:47 AM
    Moderator
  • Hi Matt,

    the switch INSTALLLEVEL is for the initial installation of the application, but not for the configuration.
    As CRM 4.0 is already installed on my RDSH Server, I just need to configure it.

    Maybe you have some other hints?

    Regards
    Johannes 

    Wednesday, January 4, 2012 9:37 AM
  • Maybe it´s just me, but the lack of information regarding this (not just here in the forums, in generell) colors me skeptik. I cannot believe that bigger rollouts force their users to configure it by themselves? I know about customers with more than 200 users, I cannot believe there is no automatic configuration like in my case?
    Tuesday, January 10, 2012 8:43 AM
  • Hi All,

    Is there anyway to unconfigure the CRM 4 outlook client with xml or something?

    Currently using the C:\Program Files\Microsoft Dynamics CRM\Client\ConfigWizard>Microsoft.Crm.Client.Config.exe /Q /config "C:\CRMConfigLog\CRM_Client_Config.xml" /l "C:\CRMConfigLog\ClientConfigLog.txt" to configure the CRM Outlook Client.

    CRM_Client_Config.xml

    <?xml version="1.0" encoding="utf-8"?>
    <CRMConfiguration>
      <Client>
       <ServerUrl Type="OnPremise" ShowUser="false">http://serverurl</ServerUrl>
       <Organization>ORG</Organization>
       <CEIP optin="false" />
       <Database Reuseexisting="false" />   
      </Client>
    </CRMConfiguration>

    Regards

    Sunday, April 8, 2012 10:55 AM
  • Friday, May 4, 2012 7:26 AM
  • Maybe it´s just me, but the lack of information regarding this (not just here in the forums, in generell) colors me skeptik. I cannot believe that bigger rollouts force their users to configure it by themselves? I know about customers with more than 200 users, I cannot believe there is no automatic configuration like in my case?

    Did you make it work?

    I just had the same problem, it's working now from a command promt with:


    "C:\CRM\SetupClient.exe" /Q /L "c:\clientinstalllog.txt" /targetdir "c:\programmer\Microsoft Dynamics CRM" INSTALLLEVEL=2

    "C:\Program Files\Microsoft Dynamics CRM\Client\ConfigWizard\Microsoft.Crm.Client.Config.exe" /Q /config "C:\CRM\Client_Config.xml" /l c:\config.log


    the .xml file look like this:

    <?xml version="1.0" encoding="utf-8"?>
    <CRMConfiguration>
      <Client>
        <ServerUrl Type="OnPremise" ShowUser="True">http://servername</ServerUrl>
            <Organization>companyname</Organization>
            <CEIP option="False" />
        <Database Reuseexisting="False"/>
      </Client>
    </CRMConfiguration>

    Thursday, February 21, 2013 3:33 PM