locked
Routine backup conflicts with workstation usage RRS feed

  • Question

  • My WHS is on all the time and the back-up schedule is the default schedule.  Also the option to wake computers for backup is checked. My main PC is an Intel i7 940 with 6 GB RAM and two 500 GB HDD that is left on overnight.

    With the software having available plenty of time to conduct a backup, it only starts a backup procedure when I am actively using the system and many times while I am performing a procedure that requires lots of computers resources like creating a vacation movie from many clips in *.mod format created files to a single *.mpeg file or worse while building a DVD for display on the entertaiment system.  

    Doesn't this software have any logic built-in that recognizes the PC is busy and should try while it is idle?

    I have other PC's on this system several that are only used on certain occasions.  And most likely used during the day only.  So they are off most of the time.  Therefore, they required backingup during the normat 8:00 AM to 8:00 PM time period.

    Any suggestions on how to improve this bothersome problem will be appreciated.  I usually cancel the backup and let it try another day.  Which could  result in losing some important file for lack of backup.

     

     

    Friday, July 2, 2010 2:35 PM

All replies

  • My WHS is on all the time and the back-up schedule is the default schedule.  Also the option to wake computers for backup is checked. My main PC is an Intel i7 940 with 6 GB RAM and two 500 GB HDD that is left on overnight.

    With the software having available plenty of time to conduct a backup, it only starts a backup procedure when I am actively using the system and many times while I am performing a procedure that requires lots of computers resources like creating a vacation movie from many clips in *.mod format created files to a single *.mpeg file or worse while building a DVD for display on the entertaiment system.  

    Doesn't this software have any logic built-in that recognizes the PC is busy and should try while it is idle? 

    No.

    I have other PC's on this system several that are only used on certain occasions.  And most likely used during the day only.  So they are off most of the time.  Therefore, they required backingup during the normat 8:00 AM to 8:00 PM time period.

    Any suggestions on how to improve this bothersome problem will be appreciated.  I usually cancel the backup and let it try another day.  Which could  result in losing some important file for lack of backup.

    You can either A) move your backup window to a different window (perhaps shorten it to "force" it to start at a different time) or B) run a manual backup at your discretion.

    Friday, July 2, 2010 3:57 PM
    Moderator
  • I hope you are not getting credit for answering this question because you did not.  Perhaps you can recommend a patch to the software developers to insert logic to test for CPU usage and if it is more than 80% utilized do not back up now, wait and try again later.
    Friday, July 2, 2010 7:03 PM
  • I hope you are not getting credit for answering this question because you did not.  Perhaps you can recommend a patch to the software developers to insert logic to test for CPU usage and if it is more than 80% utilized do not back up now, wait and try again later.


    Kariya21 actually answered the question you asked, which is whether there's any logic that will detect that a computer is "in use". No, there isn't. What you really wanted was to suggest taht something like that be added. For that, please submit product suggestions on Connect. :)

    That said, your original post is somewhat confusing. In one place you refer to the default backup schedule, in another you refer to an 8:00 AM to 8:00 PM schedule. The default schedule is midnight to 6:00 AM, so what is the actual schedule on your server? Your suggestion to check for CPU usage is simplistic and unlikely to produce the desired result (only back up if a human isn't using the computer) since there are many processes running on your computer, some of which will consume as much CPU as they can. (Windows Search will do that, for example.)

    There are workarounds for your issue. The simplest is to simply cancel a backup that starts while you're using your computer, and don't worry about the missed backup. That's what you're doing now. Or you could configure a scheduled task that would trigger a backup at a time of your choosing, or just put a batch file on your desktop to do so, then set your backup window to a time the computer is normally off. Also, please note that a workaround is intended to "work around" a perceived problem. It's not a complete solution, just a less-inconvenient way to deal with the issue.

     


    I'm not on the WHS team, I just post a lot. :)
    Friday, July 2, 2010 8:00 PM
    Moderator
  • Ken:

    You seem to have a reading comprehension problem.  My original comment clearly says that I allow the WHS to be able to backup anytime in the 24 hours.  I use my main computer between 8:00 AM to 8:00 PM so I could easily prevent the WHS from performing backups during that time.  Except that some of our computers, I have 3 other PC's and a laptop, that are not used everyday, so they are usually turn off.  And when they are on it is useally between during the day hours (you know, 8:00 AM to 8:00 PM). 

    Besides, hasn't anybody expirenced this problem before?  This should have been addressed a long time ago.  Mr. Warren you seem to be interested in demonstrating your knowledge of the software by answering other peoples questions, did you ever have the WHS interrupt your work by starting a backup?  You at the very least should have noticed this and made this suggestion yourself a long time ago.  But since you did not, please  go ahead and take my suggestion, put your name on it and send it to whom you wish.

     

     

    Saturday, July 3, 2010 12:17 AM
  • No, I don't have a reading comprehension problem. From your original post:

    "My WHS is on all the time and the backup schedule is the default schedule. ..."

    And later in that same post:

    "... Therefore, they required backingup during the normat 8:00 AM to 8:00 PM time period. ..."

    Nowhere in your original post did you state that your backup window was all day, or 24 hours. Thus my confusion. In one place you're asserting you have the default window (midnight to 6:00 AM), in another it appears you have a non-default 8:00 AM to 8:00 PM window, and neither is actually true.

    Backups don't interfere with my use of my computers; my server is set to use the default window, my computers are configured to wake for backups, and they're placed in hibernation if they'll be used again soon, so they wake and back up successfully at times that don't interfere with my use of them, or my family's. If a computer won't be used for several days, it gets shut down. (No need to back it up if nothing is changing.)

    Now that I know what your backup schedule is actually set to, it's a combination of your backup schedule and the way you use your computers that's causing your issue. I recommend you do as I've done: set your computers to hibernate, set the connector to wake them for backups, and set your server back to the default midnight to 6:00 AM window. Your computers should wake, back up, and go back into hibernation.

     


    I'm not on the WHS team, I just post a lot. :)
    Saturday, July 3, 2010 3:11 AM
    Moderator
  • My experience is, that differential backups don't take a very long time and are not a real burden for a mediocre PC with enough RAM.

    This depends from how many data is changed daily (if you defragment your disk daily, you may experience a large increase of backup time), which OS is installed (XP usually takes less than 10 minutes in an office scenario), which bandwidth your network connection has (Gigabit is recommended and should be supported by each member of the chain - server, client, switch, cabling).

    Misconfigurations of the network drivers can also come into the play - which copy speed you see, if you copy a large file to a shared folder on the home server?

    Best greetings from Germany
    Olaf

    Saturday, July 3, 2010 11:52 AM
    Moderator
  • Olaf:

    Thank you for your response, please note that my computer as I described in my original post has decent performance capabilities.  My Os is Windows 7 Ultimate.  My router is a Linksys WRT320N which also has gigabits.  And I use Diskeeper 2009 for keeping the HDD defragmented.  The problem I have noticed is not in the transfer time, but in the preliminary scan the system performs to determine which clusters in my hard drives have changed.   When the backup starts there is a flurry of activity in my workstation.   But this is not the issue what people has fail to notice in my original post is that I have checked the option to “Wake this computer for backup” and that is not happening.   If it did, it would be backing up the system while I sleep, or having a meal which would be plenty of time to complete the most complicated backup.

     

    My wife and I recently went to Europe on vacation.  She took lots of movies on her JVC camcorder which has a 30 GB HDD and I took about 700 digital photos in about 21 cities.  I used Microsoft Movie Maker to edit compile and merge photos with music tracks of the country.  I also used Cyberlink PowerDirector to compile, edit and create movies from the video clips taken with the camcorder.   The output of both of those was used in Nero to create DVD’s to create and burn the discs.

     

    Because I am using two 500 GB hard drives those programs are reading data, creating temp files and writing output to both drives.  But you have to agree that when I am creating a DVD and a backup starts, even with a CPU with 4 processing cores and HT,  the work gets frustrating.

     

    By the way I am glad to hear that Ken knows about “hibernation” because that process uses my “simple minded” idea to recognize that the system is idle and they can shut down the monitor, the hard drives, etc.  But his suggestion to wake up the laptop from hibernation makes me wonder how the computer is going to open the laptop lid to wake up from hibernation.

     

    Thank you ALL of you for your assistance, but please do not respond to this post any longer because I will not be monitoring it.  Maybe WHS v2 will perform this task more efficiently, there is always hope.

     

    Saturday, July 3, 2010 3:18 PM
  • Hello Luis,  my answers are inline with yours

    On 7/3/2010 10:18 AM, Luis wrote:
    Olaf:
    
    Thank you for your response, please note that my computer as I described in my original post has decent performance capabilities. My Os is Windows 7 Ultimate.  My router is a Linksys WRT320N which also has gigabits.  And I use Diskeeper 2009 for keeping the HDD defragmented. The problem I have noticed is not in the transfer time, but in the preliminary scan the system performs to determine which clusters in my hard drives have changed.  When the backup starts there is a flurry of activity in my workstation.   But this is not the issue what people has fail to notice in my original post is that I have checked the option to “Wake this computer for backup” and that is not happening.  If it did, it would be backing up the system while I sleep, or having a meal which would be plenty of time to complete the most complicated backup.
    
    

    Most likely the reason that you're not seeing them woke up at night to back them up is they're powered off.  I'm getting that from this:

    I have other PC's on this system several that are only used on certain occasions.  And most likely used during the day only.  So they are off most of the time.  Therefore, they required backingup during the normat 8:00 AM to 8:00 PM time period.
    

    in your original post.  You said "So they are off most of the time."  Assuming that my interpretation is correct, you should either put them in standby, sleep, or hibernation instead of shutting them down.  If you have them in standby, sleep, or hibernation, then on the computers that are not backing up, you should go into their device manager, and make sure that the network cards are set to allow for Wake On Lan.  (You may want to use the Help feature to find all of the configurations that you'll need to do such as Power Management Options).

     
    
    My wife and I recently went to Europe on vacation. She took lots of movies on her JVC camcorder which has a 30 GB HDD and I took about 700 digital photos in about 21 cities. I used Microsoft Movie Maker to edit compile and merge photos with music tracks of the country. I also used Cyberlink PowerDirector to compile, edit and create movies from the video clips taken with the camcorder.  The output of both of those was used in Nero to create DVD’s to create and burn the discs.
    
     
    
    Because I am using two 500 GB hard drives those programs are reading data, creating temp files and writing output to both drives. But you have to agree that when I am creating a DVD and a backup starts, even with a CPU with 4 processing cores and HT, the work gets frustrating.
    
     
    

    In reality, if this happens (and you're not able to fix it by leaving the computers on at night or enabling Wake On Lan on them), your only real option is to cancel the backup, and do a manual backup when you're finished with the intensive processing.

    By the way I am glad to hear that Ken knows about “hibernation” because that process uses my “simple minded” idea to recognize that the system is idle and they can shut down the monitor, the hard drives, etc. But his suggestion to wake up the laptop from hibernation makes me wonder how the computer is going to open the laptop lid to wake up from hibernation.
    
     
    

    Configure the computer to hibernate without having to close the lid.  Or manually put it into hibernation through the Start Menu--> Shutdown--> Hibernate option.  Plus, Wake On LAN should wake it up regardless of whether the lid is closed or not (which is why you NEVER hibernate the laptop and put it into a case, if you have Wake On LAN turned on).  All closing the lid does is activate a trigger.  You can set it to do whatever you want (I've set it to do nothing on occasion, when I was listening to music on the laptop through external speakers).

    Thank you ALL of you for your assistance, but please do not respond to this post any longer because I will not be monitoring it.  Maybe WHS v2 will perform this task more efficiently, there is always hope.
    
     
    
    

    Sorry, I missed this portion before I started responding.  However, I will still post, because someone else may be looking for similar answers, and may find these useful (even if you're choosing not to try and solve the issue anymore).

    Have a great day:)
    Patrick.

    -- 
    Smile... Someone out there cares deeply for you.
    Have you updated today?
    http://update.microsoft.com

    Smile.. Someone out there cares deeply for you.
    Saturday, July 3, 2010 5:31 PM
  • Diskkeeper may well be the culprit.

    By rearranging the clusters on the disk it makes changes, which do require validation of each relocated cluster with existing stuff in the backup database, therefore increasing the time needed for the check, even if only a low amount of data has been changed.

    Best greetings from Germany
    Olaf

    Tuesday, July 6, 2010 7:54 PM
    Moderator
  • ... Wake On LAN ...

    Windows Home Server doesn't use Wake on LAN for anything. Client computers wake themselves up, with a hidden scheduled task that wakes the computer using a hardware timer. There are third party add-ins that add some level of Wake on LAN capability to Windows Home Server, and some OEMs may have added those capabilities as well, but WoL isn't part of the core product.


    I'm not on the WHS team, I just post a lot. :)
    Tuesday, July 6, 2010 8:30 PM
    Moderator