locked
Saving files from client PCs to my WHS 2011 is very slow RRS feed

  • Question

  • Hello Forum

    I have WHS 2011 running in my home network.  I have 3 PCs running Win7 on the same network.  On each PC I have added a folder to the Documents Library which points to a folder on the home server.  Each PC has 4 users.  The home server has the same 4 users with user folders set up for each user's Documents.  When a user goes to save a document in their document library on the PC they have to option to save it to the local folder or to the home server folder.  Both of these Library locations show up in the file open and file save dialog boxes.  In this way any user can work on their documents from any PC and save them to the home server rather than locally.

    Opening a word doc on a PC that was saved to the home server takes over 30 secs.
    Opening the same word doc on a PC that was saved locally is instantaneous. 
    Saving the same word doc from a PC to the home server takes over 30 secs. 
    Saving the same work doc to the PC locally is instantaneous. 

    Why is it so slow to open and save to the home server.

    If I try and copy the same word doc from the PC to the home server it is instantaneous so the problem is not network related.  I can copy much larger files over the network in much quicker time. 

    Also when saving the word doc from the PC to the Library on the home server a dialog appears saying "Save As \\home-server\......doc"  It shouldnt be saying "Save As" because I opened the document from the home server.  It should just be "Save", not "Save As"

    Any help on this would be appreciated.  Maybe I have not set something up properly.

    Regards

    Davros66

    Saturday, March 3, 2012 2:53 AM

All replies

  • I had a similar issue myself and it was my 3rd party Firewall, I just set all my local clients and server "Trust Level" to "Full Trust" and all was well. I left my router at the default setting "Shared" to keep the bad guys out.

    Not sure about the Library,  don't use it much I just Map my Network Drives.

    Good Luck

    Sunday, March 4, 2012 5:47 AM
  • thanks for your response mikmock.  I have ZoneAlarm firewall and I have just tested your theory by turning it off temporarily.  There was no change to the performance of opening and saving a file that resides on the WHS from the client PC using MS Word.  I also tried mapping a network drive and used MS Word to open a document that resides on the server using the mapped network drive.  The document took just as long to open and to save as it did using the Windows Document Libraries.  As I mentioned before I can copy the file to and from the WHS using the file system very fast.  It is only when I use MS Word or even Notepad that it takes much longer to save and open the files that reside on the WHS from a client PC.

    My family are not as computer savvy as me and so I want to make it as easy as possible for them to work on the client PCs and save their files on the WHS.  They will find it difficult to save locally and then copy to the WHS which will end up with two copies of the file unless they clean up the local copy after copying.

    Wednesday, March 7, 2012 11:55 AM
  • I wondered whether it was just MS Word that was making it so slow to save and open documents from the client PC that exist on the home server.  So I tried with Notepad to open a txt file that resides on the server from the client PC.  Even Notepad is very slow to open and save a very small txt file. 

    These are my steps.

    1. Open Notepad
    2. Browse to the file that exists on the home server using the My Documents Library (because I have added a shared folder on the server to the My Documents Library on the PC)
    3. Edit the txt file (very small txt file)
    4. Press save (to the home server)
    5. Wait for 20 -30 seconds for the txt file to save

    Second method

    1. Open Notepad
    2. Browse to the file that exists on the home server using a mapped drive (that I prepared earlier)
    3. Edit the txt file
    4. Press save (to the home server)
    5. Wait for 20-30 seconds for the txt file to save

    As described in original post, I dont think it is network speed alone that is the problem because I can copy much larger files to a from the home server in Windows Explorer in very fast (normal) time.

    What am I doing wrong?  Why is it so slow to edit files that reside on the home server from the client PC????

    Friday, March 9, 2012 12:14 AM
  • Try it from PC A to PC B. Accessing a file across a network is slower than a local file, but it shouldn't be as much slower as you're describing.

    I'm not on the WHS team, I just post a lot. :)

    Friday, March 9, 2012 12:35 AM
  • Thanks for the good idea Ken.  Opening and saving a file from PC A to PC B is as fast as I would expect.  Practically instantaneous. On my WHS I have shadow copies turned off on my shared folders.  But I have hard disk Mirroring set up.  I dont think this is the issue though because as I described earlier, I can copy files from any PC to the home server in normal very fast time.  It seems Windows Explorer can write files in normal speed but other applications like MS Word and Notepad have much more difficulty writing files to the home server and reading files from the home server


    • Edited by davros66 Tuesday, March 13, 2012 12:23 PM
    Tuesday, March 13, 2012 10:42 AM
  • I have more information and I am still looking for more feedback on this issue.

    I turned off hard disk Mirroring on the home server to see if it had any impact and it did not make any difference.  I am going to set up some performance counters on both the client pc and the home server while opening up a document and saving the document to see if this sheds any light on the issue.

    Sunday, March 18, 2012 3:06 AM
  • I have been researching this issue for weeks now and finally came up with a solution that worked for us:

    Start -> Run -> type regedit and hit enter -> HKLM -> System -> CurrentControlSet -> Services -> LanmanServer -> Parameter

    Right click and select new -> DWORD -> This adds a "REG_DWORD" entry.  Name the entry "Smb2" with a value of 0

    MAKE SURE YOU REBOOT AFTER and it should be working as it did for us.  One other thing I ended up having to do is use "net use" to ensure all my network drives were disconnected.  Then I simply added it back.  On some machines I had to use the FQDN to reach the share but otherwise it works flawlessly

    Enjoy :-)

    • Proposed as answer by FrankieFish1 Wednesday, April 4, 2012 7:53 PM
    Wednesday, April 4, 2012 7:53 PM
  • I assume you've done this on your server? Turning off SMB 2.0 on your server can improve performance in some circumstances, where the client computers are running a version of Windows earlier than Vista, but all versions of Windows from Vista on support SMB 2.0, so it should have no effect or a negative effect (i.e. worse performance, up to 2x) on those operating systems.

    If folks having transfer speed issues want to experiment with this, I would recommend reading e.g. this blog pos t, which has some detail on what's going on.


    I'm not on the WHS team, I just post a lot. :)

    Wednesday, April 4, 2012 8:26 PM
  • Hi ken,

    Thanks for the response, I can't really give you many details about our system, but this task was completed on a Windows 7 machine.  For a general background it was running WinXP at first, then moved to Win7.  We could transfer a 150MB file in under 20 seconds but when it came to saving a document to the share while open we were dead in the water...would take about 45 seconds to save then become non-responsive, leaving it alone it would come back saved after about 2 minutes.  This solved our problem.  I also conducted the same tests on two other Win7 machines.

    Wednesday, April 4, 2012 8:47 PM
  • I think you just validated Ken's comment about OS's earlier than Vista. You said the Box was running XP but moved to Win7. Did you upgrade to win7 or do a complete format and re-install. An upgrade would give you the the Win7 front end but you'd be saddled with legacy XP stuff
    Tuesday, April 10, 2012 12:41 PM
  • My apologies, our machine was indeed originally WinXP without any issues as far as the network share was concerned.  The upgrade was a clean wipe of WinXP and a clean Win7 install.  The box had its HDD formatted and several passes were made due to sensitivity of information.  Win7 was then installed onto the machine.  I agree with Ken, this isn't the result I was expecting.
    Tuesday, April 10, 2012 6:14 PM