locked
renew oncare subscription RRS feed

  • Question

  • I have a current onecare subscription ending soon.
    I purchased it here in singapore, and it's been working fine, now I am asked to renew my sub.
    when I press the renew button I am redirected to a site where I input my credit card details, but on this page the country is fixed to United states and I can't change it,
    I suspect that this is causing the validation of a singapore based credit card to fail, so I am never really going as far as doing the payment....

    I have very few days left on my subscription and depend on onecare for a lot of things...

    how do I renew my my subscription?

    thanks,
    pv
    Saturday, February 28, 2009 2:52 AM

Answers

  • The website gets your default location from your browser settings. English ( Singapore ) is an option on my computers. What version of Internet Explorer and what operating system are you using? Since you are nearing the end of your subscription send an e-mail with One Care in the subject line to jrap107@msn.com and I will send you contact information for local One Care support.
    Jim
    Saturday, February 28, 2009 12:55 PM
    Moderator

All replies

  • Hello p_velay, you can purchase and renew One Care in Singapore. You just have to localize Internet Explorer. To do this open Internet Explorer>Tools>Internet Options>General>Languages>Add, and add English ( Singapore ). You should then be able to renew.
    Jim
    Saturday, February 28, 2009 3:25 AM
    Moderator
  • there is no such choice as English (singapore), so I tried to change the config of windows adding ma location to be  singapore, same result, I also changed my setting for my live account, it is singapore, so I am not sure where the web site gets the default to US, but I still can't change to singapore,
    My credit card won't work until the country matches the cards country of issuance.

    any ideas?
    thanks,
    pv
    Saturday, February 28, 2009 8:09 AM
  • The website gets your default location from your browser settings. English ( Singapore ) is an option on my computers. What version of Internet Explorer and what operating system are you using? Since you are nearing the end of your subscription send an e-mail with One Care in the subject line to jrap107@msn.com and I will send you contact information for local One Care support.
    Jim
    Saturday, February 28, 2009 12:55 PM
    Moderator
  • I use windows XP, and I don't have English (Singapore),
    how do I get it?

    thanks,
    pv
    Sunday, March 1, 2009 7:53 AM
  • The option is found in Internet Explorer 7.
    Tools/Internet Options
    General tab
    Languages button
    Add
    English (Singapore) [En-SG] is in the list to add.
    That needs to be the default language for your location.

    -steve
    Microsoft MVP Windows Live / Windows Live OneCare & Live Mesh Forum Moderator
    Monday, March 2, 2009 4:05 AM
    Moderator
  • sorry for not being clear, when I said I don't have it, I meant it's not part of the options to chose from...
    when I do:
    Tools/Internet Options
    General tab
    Languages button
    Add

    in the list it goes from English (Philippines) [en-PH] to English (South Africa) [en-ZA] there is no Singapore...

    how can I add it to the List>
    thanks,
    pv
    Monday, March 2, 2009 9:56 AM
  • I suspect that you already have En-SG in the list *before* you click the add button. That's the only reason I can see for it to not be there when you click add. If you have multiple languages listed as already installed, move En-SG to the top of the list, making it the default.
    -steve
    Microsoft MVP Windows Live / Windows Live OneCare & Live Mesh Forum Moderator
    Monday, March 2, 2009 5:52 PM
    Moderator
  • I don't.
    anyway, tried it from another PC running Vista that indeed had a en-SG, switched to this, rebooted (just be on the safe side), check en-SG was still the language in IE,
    tried to renew, and it still displayed country as United state, and it's grayed out, as in I can't switch to another country,
    now you guys sounded quite confident it would solve my issue, but didn't;
    any other ideas,
    thanks,

    the time I spend on this forum, being treated as a moron is less time it would have taken me to switch to a working security suite, certainly hope that your next shoot in the dark will help....
    Saturday, March 7, 2009 12:33 AM
  • If you e-mail me per my earlier post you can speak to technical support and they can help you renew your subscription.
    Jim
    Saturday, March 7, 2009 1:14 AM
    Moderator