locked
Extreme Slowdown When Defaulting Windows Firewall to Block All RRS feed

  • Question

  • (If this post is in an inappropriate category, please help me find the correct one)

    I have been concerned lately with the number of programs that have been transmitting data on my machine, so in attempt to halt all unwanted communication I set the Windows firewall state to block everything inbound and outbound by default.  I then proceeded to add exceptions to IE, Firefox, Chrome, and Opera (I am a web developer) as well as other programs such as Thunderbird Mail.

    One would think this would work, right?  Wrong.  My connection speed always has been about 30Mbps down and 5Mbps up.  After this change I have noticed all communication bottle-necked at 1 to 2 Mbps up and down.  This is also with a significant connection wait time for all established connections.

    I returned my settings to before and the problem did not go away.  I may have deactivated a few rules/exceptions in the list that I felt were unnecessary, but when I went through the list and activated groups at a time, none succeeded to fix the bottle-neck. 

    My system specifications:
    Processor: Intel Core I7 960 Bloomfield (3.2Ghz x4)
    RAM: 16GB DDR3 (4x 4Gb)
    Network Type: Wireless N PCIe (Constant five bars) [NOTE: it says 5.5Mbps as my speed on it now?  WHAT?  Usually well over 100Mbps]
    OS: Windows 8 (6.2)
    AV: Avast! Ver. 2014.9.0.1018

    All suggestions are more than welcome.  I must get this resolved.  Thanks.

    Sunday, May 25, 2014 1:00 AM