locked
Creating Volume Failed - Element not Found error during setup RRS feed

  • Question


  • Trying to install Beta 2,  made it all the way to the last part (stage 7 step 4)- Finalizing Installation

    At the step "Creating Volume Primary Volume"  this error pops up:

    Creating Volume Failed: Element Not Found

    Error: 0x80070490

    The box is an Asus A7N8X Deluxe with a 300gb Maxtor SATA drive using the Built-In Silicon Image 3112 SATARaid controller.

    In device manager everything is good, no other errors noted.

    Thanks

     

     

     

     

    Saturday, March 10, 2007 1:50 AM

All replies

  •  

    This issue has surfaced again with RC1 -- I took my functioning CTP server, rebooted with the install DVD, and near the end of the clean install, this error came back!   In the q_setup.log file I have:

     

    [7/1/2007 9:02:01 PM 7c4] Messagebox: Creating volume failed: Element not Found. (error code 0x80070490)

      [TRACE] Step_CreatePrimaryVolume : Exited (0x80070490)

    [7/1/2007 9:06:41 PM 7c4] Windows Home Server setup failed. The error code is 0x80070490. Please correct the problem and reboot to restart the setup program.

     

       I fought this with Beta 2, and if memory serves me correctly, I finally got past it by using a brand new hard drive (500gb Maxtor).    Now the error returns trying install RC.  Agggh. 

     

    It's far enough along in the setup process "Install step is set to 5"  -- when the install exits I'm able to use the server, and through disk manager, etc. everything looks fine.  I've tried manually partitioning/formatting/erasing the rest of the drive with no luck.  I've also tried Low Level Formatting the drive using the 3112 SATA controller, but that didn't help either.

     

    Any Ideas?  Thanks in advance.

     

     

    Monday, July 2, 2007 2:37 AM
  • Hi,

     

    I have seen this message, 0x80070490,  previously, but not in WHS.

    In other cases it referred to incorrect SATA drivers being used. Could this be an explanation in your case?

     

    Colin

    Monday, July 2, 2007 5:14 PM
  • The same thing happened to me. I tried re-installing, but that did not work. I am using and old AMD based computer with an IDE drive, so I don't think it is THAT hardware specific. I do not have a solution, but I have a patch. I opened 'msconfig' and turned off the setup file in startup. I can now boot my server without an error popping up. I have not used the server a lot, so I don't know what I am missing with the volume not being created right. If any has a fix, please share the wealth.

    -Happy Beta testing!!!!
    Thursday, July 12, 2007 4:00 AM
  • I had this problem too.  Each time it installed the disks in the early setup screen, but in the late ones I got this error.

     

    I eventually fixed it by doing the following:

     

    • At the screen that says "do you want to install additional drivers" (for me no HDD existed, so it is manditory), I selected yes
    • A file dialogue box appears.  I inserted my USB key with the folder containing drivers.  In my case I used 3112Raid_x86_10600_logo.zip.  This zip file was extracted to a folder called 3112Raid_x86_10600_logo
    • After the new drive was displayed (being the usb drive), I navigated to the extracted 3112Raid_x86_10600_logo folder, right clicked on the folder and chose copy.
    • I then pasted the folder onto the temporary installation partition on the hard disk that setup uses (X:, in my case)
    • Remove the USB key (must do this before selecting the driver!)
    • Select the inf file on the temporary drive on HDD (in my case the inf was in x:\3112Raid_x86_10600_logo)

     

    Cheers,

    Matt.

    Saturday, August 11, 2007 9:44 AM
  •  

    I think I get a similar problem.

     

    When installing I get the message that no harddisk was found. Then I click to "add driver" and select the apropriate driver from a CD. Afterwards the expected raid drive appears in the hard disk list box. I then select it as installation target.

     

    In the following screen I shoud select a keyboard language but the drop down lists are empty.

     

    When continueing the setup the system reboots and nothing has been done. That means that if I try to boot from harddisk there is nothing on it that could be bootet. Otherwise (booting from the CD-Rom) I resart the same installation process as before.

     

    I've no idea what I could do - OK I could buy another PC, but I mean I want THIS PC get to run.

    Monday, August 13, 2007 1:15 PM
  • Erich, when asked for the drivers - try copying the drivers from the CD to the temprory disk created by setup and then select the drivers there, instead of the CD.  I'd be interested to see what results you get.

     

    Cheers,

    Matt.

    Tuesday, August 14, 2007 12:22 PM
  •  

    Did anyone ever find out what the consequence of this error is?  I mean, what feature isn't there or what can't you do if you ignore the error and use the OS as is?

     

    Also, if a driver works well enough for the OS to see the drives, and get that far in the install, how can the driver be limiting the OS in a way that would prevent it from making a further modification to the drives? What else could it be wanting to do that is more difficult to do than partitioning, formatting and installing the OS in the first place?

     

    OK, found out aswers to my own questions.

     

    Consequence to error:  When the error does not occur the installer is presented with a setup wizard to configure Windows Home Server.  Could this all be done manually?  Not sure.

     

    Also, when I recieved the error I had a 20GB install partition but the remainder of the drive remained unpartitioned.  SO the error likely means this 2nd larger/data partition was not sucessfully created.  I was able to create and format using the drive manager without incident so I am not sure why the installer couldn't do it.

     

    How I fixed it:  The dell driver I was using had a windows 2000 and a windows 2003 option.  I could see this after the file copy and reboot into console installer after pressing F6 to install the driver a 2nd time.  The first time I am asked to provide the driver I am in the GUI installer and am not asked to select between the 2000 and 2003 drivers.  I suspect the GUI installer was picking the 2000 driver.  

     

    To prevent an incorrect auto selection of the 2000 driver I edited the inf file and removed the Windows 2000 option. I formatted the drives and reinstalled using the new INF and didn't get the error.

     

    I hope this helps someone.

     

    PS I think it's odd that a controller driver would cause this since the other driver was able to partition, format, and copy files without any issues.

    Wednesday, October 17, 2007 2:33 PM
  • I'm running into the same problem, but I don't have multiple versions of the driver.  Did anyone verify if we can just format the remainder of the drive manually?  What else does the install routine have to do, after that step?

     

    Friday, November 2, 2007 5:53 PM