locked
Remote connectivity fails using http://<myname>.homeserver.com/ RRS feed

  • Question

  • Hi,

    I've searched through the various posts and threads describing similar problems as this, tried out the suggestions, but still no luck!

     

    What have I got?

    - PC with XP(SP3)

    - Inventel router, fairly tried & tested.

    - All hard connected via ethernet

    - Windows home server on HP Mediasmart,

    - set up for remote access & enabled

    - website connectivity on

    - router configured via uPnP and appears to be correct.  However I've also switched to manual port forwarding 80/443/4125, taking the precautions mentioned in various posts about first "unconfiguring" uPNP in WHS settings to avoid conflict with the manual setting on the router, but no difference.

    - in Router Config details on WHS the 1st four checks are ticked but it can't verify router is accepting web site connections and can't verify router is accepting Remote access connections.  That may just be a router/WAN looping issue perhaps?

    - in Domain Name details (WHS) all four checks are ticked OK.

    - Ports 80/443/4125 checked via ShieldsUp! and appear to be open.

     

    What am I getting so far?

    - Access to WHS via the local network is fine, access via remote desktop, network file access, etc all OK.

    - Access remotely (via dial-up - as I'm aware of the possible looping problem trying to access out and back using the router) only works if I use the router WAN IP address.  e.g. http://<ipaddress>/home and even https://<ipaddress>/remote

    - if I use http://<myname>.homeserver.com/home I get a broken link

    - if I do an IP check on the name <myname>.homeserver.com I do obtain the correct router WAN address that's currently assigned.

     

    So in summary if I use the WAN IP address itself (http://<IPaddress>/home) it works, but not when I use the vanity address (http://<myname>.homeserver.com/home).  I want to use the vanity address as WHS updates it with any changes to my router WAN address whenever it's changed by the ISP (as it's not static).

     

    Can anybody offer any advice?  I'm out of ideas!

     

    Saturday, May 31, 2008 9:50 AM

Answers

  • Good morning,

    No, using the server names for both my servers, resole correctly IP to name and name to IP.

    As a quick test, you could sign up for a free DYDNS and check to see if that has the same problems or not. If it works correctly, then we need to look further into your IP/Router information.

     

    Colin

    Sunday, June 1, 2008 9:25 AM

All replies

  • You didn't inadvertently either spell the <myname> incorrectly, or insert a space when setting it up? 

    Also, your router doesn't have any blocking facilities, or port triggering settings which might block name forwarding?

     

    Colin

     

    Saturday, May 31, 2008 5:32 PM
  • Find Other Uses For It!!

     

    I wouldn't worry to much.  Mine has never connected either.  The troubleshooter runs through just fine with all green check marks.  I Get All Green Check Marks In Remote Connectivity.  I've called my ISP to see if they are blocking any ports which they claim they have NEVER done.  At any rate I've just given up on the idea.  I have found though that with the 4 1 Tb drives I put in the HP EX 475 when I first got it as far as a DOOR STOP goes it's the best damn door stop I've ever had.  Heck, I've had the wind howling through here and that EX475 stands it's ground and doesn't move.  I figure 2 Grand to keep the wind out is a real bargin.

     

    I'm just going to gut the thing and throw the carcass away, keep the drives and build something that works.  Forget the external drives, they don't come back in a crash anyway.

     

    Never in my life have I seen a piece of hardware where the documentation is so poor, promises made about performance are just empty talk and you don't find out any of this until you actually own one.

     

    Those folks at HP have gone down a road with this one where the people they lead there will NEVER follow them again.

    Saturday, May 31, 2008 8:55 PM
  • Hi Colin

    No the vanity URL is all spelt OK. I ran a check on the name to IP conversion here (http://www.hcidata.info/host2ip.htm) and it came up with the correct address for my WAN router.

    As far as required ports are concerned I don't think they are being blocked, either by the router or the ISP.  When I use the router's WAN IP address directly (like http://<WAN_ip_address>/home ) I manage to connect to the windows home server.  But when I use http://<myname>.homeserver.com/ it fails.  As far as I can see there's no port triggering set up.

     

    I'm no expert on routers or internet protocols though, is there a possibility the router recognises the difference between using the ip address directly and the vanity URL?  I'd have thought the process of resolving the ip address from the name would have been more upstream at some domain name servers somewhere.

     

    The problem does seem to be in that area though, I'm still looking.

    Fran

     

     

    Saturday, May 31, 2008 10:33 PM
  • You can test if it's your router or not by bypassing it temporarily.  Plug it right into your modem for tests.

     

    Sunday, June 1, 2008 4:40 AM
  • It's actually a modem/router combined so I can't bypass it.  But I did temporarily DMZ the router to direct all ports to the server - still no difference. 

     

    I'm beginning to feel it's a problem with name/IP translation out in the network somewhere but it's only a guess.  If there's anyone out there with knowledge of routing/DNS they might be able to shed some light.

     

    Using a site that's able to convert name to IP and vice versa ( e.g. http://www.hcidata.info/host2ip.htm), what I did find is this: 

    1. If I enter my host name (i.e. <myname>.homeserver.com) I get the correct WAN IP address that the ISP has assigned to my router.
    2. If I then do the reverse and enter that IP address, I get the ISP's host name for me (a long alpha-numeric address that obviously must be unique and point to my router).  I can check this name by entering it as the host name, and I get the correct IP address.

    I wondered whether that could provide me with a solution - use long ISP-assigned host name to access the home server. Unfortunately it's not permanent - some of the numbers in this name come from the IP address itself, and that changes from time to time.

     

    Does anybody else get the same result as I do in 1. and 2. above?

    Sunday, June 1, 2008 7:26 AM
  • Good morning,

    No, using the server names for both my servers, resole correctly IP to name and name to IP.

    As a quick test, you could sign up for a free DYDNS and check to see if that has the same problems or not. If it works correctly, then we need to look further into your IP/Router information.

     

    Colin

    Sunday, June 1, 2008 9:25 AM
  • Colin thanks for your help and suggestion!

     

    I signed up with DynDNS, got my free name and it worked!  All within half an hour so the name/IP propagation was very quick.  My router allows the configuration of an IP update service to DynDNS so it should keep in step with any IP address changes from my ISP.  So that's the solution I'll stick with if it continues to work OK.  I did see something on DynDNS about a 30 day re-enable (or similar) for their free service, bit I'll see.

     

    I still don't understand why it should work with a DynDNS domain name and not the homeserver DNS name.  Unless my ISP is blocking <xx>.homeserver.com addresses for some reason.  But would they be aware if the translation is done somewhere else?  This is where I reach my limits of understanding.......!

     

    Any way it works with the DynDNS domain name so fine and thanks again.

     

    Fran

    Sunday, June 1, 2008 1:35 PM
  • Hi,

    Well, that rules out the ISP really as I don't think they should be blocking a particular server,

    The 30 day 'thing' is you need to re-log every thirty days to keep the service. They do have a download available which will do it for you.

    It's OK as a solution, but not as good as getting your Homeserver name up and running as that includes a certificate for your server to authenticate it to external users.

     

    Another option, is to try a different DNS server as a trial. OpenDNS are reputed to be better that an ISP's own ones, so will be worth a few minutes effort.

     

    Colin

     

    Sunday, June 1, 2008 2:59 PM