locked
Business rule: Lock "hidden" fields failed [2015 On Promise] RRS feed

  • Question

  • Hello,

    I created a business rule at the entity scope, and add some actions "Lock field". And I've discovered that if you try to lock a field not added on the form, all the "lock field" actions of the rule failed (without error message) even if the others fields are on the form.

    This bug is pretty annoying especially if you have 2 forms with differents fields, and you want create a common business rule.

    Am I missing something or is it really a bug?

    And why Dynamics CRM is not on Microsoft Connect. There is no way to report bug without spend hours with support.

    Valentin B.

    PS: I have the latest version (7.0.1.129)



    Tuesday, May 12, 2015 2:25 PM

All replies

  • Here's the Dynamics Connect: https://connect.microsoft.com/dynamicssuggestions

    As to the "lock field" issue, I would expect that's normal behavior.  JavaScript will also fail in the exact same circumstance, as there is no field to reference.  You'd need to be form-specific with your rules.


    The postings on this site are solely my own and do not represent or constitute Hitachi Solutions' positions, views, strategies or opinions.

    Tuesday, May 12, 2015 2:43 PM
  • Thank you for your answer.

    For me it's still a bug. The other "Lock field" actions should work even if one of the action failed, and I really liked the entity scope instead of form scope... but it's unusable.

    Wednesday, May 13, 2015 8:08 AM