locked
SyncToy 2.0 error: Exception during run: Failed to detect changes RRS feed

  • Question

  • I am using a brand new Maxtor 320Gb USB disk as a mirror of my network server (a Buffallo NAS device).
    I have not had any problems with either. The PC runs Vista. I have about a dozen folder pairs.

    I did an initial run overnight last night (the USB disk was empty), and it successfully copied some 190,000 files, creating about 10,000 folders. There was no error.
    I have since tried to synchronise several times, both using 'all folder pairs' and individual ones, both doing a run and a preview. In every case I get the same error:
    Exception during run (or preview): Failed to detect changes.

    Any help would be gratefully received.
    Many thanks,
    David Moore

    The verbose log contains:
    SYNC: 04/07/2009 16:18:30:662: -------------------------------------------------------------------------
    SYNC: 04/07/2009 16:18:30:664: Starting SyncToy, version 2.0.100.0, built 12/08/2008 15:07:12.
    SYNC: 04/07/2009 16:18:35:785: Started scanning directory : I:\
    SYNC: 04/07/2009 16:18:35:785: Started scanning directory : H:\AxitechMirror\drivei\
    SYNC: 04/07/2009 16:19:25:995: Stopped scanning directory : I:\
    SYNC: 04/07/2009 16:19:26:010: *** Exception during preview: {0} :
     Microsoft.Synchronization.SyncException: Failed to detect changes. ---> System.Runtime.InteropServices.COMException (0x8007045D): The FileSyncProvider failed while detecting changes.
       at Microsoft.Synchronization.Files.Interop.FileSyncProviderClass.DetectChanges()
       at Microsoft.Synchronization.Files.FileSyncProvider.DetectChanges()
       --- End of inner exception stack trace ---

    Server stack trace:
       at Microsoft.Synchronization.Files.FileSyncProvider.DetectChanges()
       at SyncToy.SyncEngine.DetectChangesOnProvider(FileSyncProvider syncProvider, String replicaRootPath)
       at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Int32 methodPtr, Boolean fExecuteInContext, Object[]& outArgs)
       at System.Runtime.Remoting.Messaging.StackBuilderSink.PrivateProcessMessage(RuntimeMethodHandle md, Object[] args, Object server, Int32 methodPtr, Boolean fExecuteInContext, Object[]& outArgs)
       at System.Runtime.Remoting.Messaging.StackBuilderSink.AsyncProcessMessage(IMessage msg, IMessageSink replySink)

    Exception rethrown at [0]:
       at System.Runtime.Remoting.Proxies.RealProxy.EndInvokeHelper(Message reqMsg, Boolean bProxyCase)
       at System.Runtime.Remoting.Proxies.RemotingProxy.Invoke(Object NotUsed, MessageData& msgData)
       at SyncToy.SyncEngine.DetectChanges.EndInvoke(IAsyncResult result)
       at SyncToy.SyncEngine.Run(Boolean previewMode)
       at SyncToy.SyncEngine.Preview()
       at SyncToyUI.PreviewDialog.PreviewOnePair(SyncEngine she)
    SYNC: 04/07/2009 16:19:26:011: *** Exception during preview: Failed to detect changes.
    Tuesday, April 7, 2009 3:35 PM

Answers

  • I had a similar problem when copying between a Laptop and a FQDN Path on a File Server (ex. \\servername\Share\Username\Folder).  I was able to resolve the issue by specifically granting my Domain User Account access to the folder.  Originally my access was granted by using the "SELF" option, but this seemed to be causing the issue.  I've also had this issue when trying to sync with folders where I had permissions via a Group Membership that was also resolved by specifically granting my domain user account access to the folder and files in question.  Don't know if this will help with your error, but thought it may be worth a shot.

    Wednesday, April 8, 2009 8:05 PM