locked
The Report Cannot be displayed RsProcessingAborted CRM 2011 RRS feed

  • Question

  • I have just imported are organization and updated the from CRM 4 to CRM 2011 on Rollup 1.  When I try to run any report i get the error the report cannot be displayed.  If I check the SQL logs I get the following message about not having permission.  CRM 2011 is on a Windows 2008 R2 Enterprise Server and SQL is on its own server and is version 2008 R2.  

     

    I checked some of the postings and I created an execution account by creating a new account in active directory.  Please tell me what permissions I need to give this execution account, and any other permissions I need to set to get this working.  Please be very specific I am an infrastructure guy and don't work with Reporting Services often.  

     

    I should also mention that my SRS service account is Network Service.  I am sure there are permissions I need to setup for these accounts I just don't know where or how some other links reference them but don't tell you how. 

     

    ERROR: Throwing Microsoft.ReportingServices.ReportProcessing.ProcessingAbortedException: , Microsoft.ReportingServices.ReportProcessing.ProcessingAbortedException: An error has occurred during report processing. ---> Microsoft.ReportingServices.ReportProcessing.ReportProcessingException: Cannot create a connection to data source 'CRM'. ---> Microsoft.Crm.Reporting.DataExtensionShim.Common.ReportExecutionException: Immediate caller LWGINC\SRS2008R2 has insufficient privilege to run report as user S-1-5-21-1186999560-1424097373

    Wednesday, May 11, 2011 7:54 PM

All replies

  • Hi,

    Here is the fix - http://support.microsoft.com/kb/2006869


    Cheers, Edwin

    Follow me on: https://twitter.com/astutecrm

    My Blog: http://astutecrm.wordpress.com/

     

    Thursday, May 12, 2011 11:31 AM
  • The link you gave me has you manually enter in the org and system ID for a particular user.  I want to be able to run reports from any user all of the time this is not a fix. 
    • Edited by pslager Thursday, May 19, 2011 2:42 PM
    Tuesday, May 17, 2011 6:53 PM
  • So if I manually set the execution account in the Reporting Services Configuration GUI and then try to run a report the report log shows that the execution account doesnt have the right permission.  What permissions does the execution account need and how do I set them?

    Or if its not a best practice to use an execution account.  My SSRS services is currently running off of the network service acccount.  I tried adding Network service as an administrator in the SQL Report Services Admin URL --> http://SRSServerName/SQLReports --> The CRM Database --> Site Settings --> Security adding Network Service as administrator.  However, it still says Network Service doesnt have permission to run the report when I view the SSRS log. 

    Tuesday, May 17, 2011 7:07 PM
  • I solved it on my system by enable the Report Manager URL in "Reporting Services Configuration Manager"

    check that this URL works.

    http://devdbmssql/Reports

     

    Wednesday, September 21, 2011 6:02 PM
  • Please follow below steps on SSRS server:-

    1) Start -> Microasoft SQL Server -> Configuration Tools -> Reporting Services Configuration Manager -> Execution Account

    2) Uncheck teh execution accounta nd keep it empty.

    3) Apply teh settings and restart reporting services.

    4)Make sure that if you go to Reports manager http://servername/reports-> Shared Reports -> MSCRM_DataSource -> "Credentials Supplied by User" option is checked.

     

     


    Arpita
    Friday, September 23, 2011 4:36 PM
  • I have same problem and i would like to know what permissios are required for execution account to run CRM reports.
    Friday, October 28, 2011 11:43 AM
  • nobody knows? i need CRM reports badly.
    Thursday, November 3, 2011 8:00 AM
  • Arturas, did you solve the problem? I have the same problem and tried everything, but nothing yet.
    Thursday, November 17, 2011 4:08 PM
  • pslager,

    I encountered the same problem and I was able to fix using the directions below (extracted from: http://andreaswijayablog.blogspot.com/2011/08/crm-2011-report-error.html):

    Issue: Cannot create a connection to data source 'CRM'. ---> Microsoft.Crm.Reporting.DataExtensionShim.Common.ReportExecutionException: Immediate caller Domain\SqlService has insufficient privilege to run report as user S-1-5-21-1162093662-620106126-315576832-39399.

    The CRM is installed on the application server and the SSRS is installed on different server. After futher investigation it turns out that it's caused by double hopping issue regarding the authentication and we just need to set the correct SPN on the machines.

    setspn -a http/your-crm-server-name domain\crm-user
    setspn -a http/your-crm-server-name(FQDN) domain\crm-user

    Other things to check to make sure your reports work:
    1. Make sure your SRS connector has the same RollUp version as the CRM Server RollUp
    2. In Reporting Service Configuration Manager, uncheck the 'Specify an Execution Account'
    3. Browse to both SharedReports\5.0.xxxx\ and _MSCRM report folder and check the MSCRM_DataSource connection. The connection string should be empty,  DataSource Type should be Microsoft Dynamics CRM SQL, and the connection should be Credentials supplied by the user running the report (uncheck the Windows Credentials box)

    Regards,

    Rafael

    Monday, March 5, 2012 10:48 PM
  • Hi RafaelL,

    I think I am getting the same message, and therefore setting the SPN may fix the issue.

    Do I need to set the SPN on both the SQL server and the CRM server?

    Can you explain the PS command a little further - what "\crm-user" shall I use if I want multiple users to run reports?

    Thanks

    Friday, October 5, 2012 12:59 PM