locked
Cannot Mount Drive after successful Server Recovery RRS feed

  • Question

  • before i had a chance to replace and restore the server system drive on my server, I had 3 laptops die on me.  Basically all but 1 very old dell.

    I successfully recovered the server with one of the dead machines i was able to resurect temporarily, i connected it to the server.  I was running XP and tried to mount a vista back up just to access the files, but i kept getting the cannot mount drive error.  That laptop died again.

    I have a new dell laptop that has windows 7, i installed the connector successfully, I am again trying to access the vista back up and i am again getting the cannot mount drive error.  This time, however, when I close the error message i see a prompt to format drive Z.  I have nothing connected to drive Z?  What is the software trying to do?  What do I need to do to successfully access the files in the backups?

    Very much appreciate the help.  I was not able to find any solutions on the forums to this problem.

    Julie

    Wednesday, April 11, 2012 2:57 PM

All replies

  • Welcome back - pleased the other problem was fixed! Z: is normally where WHS mounts the backup you are trying to recover from. Sounds as though the backup datbase may be corrupt. Have a look at this from the FAQ section of this website:

    http://social.microsoft.com/Forums/en-US/whsfaq/thread/cf354b5d-b37b-4b7f-a0d5-8e573697777f

    and this:

    http://social.microsoft.com/Forums/en-US/whsfaq/thread/828b438f-5770-4f4b-bf82-b5d2f12e3887


    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.


    Wednesday, April 11, 2012 3:41 PM
  • Thanks for the quick response!

    The first link addresses how to recover the server which i've already done successfully.

    The second link covers what i could loose with a system drive failure, which i had, and back ups is not one of them. 

    I was hoping someone might have some additional suggestions because it seems to be a common experience.  The posts i found were from 2009 and 2010 identifying a bug.  I have not seen any other successful solutions that are similar to my problem. 

    The recovery gets to about 80%.  Is there a way to uncorrupt the database?  some kind of a chk dsk or anything?

    Wednesday, April 11, 2012 5:53 PM
  • Take a look at this thread, in particular Marc Moon's second post.

    I'm not on the WHS team, I just post a lot. :)

    Wednesday, April 11, 2012 7:00 PM
    Moderator
  • Thanks for the link.  I tried the steps exactly, but when opening the back up again it gets to 81% and a pop up tells me i need to format the z drive before i can mount the drive.  Do i want to format now.  Before i can answer I get the can not mount drive error.  If i quickly answer yes, it tells me that it cant find the drive and see if it is connected, etc. 

    I really hope there is an answer to this one!!!

    Thursday, April 12, 2012 2:22 PM
  • Did the driver re-installation happen as expected?

    I know you have multiple dead machines, but can you try this from the same thread (courtesy of Brubber):

    If you have more then one client that is backed up can you please try:

    1. Open a backup of another client on the client that causing the problem

    2. Open the backup of the client that will not open on another client

    This should tell you if the problem is some issue on the client or if it's a problem with the backup itself


    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.

    Friday, April 13, 2012 8:35 PM
  • I THOUGHT I tried it on the last dead machine before it died and it gave me the cannot mount error.  I do not recall if it was telling me to format the drive, however?

    I have this one (new dell windows 7), a macbook pro, a dell that i can't install the connector on.  Suggestions?

    None of the backups will open.

    I also tried restoring the back up to an external drive using the PC restore CD and I get this error:

    An unknown network error has occurred during pc restore.

    Please verify that your network connection is active and that your windows home server is powered on.

    I followed these steps but still get the mount error.  There seems to be a pool of us that get this format error, but there seems to be no solution:  See Comments in this blog

    1.  To permit automount:

    You must be an Administator.  Go to Start | Run
    Enter cmd.exe
    > diskpart

    DISKPART> automount enable

    DISKPART> exit

    2.  To identify failed Backup files:
    Open Windows Home Server Console
    Go to View Backup for each system
    Select each Failed Backup
    For each failed backup, select Delete at next Backup Cleanup | Apply | OK

    3.  To remove failed Backup Files:
    Go to Settings | Backup and start Cleanup Now

    4.  To restore backed up data:
    Go to View Backups and restore

    Friday, April 13, 2012 9:25 PM
  • PS - is there any other way to access the files in the back up?  I just need our business quickbooks file! 
    Friday, April 13, 2012 9:27 PM
  • Continuing to work on this i copied the back up database and then repaired the database.  All backups were successfully repaired, much to my surprise.

    I tried to access the backup again but i get the same results.

    Is there a connector for mac?  If so i would try that, but i am guessing probably not.

    I will also try to get the old dell to work.

    Sunday, April 15, 2012 1:10 PM
  • one more note.  I can access the new backups this new machine has made.  These are the only new backups since the server recovery.
    Sunday, April 15, 2012 1:11 PM
  • i also tried to open a very small back up that is windows 7 and also had no luck.
    Sunday, April 15, 2012 5:15 PM
  • Just tried on my Nanny's XP machine and also got the 81% cannot mount drive error. 
    Monday, April 16, 2012 4:04 PM
  • All the backup logs indicate that this restore was successful even though the backups are not successful. 

    I ran the WHSdbCheck on the backup database files and havea  warning message that next index record mismatch and then another error message that one or more referenced data files are not found.  index file is referencing missing datafiles.  The following data files are missing:  then it lists about 100 data.4096.5.dat data.4096.6.dat and so on through Data.4096.160.dat. 

    Then it says "This indicates massive data loss."

    Based on my research it seems that others have had luck faking up the missing files.  I have no idea how long this would take me and if it would even help me proceed?

    I would love to attempt to recover files from the database but i keep getting an error with the program whsdbdatadump, it processes everything but then fails with this error "dumping volume files attempted to divide by zero".

    I don't know if there is anything else i can do to recover the files?  At this point I have pretty much given up, but will keep an eye on this post to see if anyone comes up with anything.

    Monday, April 23, 2012 10:29 PM