locked
SATA Drive not found on PC Restore RRS feed

  • Question

  • Here's a puzzler.  I have a laptop that I have backed up AND RESTORED several times.  After a hardware failure the device went into the shop and (supposedly) three things were changed:
    - Memory replaced
    - Keyboard replaced
    - Hard disk reimaged to Lenovo factory image

    I wanted to restore the previous backup image onto this machine.  But when I run PC Restore from the CD, none of the hard disk partitions show up as possible restore targets.  What's more, if I run Disk Manager I don't see a drive 0.

    However the SATA driver definitely shows up in the Drivers screen (where I do need to load the drivers for my Ethernet connection).  And the machine runs Vista properly -- the Drive 0 partitions are definitely available when I boot from hard disk.

    Here's what I've tried:
    1. Backup te existing image, get the drivers from there onto my USB key.  NO JOY.
    2. Restore the image I just backed up.  NO JOY.
    3. in the BIOS change the SATA type from AHCI to IDE.  NO JOY.
    4.  

    At this point I'm at a loss as to how to get this machine restored.  Since I can't even restore hte current image I don't really want to flatten the machine and end up with nothing bootable.  This is the first time I've ever seen this on any of my WHS PCs.  ANY SUGGESTIONS???

    Sunday, February 22, 2009 7:54 PM

All replies

  • As a practical matter, you can restore by removing the drive from the laptop and connecting it to some other computer that has the WHS connector installed, then running ClientRestoreWizard.exe from (by default) C:\Program Files\Windows Home Server. this is the same tool that you would be using on the Restore CD, jsut hosted in a full Windows Environment instead of the WinPE environment on the CD.

    when you say that none of the partitions shows up as possible restore targets, though, do you nean that they show up, but the Restore CD isn't letting you restore to them, or do you mean that they don't show up?

    I'm not on the WHS team, I just post a lot. :)
    Sunday, February 22, 2009 8:45 PM
    Moderator
  • Hi,
    I remember that I have read about problems with Lenovo laptops some time ago, but this was more about the machine not booting after being restored.
    If you change in the Bios from AHCI to IDE, it should work without supplying specific mass storage drivers, may be those cause the trouble. Are they for Vista 32 Bit?

    The procedure, which is recommended by Ken involving a second client PC, is also explained in this FAQ.


    Best greetings from Germany
    Olaf
    Sunday, February 22, 2009 9:25 PM
    Moderator
  • None of the disk partitions show up at all -- on the screen that allows me to pick which backed-up drive goes where, the only choice is my USB key.  When I run Disk Manager, I see SATA Drive 1 (the DVD drive) but not SATA Drive 0 (the hard disk).

    The thing that bugs me is that this worked before the box was reimaged; I'm banging my head against the way trying to figure out what has changed since the O/S isn't getting loaded at all.  I know WinPE can be sensitive about device drivers (I used to be on the Microsoft Deployment Toolkit team) but it worked as advertised before.  The big thing that's changed is that the old O/S was Vista Ultimate and the new factory image one is Vista Home Premium.

    Ken, thank for the tip, I will try to assemble the cables and get the laptop drive connected to a desktop PC.

    Monday, February 23, 2009 4:10 PM
  • I am having this problem with a Lenovo X200t and I am trying to narrow down the issue.

    Have you ever used Bitlocker on your machine?
    Wednesday, February 25, 2009 7:03 AM
  • No, never used Bitlocker on this machine. 
    Wednesday, February 25, 2009 8:47 PM
  • I gave up and bought a 2.5" SATA drive enclosure from NewEgg. I can not figure out for the life of me why this has worked so many times before without an issue and now it is not working. I have not made any changes to any of the hardware or the BIOS.
    Thursday, February 26, 2009 12:46 AM