locked
ClientDeploy.exe fails to install RRS feed

  • Question

  • I have three PCs and one of them refuses to install the Client software. I beta tested Vail, but I removed the Vail Connector before trying to install 2011's connector.

    I've attached the logs from the failed systems.

    Version=1
    EventType=APPCRASH
    EventTime=129517796373412100
    ReportType=2
    Consent=1
    UploadTime=129517796375187127
    ReportIdentifier=2290a305-8fb3-11e0-b965-002219e34efd
    IntegratorReportIdentifier=2290a304-8fb3-11e0-b965-002219e34efd
    Response.BucketId=33376418
    Response.BucketTable=4
    Response.type=4
    Sig[0].Name=Application Name
    Sig[0].Value=ClientDeploy.exe
    Sig[1].Name=Application Version
    Sig[1].Value=6.1.8800.16385
    Sig[2].Name=Application Timestamp
    Sig[2].Value=4d6ed25d
    Sig[3].Name=Fault Module Name
    Sig[3].Value=KERNELBASE.dll
    Sig[4].Name=Fault Module Version
    Sig[4].Value=6.1.7601.17514
    Sig[5].Name=Fault Module Timestamp
    Sig[5].Value=4ce7c78c
    Sig[6].Name=Exception Code
    Sig[6].Value=e0434352
    Sig[7].Name=Exception Offset
    Sig[7].Value=000000000000a49d
    DynamicSig[1].Name=OS Version
    DynamicSig[1].Value=6.1.7601.2.1.0.256.1
    DynamicSig[2].Name=Locale ID
    DynamicSig[2].Value=1033
    DynamicSig[22].Name=Additional Information 1
    DynamicSig[22].Value=152d
    DynamicSig[23].Name=Additional Information 2
    DynamicSig[23].Value=152d49a18dcb45231bb1c1efff527c4d
    DynamicSig[24].Name=Additional Information 3
    DynamicSig[24].Value=36b6
    DynamicSig[25].Name=Additional Information 4
    DynamicSig[25].Value=36b6e08c055a5432397663ef795db021
    UI[2]=C:\Windows\Temp\Client Deployment Files\ClientDeploy.exe
    UI[3]=Windows Server Client Deployment Wizard has stopped working
    UI[4]=Windows can check online for a solution to the problem.
    UI[5]=Check online for a solution and close the program
    UI[6]=Check online for a solution later and close the program
    UI[7]=Close the program
    LoadedModule[0]=C:\Windows\Temp\Client Deployment Files\ClientDeploy.exe
    LoadedModule[1]=C:\Windows\SYSTEM32\ntdll.dll
    LoadedModule[2]=C:\Windows\SYSTEM32\MSCOREE.DLL
    LoadedModule[3]=C:\Windows\system32\KERNEL32.dll
    LoadedModule[4]=C:\Windows\system32\KERNELBASE.dll
    LoadedModule[5]=C:\Windows\system32\ADVAPI32.dll
    LoadedModule[6]=C:\Windows\system32\msvcrt.dll
    LoadedModule[7]=C:\Windows\SYSTEM32\sechost.dll
    LoadedModule[8]=C:\Windows\system32\RPCRT4.dll
    LoadedModule[9]=C:\Windows\Microsoft.NET\Framework64\v4.0.30319\mscoreei.dll
    LoadedModule[10]=C:\Windows\system32\SHLWAPI.dll
    LoadedModule[11]=C:\Windows\system32\GDI32.dll
    LoadedModule[12]=C:\Windows\system32\USER32.dll
    LoadedModule[13]=C:\Windows\system32\LPK.dll
    LoadedModule[14]=C:\Windows\system32\USP10.dll
    LoadedModule[15]=C:\Windows\system32\IMM32.DLL
    LoadedModule[16]=C:\Windows\system32\MSCTF.dll
    LoadedModule[17]=C:\Windows\Microsoft.NET\Framework64\v4.0.30319\clr.dll
    LoadedModule[18]=C:\Windows\system32\MSVCR100_CLR0400.dll
    LoadedModule[19]=C:\Windows\assembly\NativeImages_v4.0.30319_64\mscorlib\727e93705df0ad4eaf442a36e3301e96\mscorlib.ni.dll
    LoadedModule[20]=C:\Windows\system32\ole32.dll
    LoadedModule[21]=C:\Windows\system32\CRYPTBASE.dll
    LoadedModule[22]=C:\Windows\system32\uxtheme.dll
    LoadedModule[23]=C:\Program Files\Common Files\microsoft shared\ink\tiptsf.dll
    LoadedModule[24]=C:\Windows\system32\OLEAUT32.dll
    LoadedModule[25]=C:\Windows\system32\version.dll
    LoadedModule[26]=C:\Windows\Microsoft.NET\Framework64\v4.0.30319\nlssorting.dll
    LoadedModule[27]=C:\Windows\system32\CRYPTSP.dll
    LoadedModule[28]=C:\Windows\system32\rsaenh.dll
    LoadedModule[29]=C:\Windows\Microsoft.NET\Framework64\v4.0.30319\clrjit.dll
    LoadedModule[30]=C:\Windows\assembly\NativeImages_v4.0.30319_64\System\6f3dc4a7cabf8dae89e5f1b76b67e302\System.ni.dll
    LoadedModule[31]=C:\Windows\system32\RpcRtRemote.dll
    LoadedModule[32]=C:\Windows\Temp\Client Deployment Files\ClientSetupCommon.dll
    LoadedModule[33]=C:\Windows\Temp\Client Deployment Files\ServerDiscovery.dll
    LoadedModule[34]=C:\Windows\Temp\Client Deployment Files\AdminCommon.dll
    LoadedModule[35]=C:\Windows\assembly\NativeImages_v4.0.30319_64\System.Drawing\bff967d6adb482a0a1929e2fb5c307d6\System.Drawing.ni.dll
    LoadedModule[36]=C:\Windows\assembly\NativeImages_v4.0.30319_64\System.Windows.Forms\c3c8c4d5960dd31f398dd437a80cc55e\System.Windows.Forms.ni.dll
    LoadedModule[37]=C:\Windows\Microsoft.Net\assembly\GAC_MSIL\Common\v4.0_6.1.0.0__31bf3856ad364e35\Common.dll
    LoadedModule[38]=C:\Windows\Microsoft.Net\assembly\GAC_MSIL\WssgCommon\v4.0_6.1.0.0__31bf3856ad364e35\WssgCommon.dll
    LoadedModule[39]=C:\Windows\Temp\Client Deployment Files\ServerDiscoveryObjectModel.dll
    LoadedModule[40]=C:\Windows\assembly\NativeImages_v4.0.30319_64\System.Core\c0861369bd9b124a4f3e6a600d0d4fc1\System.Core.ni.dll
    LoadedModule[41]=C:\Windows\Microsoft.NET\Framework64\v4.0.30319\diasymreader.dll
    State[0].Key=Transport.DoneStage1
    State[0].Value=1
    State[1].Key=DataRequest
    State[1].Value=Bucket=33376418/nBucketTable=4/nResponse=1/n
    FriendlyEventName=Stopped working
    ConsentKey=APPCRASH
    AppName=Windows Server Client Deployment Wizard
    AppPath=C:\Windows\Temp\Client Deployment Files\ClientDeploy.exe

    ========End of Log========

    [06/05/2011 14:14:05 1388] --------------------------------------------------------------------------------------------------
    [06/05/2011 14:14:05 1388] wmain: Start of Computerconnector
    [06/05/2011 14:14:05 1388] wmain: Calling Computerconnector::ShowWizard()
    [06/05/2011 14:14:05 1388] CComputerconnector::ShowWizard: Initializing common controls
    [06/05/2011 14:14:05 1388] CComputerconnector::ShowWizard: Done initializing common controls
    [06/05/2011 14:14:05 1388] Displaying the wizard
    [06/05/2011 14:14:05 1388] CComputerconnector::ConnecttingDlgProc: IDD_CONNECTING Page Initialization
    [06/05/2011 14:14:05  d4c] GlobalData::Initialize ([fe80::c1b0:89b6:7b56:58e], 65510, C:\Users\Ashley\Downloads\ComputerConnector(fe80__c1b0_89b6_7b56_58e) (1).exe, 1033)
    [06/05/2011 14:14:05  d4c] ExpandEnvironmentStrings return (C:\Windows\Temp\Client Deployment Files\)
    [06/05/2011 14:14:05  d4c] CComputerconnector::Run: Running Task: Id=1 Description=Downloads the Setup.cab file
    [06/05/2011 14:14:05  d4c] NetworkUtil::DownloadFile (HTTP://[fe80::c1b0:89b6:7b56:58e]:65510/Connect/default.aspx?Get=Setup.cab&64bit=1&LanguageId=1033, C:\Users\Ashley\AppData\Local\Temp\Setup.cab)
    [06/05/2011 14:14:05  d4c] NetworkUtil::DownloadFile - Create directory [C:\Users\Ashley\AppData\Local\Temp] if not exist.
    [06/05/2011 14:14:05  d4c] NetworkUtil::_WinInetDownloadFile (HTTP://[fe80::c1b0:89b6:7b56:58e]:65510/Connect/default.aspx?Get=Setup.cab&64bit=1&LanguageId=1033, C:\Users\Ashley\AppData\Local\Temp\Setup.cab)
    [06/05/2011 14:14:08  d4c] ExtractCabinet: Extract (C:\Users\Ashley\AppData\Local\Temp\Setup.cab, C:\Windows\Temp\Client Deployment Files\)
    [06/05/2011 14:14:09  d4c] SetRegValue [C:\Windows\Temp\Client Deployment Files\].
    [06/05/2011 14:14:09  d4c] Deleting [C:\Users\Ashley\AppData\Local\Temp\Setup.cab].
    [06/05/2011 14:14:09  d4c] RunShellExecute: ShellExecute [C:\Windows\Temp\Client Deployment Files\CSetup.exe] with parameters [(null)]
    [06/05/2011 14:14:09  d4c] CSetup::Run: Waiting upto 30secs for Sync Event to be signaled
    [06/05/2011 14:14:09  d4c] CComputerconnector::Run: WaitForSingleObject RetVal = 0
    [06/05/2011 14:14:09 1388] wmain: End of Computerconnector: hr=0x0
    [06/05/2011 14:33:49  7ec] --------------------------------------------------------------------------------------------------
    [06/05/2011 14:33:49  7ec] wmain: Start of Computerconnector
    [06/05/2011 14:33:49  7ec] wmain: Calling Computerconnector::ShowWizard()
    [06/05/2011 14:33:49  7ec] CComputerconnector::ShowWizard: Initializing common controls
    [06/05/2011 14:33:49  7ec] CComputerconnector::ShowWizard: Done initializing common controls
    [06/05/2011 14:33:49  7ec] Displaying the wizard
    [06/05/2011 14:33:49  7ec] CComputerconnector::ConnecttingDlgProc: IDD_CONNECTING Page Initialization
    [06/05/2011 14:33:49  824] GlobalData::Initialize ([fe80::c1b0:89b6:7b56:58e], 65510, C:\Users\Ashley\Downloads\ComputerConnector(fe80__c1b0_89b6_7b56_58e) (1).exe, 1033)
    [06/05/2011 14:33:49  824] ExpandEnvironmentStrings return (C:\Windows\Temp\Client Deployment Files\)
    [06/05/2011 14:33:49  824] CComputerconnector::Run: Running Task: Id=1 Description=Downloads the Setup.cab file
    [06/05/2011 14:33:49  824] NetworkUtil::DownloadFile (HTTP://[fe80::c1b0:89b6:7b56:58e]:65510/Connect/default.aspx?Get=Setup.cab&64bit=1&LanguageId=1033, C:\Users\Ashley\AppData\Local\Temp\Setup.cab)
    [06/05/2011 14:33:49  824] NetworkUtil::DownloadFile - Create directory [C:\Users\Ashley\AppData\Local\Temp] if not exist.
    [06/05/2011 14:33:49  824] NetworkUtil::_WinInetDownloadFile (HTTP://[fe80::c1b0:89b6:7b56:58e]:65510/Connect/default.aspx?Get=Setup.cab&64bit=1&LanguageId=1033, C:\Users\Ashley\AppData\Local\Temp\Setup.cab)
    [06/05/2011 14:33:52  824] ExtractCabinet: Extract (C:\Users\Ashley\AppData\Local\Temp\Setup.cab, C:\Windows\Temp\Client Deployment Files\)
    [06/05/2011 14:33:52  824] SetRegValue [C:\Windows\Temp\Client Deployment Files\].
    [06/05/2011 14:33:52  824] Deleting [C:\Users\Ashley\AppData\Local\Temp\Setup.cab].
    [06/05/2011 14:33:52  824] RunShellExecute: ShellExecute [C:\Windows\Temp\Client Deployment Files\CSetup.exe] with parameters [(null)]
    [06/05/2011 14:33:52  824] CSetup::Run: Waiting upto 30secs for Sync Event to be signaled
    [06/05/2011 14:33:53  824] CComputerconnector::Run: WaitForSingleObject RetVal = 0
    [06/05/2011 14:33:53  7ec] wmain: End of Computerconnector: hr=0x0

    =======End of Log=======

    [06/05/2011 14:14:09 13bc] --------------------------------------------------------------------------------------------------
    [06/05/2011 14:14:09 13bc] wmain: Start of CSetup
    [06/05/2011 14:14:09 13bc] CoCreateInstance CLSID_DOMDocument60 succeeded.
    [06/05/2011 14:14:09 13bc] CServer::GetNodeValue - selectSingleNode
    [06/05/2011 14:14:09 13bc] CServer::GetNodeValue - get_firstChild
    [06/05/2011 14:14:09 13bc] CServer::GetNodeValue - get_nodeValue
    [06/05/2011 14:14:09 13bc] CServer::GetNodeValue - SysAllocString value: SERVER
    [06/05/2011 14:14:09 13bc] CoCreateInstance CLSID_DOMDocument60 succeeded.
    [06/05/2011 14:14:09 13bc] CServer::GetNodeValue - selectSingleNode
    [06/05/2011 14:14:09 13bc] CServer::GetNodeValue - get_firstChild
    [06/05/2011 14:14:09 13bc] CServer::GetNodeValue - get_nodeValue
    [06/05/2011 14:14:09 13bc] CServer::GetNodeValue - SysAllocString value: fe80::c1b0:89b6:7b56:58e%13
    [06/05/2011 14:14:09 13bc] CoCreateInstance CLSID_DOMDocument60 succeeded.
    [06/05/2011 14:14:09 13bc] CServer::GetNodeValue - selectSingleNode
    [06/05/2011 14:14:09 13bc] CServer::GetNodeValue - get_firstChild
    [06/05/2011 14:14:09 13bc] CServer::GetNodeValue - get_nodeValue
    [06/05/2011 14:14:09 13bc] CServer::GetNodeValue - SysAllocString value: 34
    [06/05/2011 14:14:09 13bc] CoCreateInstance CLSID_DOMDocument60 succeeded.
    [06/05/2011 14:14:09 13bc] CServer::GetNodeValue - selectSingleNode
    [06/05/2011 14:14:09 13bc] CServer::GetNodeValue - get_firstChild
    [06/05/2011 14:14:09 13bc] CServer::GetNodeValue - get_nodeValue
    [06/05/2011 14:14:09 13bc] CServer::GetNodeValue - SysAllocString value: Administrator
    [06/05/2011 14:14:09 13bc] CoCreateInstance CLSID_DOMDocument60 succeeded.
    [06/05/2011 14:14:09 13bc] CServer::GetNodeValue - selectSingleNode
    [06/05/2011 14:14:09 13bc] CServer::GetNodeValue - get_firstChild
    [06/05/2011 14:14:09 13bc] CServer::GetNodeValue - get_nodeValue
    [06/05/2011 14:14:09 13bc] CServer::GetNodeValue - SysAllocString value: en-US
    [06/05/2011 14:14:09 13bc] CoCreateInstance CLSID_DOMDocument60 succeeded.
    [06/05/2011 14:14:09 13bc] CServer::GetNodeValue - selectSingleNode
    [06/05/2011 14:14:09 13bc] CServer::GetNodeValue - get_firstChild
    [06/05/2011 14:14:09 13bc] CServer::GetNodeValue - get_nodeValue
    [06/05/2011 14:14:09 13bc] CServer::GetNodeValue - SysAllocString value: 1033
    [06/05/2011 14:14:09 13bc] GlobalData::Initialize ([fe80::c1b0:89b6:7b56:58e], 65510, C:\Windows\Temp\Client Deployment Files\CSetup.exe, 1033)
    [06/05/2011 14:14:09 13bc] ExpandEnvironmentStrings return (C:\Windows\Temp\Client Deployment Files\)
    [06/05/2011 14:14:09 13bc] wmain: Calling CSetup::ShowWizard()
    [06/05/2011 14:14:09 13bc] CSetup::ShowWizard: Initializing common controls
    [06/05/2011 14:14:09 13bc] CSetup::ShowWizard: Done initializing common controls
    [06/05/2011 14:14:09 13bc] Displaying the wizard
    [06/05/2011 14:14:09 13bc] CSetup::WelcomeDlgProc: IDD_PROPPAGE_WELCOME Initialization
    [06/05/2011 14:14:09 13bc] CSetup::WelcomeDlgProc: Set the Deployment Sync Event
    [06/05/2011 14:14:16 13bc] CSetup::RunTasksDlgProc: IDD_PROPPAGE_TASKS Page Initialization
    [06/05/2011 14:14:16 12d0] CSetup::Run: Deployment Stage = DeploymentStage_VerifyingRequirements
    [06/05/2011 14:14:16 12d0] CSetup::RunTasks: Running Task: Id=-1 Description=Check OS Version and SP Index=  0
    [06/05/2011 14:14:16 12d0] OsChecker::CreateInstance ([C:\Windows\Temp\Client Deployment Files\SupportedOs.Xml])
    [06/05/2011 14:14:16 12d0] =================================
    [06/05/2011 14:14:16 12d0] Current Os information:
    [06/05/2011 14:14:16 12d0] Suite = [256]
    [06/05/2011 14:14:16 12d0] Type = [1]
    [06/05/2011 14:14:16 12d0] Architecture = [9]
    [06/05/2011 14:14:16 12d0] IsStarterEdition = [0]
    [06/05/2011 14:14:16 12d0] IsHomeSku = [0]
    [06/05/2011 14:14:16 12d0] Major = [6]
    [06/05/2011 14:14:16 12d0] Minor = [1]
    [06/05/2011 14:14:16 12d0] Build = [7601]
    [06/05/2011 14:14:16 12d0] SPMajor = [1]
    [06/05/2011 14:14:16 12d0] SPMinor = [0]
    [06/05/2011 14:14:16 12d0] =================================
    [06/05/2011 14:14:16 12d0] OSRule::CreateRules  (C:\Windows\Temp\Client Deployment Files\SupportedOs.Xml, .)
    [06/05/2011 14:14:16 12d0] CoCreateInstance CLSID_DOMDocument60 succeeded.
    [06/05/2011 14:14:16 12d0] OsChecker::QuerySupportedOsStatus - Major: 6 Minor: 1
    [06/05/2011 14:14:16 12d0] CSetup::RunTasks: Running Task: Id=-1 Description=Check Net Join Index=  1
    [06/05/2011 14:14:16 12d0] NetJoinChecker::CreateInstance ([C:\Windows\Temp\Client Deployment Files\ServerInfo.Xml])
    [06/05/2011 14:14:16 12d0] CMsi::IsMsiInstalled: MsiQueryProductState for ProductCode {21E49794-7C13-4E84-8659-55BD378267D5} returned -1
    [06/05/2011 14:14:16 12d0] CMsi::IsMsiInstalled: MsiQueryProductState for ProductCode {46DCED50-3A1D-4EF4-94F0-45F2681E3D70} returned -1
    [06/05/2011 14:14:16 12d0] CMsi::IsMsiInstalled: MsiQueryProductState for ProductCode {C1E4D639-4A33-4314-809E-89BD0EF48522} returned -1
    [06/05/2011 14:14:16 12d0] CoCreateInstance CLSID_DOMDocument60 succeeded.
    [06/05/2011 14:14:16 12d0] CServer::GetNodeValue - selectSingleNode
    [06/05/2011 14:14:16 12d0] CServer::GetNodeValue - get_firstChild
    [06/05/2011 14:14:16 12d0] CServer::GetNodeValue - get_nodeValue
    [06/05/2011 14:14:16 12d0] CServer::GetNodeValue - SysAllocString value: SERVER
    [06/05/2011 14:14:16 12d0] CoCreateInstance CLSID_DOMDocument60 succeeded.
    [06/05/2011 14:14:16 12d0] CServer::GetNodeValue - selectSingleNode
    [06/05/2011 14:14:16 12d0] CServer::GetNodeValue - get_firstChild
    [06/05/2011 14:14:16 12d0] CServer::GetNodeValue - get_nodeValue
    [06/05/2011 14:14:16 12d0] CServer::GetNodeValue - SysAllocString value: fe80::c1b0:89b6:7b56:58e%13
    [06/05/2011 14:14:16 12d0] CoCreateInstance CLSID_DOMDocument60 succeeded.
    [06/05/2011 14:14:16 12d0] CServer::GetNodeValue - selectSingleNode
    [06/05/2011 14:14:16 12d0] CServer::GetNodeValue - get_firstChild
    [06/05/2011 14:14:16 12d0] CServer::GetNodeValue - get_nodeValue
    [06/05/2011 14:14:16 12d0] CServer::GetNodeValue - SysAllocString value: 34
    [06/05/2011 14:14:16 12d0] CoCreateInstance CLSID_DOMDocument60 succeeded.
    [06/05/2011 14:14:16 12d0] CServer::GetNodeValue - selectSingleNode
    [06/05/2011 14:14:16 12d0] CServer::GetNodeValue - get_firstChild
    [06/05/2011 14:14:16 12d0] CServer::GetNodeValue - get_nodeValue
    [06/05/2011 14:14:16 12d0] CServer::GetNodeValue - SysAllocString value: Administrator
    [06/05/2011 14:14:16 12d0] CoCreateInstance CLSID_DOMDocument60 succeeded.
    [06/05/2011 14:14:16 12d0] CServer::GetNodeValue - selectSingleNode
    [06/05/2011 14:14:16 12d0] CServer::GetNodeValue - get_firstChild
    [06/05/2011 14:14:16 12d0] CServer::GetNodeValue - get_nodeValue
    [06/05/2011 14:14:16 12d0] CServer::GetNodeValue - SysAllocString value: en-US
    [06/05/2011 14:14:16 12d0] CoCreateInstance CLSID_DOMDocument60 succeeded.
    [06/05/2011 14:14:16 12d0] CServer::GetNodeValue - selectSingleNode
    [06/05/2011 14:14:16 12d0] CServer::GetNodeValue - get_firstChild
    [06/05/2011 14:14:16 12d0] CServer::GetNodeValue - get_nodeValue
    [06/05/2011 14:14:16 12d0] CServer::GetNodeValue - SysAllocString value: 1033
    [06/05/2011 14:14:16 12d0] NetJoinChecker::QueryNetJoinStatus - Joining a Home server
    [06/05/2011 14:14:16 12d0] CSetup::RunTasks: Running Task: Id=-1 Description=Check Pending Reboot Index=  2
    [06/05/2011 14:14:16 13bc] CSetup::JoinComputerDlgProc: IDD_PROPPAGE_JOIN_COMPUTER Initialization
    [06/05/2011 14:14:16 13bc] CSetup::RunTasksDlgProc: IDD_PROPPAGE_TASKS Page Initialization
    [06/05/2011 14:14:16 1314] CSetup::Run: Deployment Stage = DeploymentStage_InstallingPreRequistes
    [06/05/2011 14:14:16 1314] CSetup::RunTasks: Running Task: Id=-1 Description=Check DotNet Fwk Index=  0
    [06/05/2011 14:14:16 1314] DotnetRule::CreateRules  (C:\Windows\Temp\Client Deployment Files\SupportedOs.Xml, .)
    [06/05/2011 14:14:16 1314] CoCreateInstance CLSID_DOMDocument60 succeeded.
    [06/05/2011 14:14:16 1314] CSetup::RunTasks: Running Task: Id=4 Description=Download Dot Net 4.0 Index=  1
    [06/05/2011 14:14:16 1314] CSetup::RunTasks: Running Task: Id=5 Description=Install Dot Net 4.0 Index=  2
    [06/05/2011 14:14:16 1314] RunShellExecute: ShellExecute [C:\Windows\Temp\Client Deployment Files\ClientDeploy.exe] with parameters [(null)]
    [06/05/2011 14:14:16 1314] CSetup::Run: Waiting upto 60secs for Sync Event to be signaled
    [06/05/2011 14:15:16 1314] CSetup::Run: WaitForSingleObject RetVal = 258
    [06/05/2011 14:15:16 1314] CSetup::Run: WaitForSingleObject TimedOut
    [06/05/2011 14:15:16 13bc] wmain: End of CSetup: hr=0x0
    [06/05/2011 14:33:53 13f0] --------------------------------------------------------------------------------------------------
    [06/05/2011 14:33:53 13f0] wmain: Start of CSetup
    [06/05/2011 14:33:53 13f0] CoCreateInstance CLSID_DOMDocument60 succeeded.
    [06/05/2011 14:33:53 13f0] CServer::GetNodeValue - selectSingleNode
    [06/05/2011 14:33:53 13f0] CServer::GetNodeValue - get_firstChild
    [06/05/2011 14:33:53 13f0] CServer::GetNodeValue - get_nodeValue
    [06/05/2011 14:33:53 13f0] CServer::GetNodeValue - SysAllocString value: SERVER
    [06/05/2011 14:33:53 13f0] CoCreateInstance CLSID_DOMDocument60 succeeded.
    [06/05/2011 14:33:53 13f0] CServer::GetNodeValue - selectSingleNode
    [06/05/2011 14:33:53 13f0] CServer::GetNodeValue - get_firstChild
    [06/05/2011 14:33:53 13f0] CServer::GetNodeValue - get_nodeValue
    [06/05/2011 14:33:53 13f0] CServer::GetNodeValue - SysAllocString value: fe80::c1b0:89b6:7b56:58e%13
    [06/05/2011 14:33:53 13f0] CoCreateInstance CLSID_DOMDocument60 succeeded.
    [06/05/2011 14:33:53 13f0] CServer::GetNodeValue - selectSingleNode
    [06/05/2011 14:33:53 13f0] CServer::GetNodeValue - get_firstChild
    [06/05/2011 14:33:53 13f0] CServer::GetNodeValue - get_nodeValue
    [06/05/2011 14:33:53 13f0] CServer::GetNodeValue - SysAllocString value: 34
    [06/05/2011 14:33:53 13f0] CoCreateInstance CLSID_DOMDocument60 succeeded.
    [06/05/2011 14:33:53 13f0] CServer::GetNodeValue - selectSingleNode
    [06/05/2011 14:33:53 13f0] CServer::GetNodeValue - get_firstChild
    [06/05/2011 14:33:53 13f0] CServer::GetNodeValue - get_nodeValue
    [06/05/2011 14:33:53 13f0] CServer::GetNodeValue - SysAllocString value: Administrator
    [06/05/2011 14:33:53 13f0] CoCreateInstance CLSID_DOMDocument60 succeeded.
    [06/05/2011 14:33:53 13f0] CServer::GetNodeValue - selectSingleNode
    [06/05/2011 14:33:53 13f0] CServer::GetNodeValue - get_firstChild
    [06/05/2011 14:33:53 13f0] CServer::GetNodeValue - get_nodeValue
    [06/05/2011 14:33:53 13f0] CServer::GetNodeValue - SysAllocString value: en-US
    [06/05/2011 14:33:53 13f0] CoCreateInstance CLSID_DOMDocument60 succeeded.
    [06/05/2011 14:33:53 13f0] CServer::GetNodeValue - selectSingleNode
    [06/05/2011 14:33:53 13f0] CServer::GetNodeValue - get_firstChild
    [06/05/2011 14:33:53 13f0] CServer::GetNodeValue - get_nodeValue
    [06/05/2011 14:33:53 13f0] CServer::GetNodeValue - SysAllocString value: 1033
    [06/05/2011 14:33:53 13f0] GlobalData::Initialize ([fe80::c1b0:89b6:7b56:58e], 65510, C:\Windows\Temp\Client Deployment Files\CSetup.exe, 1033)
    [06/05/2011 14:33:53 13f0] ExpandEnvironmentStrings return (C:\Windows\Temp\Client Deployment Files\)
    [06/05/2011 14:33:53 13f0] wmain: Calling CSetup::ShowWizard()
    [06/05/2011 14:33:53 13f0] CSetup::ShowWizard: Initializing common controls
    [06/05/2011 14:33:53 13f0] CSetup::ShowWizard: Done initializing common controls
    [06/05/2011 14:33:53 13f0] Displaying the wizard
    [06/05/2011 14:33:53 13f0] CSetup::WelcomeDlgProc: IDD_PROPPAGE_WELCOME Initialization
    [06/05/2011 14:33:53 13f0] CSetup::WelcomeDlgProc: Set the Deployment Sync Event
    [06/05/2011 14:33:55 13f0] CSetup::RunTasksDlgProc: IDD_PROPPAGE_TASKS Page Initialization
    [06/05/2011 14:33:55  27c] CSetup::Run: Deployment Stage = DeploymentStage_VerifyingRequirements
    [06/05/2011 14:33:55  27c] CSetup::RunTasks: Running Task: Id=-1 Description=Check OS Version and SP Index=  0
    [06/05/2011 14:33:55  27c] OsChecker::CreateInstance ([C:\Windows\Temp\Client Deployment Files\SupportedOs.Xml])
    [06/05/2011 14:33:55  27c] =================================
    [06/05/2011 14:33:55  27c] Current Os information:
    [06/05/2011 14:33:55  27c] Suite = [256]
    [06/05/2011 14:33:55  27c] Type = [1]
    [06/05/2011 14:33:55  27c] Architecture = [9]
    [06/05/2011 14:33:55  27c] IsStarterEdition = [0]
    [06/05/2011 14:33:55  27c] IsHomeSku = [0]
    [06/05/2011 14:33:55  27c] Major = [6]
    [06/05/2011 14:33:55  27c] Minor = [1]
    [06/05/2011 14:33:55  27c] Build = [7601]
    [06/05/2011 14:33:55  27c] SPMajor = [1]
    [06/05/2011 14:33:55  27c] SPMinor = [0]
    [06/05/2011 14:33:55  27c] =================================
    [06/05/2011 14:33:55  27c] OSRule::CreateRules  (C:\Windows\Temp\Client Deployment Files\SupportedOs.Xml, .)
    [06/05/2011 14:33:55  27c] CoCreateInstance CLSID_DOMDocument60 succeeded.
    [06/05/2011 14:33:55  27c] OsChecker::QuerySupportedOsStatus - Major: 6 Minor: 1
    [06/05/2011 14:33:55  27c] CSetup::RunTasks: Running Task: Id=-1 Description=Check Net Join Index=  1
    [06/05/2011 14:33:55  27c] NetJoinChecker::CreateInstance ([C:\Windows\Temp\Client Deployment Files\ServerInfo.Xml])
    [06/05/2011 14:33:55  27c] CMsi::IsMsiInstalled: MsiQueryProductState for ProductCode {21E49794-7C13-4E84-8659-55BD378267D5} returned -1
    [06/05/2011 14:33:55  27c] CMsi::IsMsiInstalled: MsiQueryProductState for ProductCode {46DCED50-3A1D-4EF4-94F0-45F2681E3D70} returned -1
    [06/05/2011 14:33:55  27c] CMsi::IsMsiInstalled: MsiQueryProductState for ProductCode {C1E4D639-4A33-4314-809E-89BD0EF48522} returned -1
    [06/05/2011 14:33:55  27c] CoCreateInstance CLSID_DOMDocument60 succeeded.
    [06/05/2011 14:33:55  27c] CServer::GetNodeValue - selectSingleNode
    [06/05/2011 14:33:55  27c] CServer::GetNodeValue - get_firstChild
    [06/05/2011 14:33:55  27c] CServer::GetNodeValue - get_nodeValue
    [06/05/2011 14:33:55  27c] CServer::GetNodeValue - SysAllocString value: SERVER
    [06/05/2011 14:33:55  27c] CoCreateInstance CLSID_DOMDocument60 succeeded.
    [06/05/2011 14:33:55  27c] CServer::GetNodeValue - selectSingleNode
    [06/05/2011 14:33:55  27c] CServer::GetNodeValue - get_firstChild
    [06/05/2011 14:33:55  27c] CServer::GetNodeValue - get_nodeValue
    [06/05/2011 14:33:55  27c] CServer::GetNodeValue - SysAllocString value: fe80::c1b0:89b6:7b56:58e%13
    [06/05/2011 14:33:55  27c] CoCreateInstance CLSID_DOMDocument60 succeeded.
    [06/05/2011 14:33:55  27c] CServer::GetNodeValue - selectSingleNode
    [06/05/2011 14:33:55  27c] CServer::GetNodeValue - get_firstChild
    [06/05/2011 14:33:55  27c] CServer::GetNodeValue - get_nodeValue
    [06/05/2011 14:33:55  27c] CServer::GetNodeValue - SysAllocString value: 34
    [06/05/2011 14:33:55  27c] CoCreateInstance CLSID_DOMDocument60 succeeded.
    [06/05/2011 14:33:55  27c] CServer::GetNodeValue - selectSingleNode
    [06/05/2011 14:33:55  27c] CServer::GetNodeValue - get_firstChild
    [06/05/2011 14:33:55  27c] CServer::GetNodeValue - get_nodeValue
    [06/05/2011 14:33:55  27c] CServer::GetNodeValue - SysAllocString value: Administrator
    [06/05/2011 14:33:55  27c] CoCreateInstance CLSID_DOMDocument60 succeeded.
    [06/05/2011 14:33:55  27c] CServer::GetNodeValue - selectSingleNode
    [06/05/2011 14:33:55  27c] CServer::GetNodeValue - get_firstChild
    [06/05/2011 14:33:55  27c] CServer::GetNodeValue - get_nodeValue
    [06/05/2011 14:33:55  27c] CServer::GetNodeValue - SysAllocString value: en-US
    [06/05/2011 14:33:55  27c] CoCreateInstance CLSID_DOMDocument60 succeeded.
    [06/05/2011 14:33:55  27c] CServer::GetNodeValue - selectSingleNode
    [06/05/2011 14:33:55  27c] CServer::GetNodeValue - get_firstChild
    [06/05/2011 14:33:55  27c] CServer::GetNodeValue - get_nodeValue
    [06/05/2011 14:33:55  27c] CServer::GetNodeValue - SysAllocString value: 1033
    [06/05/2011 14:33:55  27c] NetJoinChecker::QueryNetJoinStatus - Joining a Home server
    [06/05/2011 14:33:55  27c] CSetup::RunTasks: Running Task: Id=-1 Description=Check Pending Reboot Index=  2
    [06/05/2011 14:33:55 13f0] CSetup::JoinComputerDlgProc: IDD_PROPPAGE_JOIN_COMPUTER Initialization
    [06/05/2011 14:33:56 13f0] CSetup::RunTasksDlgProc: IDD_PROPPAGE_TASKS Page Initialization
    [06/05/2011 14:33:56  968] CSetup::Run: Deployment Stage = DeploymentStage_InstallingPreRequistes
    [06/05/2011 14:33:56  968] CSetup::RunTasks: Running Task: Id=-1 Description=Check DotNet Fwk Index=  0
    [06/05/2011 14:33:56  968] DotnetRule::CreateRules  (C:\Windows\Temp\Client Deployment Files\SupportedOs.Xml, .)
    [06/05/2011 14:33:56  968] CoCreateInstance CLSID_DOMDocument60 succeeded.
    [06/05/2011 14:33:56  968] CSetup::RunTasks: Running Task: Id=4 Description=Download Dot Net 4.0 Index=  1
    [06/05/2011 14:33:56  968] CSetup::RunTasks: Running Task: Id=5 Description=Install Dot Net 4.0 Index=  2
    [06/05/2011 14:33:56  968] RunShellExecute: ShellExecute [C:\Windows\Temp\Client Deployment Files\ClientDeploy.exe] with parameters [(null)]
    [06/05/2011 14:33:56  968] CSetup::Run: Waiting upto 60secs for Sync Event to be signaled
    [06/05/2011 14:34:56  968] CSetup::Run: WaitForSingleObject RetVal = 258
    [06/05/2011 14:34:56  968] CSetup::Run: WaitForSingleObject TimedOut
    [06/05/2011 14:34:56 13f0] wmain: End of CSetup: hr=0x0

     =======End of Log=======

     

    I've manually removed all refences to Home Server in the registry and renamed all of the old WHS folders I can find to "Old_".

    I've even uninstalled .Net 4.0 and re-installed it.

    Any suggestions would be great.


    Dr. Henry "Indiana" Jones, Jr.
    Sunday, June 5, 2011 8:51 PM

All replies

  • Did you figure out what the problem was -- I'm having trouble deploying the connector a new Win7 SP1 machine, also because of a ClientDeploy exception. I'd appreciate any insights you have.

     

    Thanks.

    Monday, June 6, 2011 5:35 PM
  • No, still no solution. I plugged away at it for about three hours the other night and no joy. System Restore doesn't go back far enough, so the only choice is moving forward.

    I'm suspecting it has something to do with .Net 4.0, but that's just a hunch more than it based on fact.


    Dr. Henry "Indiana" Jones, Jr.
    Wednesday, June 8, 2011 2:06 PM
  • Make sure the machine you're trying to install on has the following two services enabled Windows Media Center Receiver Service and Windows Media Center Scheduler Service
    • Proposed as answer by jtrout Saturday, July 28, 2012 3:47 PM
    Thursday, June 9, 2011 9:05 PM
  • Rich, THANK YOU. I've spent hours trying to get the connector to install on my laptop, and I've tried every solution under the sun. My Windows Media Center services were disabled, and enabling them got the connector installed (FINALLY). You are officially my hero.

    ~JT

    Saturday, July 28, 2012 3:48 PM