locked
Removed drive via registry, how to force re-duplication on files that were on that drive? RRS feed

  • Question

  • Drive died, I was unable to remove it from the Storage Pool in order to get WHS to start duplicating the files again.  I finally ended up removing the drive by removing the references to it in the registry, but now I'm unsure how to get WHS to duplicate the files that are only sitting on one drive now.  I have enough room with the new drives that have been added, but it doesn't seem to be doing it on its own.  Any ideas?
    Monday, December 6, 2010 3:30 AM

All replies

  • Editing the registry to remove a drive isn't supported, and isn't sufficient to remove a drive anyway. If you can't remove a drive using the console, the recommended course of action is to disconnect the drive and try removing it again.

    In your case, as a practical matter you will probably find that it will take less time, and offer significantly less risk to your data, to remove one or more drives from your storage pool, disconnect all but your system drive and the drive or drives you removed from server storage, recover the data on the D: partition of the system drive per this FAQ, then do a new installation on just the system drive (and any extra drives you were able to free up). After that, use the same FAQ to copy your files back into your shares. As you finish with drives you can add them into the storage pool again.


    I'm not on the WHS team, I just post a lot. :)
    Monday, December 6, 2010 4:57 AM
    Moderator
  • I did disconnect the drive and tried removing it again.  I reconnected it and tried removing again, rebooted and tried again, etc.  After failing for the 20th time I went looking for an alternate method to resolve the problem and came across this thread:

    http://social.microsoft.com/forums/en-US/whssoftware/thread/9e3c5131-9945-44f9-b94e-562138060d70/

    I'm rather technically savvy, but this OS is supposed to be geared towards the home user...what would the recommended resolution be for a home user who was unable to remove a failed drive to rebuild data?  Surely the answer isn't "reinstall the entire OS".  What if this were one of the OEM boxes with no optical drive or even a VGA port?  The operating system can see all of my data, how is it that it cannot re-duplicate it?  Isn't this supposed to be the entire point of duplication?

    Monday, December 6, 2010 5:47 AM
  • When you manipulate drives and volumes outside of the Windows Home Server console, you're taking a risk, because you're doing something that Windows Home Server doesn't understand. In this particular case, I'm not sure what exactly happened initially to cause your problem, but following the procedure you used probably exacerbated your initial issue. I'm proposing the data recovery as a practical alternative to experimenting with this and that trying to get everything working again, because A) it may well take less time than an as-yet-undefined exploration of the issue (i.e. a "fishing expedition"), and B) because it certainly represents less risk to your data. Assuming duplication was turned on for all shares, all of your data is still on your server; something (not necessarily what you did, but something) has managed to break Drive Extender, but your data should still be available on disk. Obviously I'm presuming that you'll place data safety and speed of recovery above "fixing the issue".

    As for an OS reinstallation being a recovery method: Yes it is, indeed it's the only supported recovery method. Remember that Windows Home Server is an OEM/system builder product, not something that a consumer can buy at retail (shelfware). OEM servers are required to have no keyboard, video, or mouse ports on the outside of the case, and they are required to have a method of recovering the server from a workstation. System builders aren't required to follow the same guidelines, but in theory (not usually in reality because most system builder software is bought by individuals rather than the intended target) they're expected to be small computer shops  such as your corner computer store that will provide some support when you have this sort of issue.


    I'm not on the WHS team, I just post a lot. :)
    Monday, December 6, 2010 3:02 PM
    Moderator
  • I backed up the registry keys before removing them.  If I were to restore the 2 keys removed so that the console thinks that the drive is there again, what should I do in order to troubleshoot the "unable to remove drive from Storage Pool" error?

     

    Thanks for the help, btw.

    Monday, December 6, 2010 3:51 PM
  • You can try putting them back. I don't guarantee anything, however. Assuming Windows Home Server does recognize the drive afterward, try:

    • Shut the server down
    • Physically remove the drive (at least disconnect the data cable)
    • Boot it up
    • Remove the "missing" drive using the console.

     If that doesn't work (and I don't have your server sitting in front of me to be able to tell if it might) you'll probably have to go through that data recovery effort I alluded to earlier.


    I'm not on the WHS team, I just post a lot. :)
    Monday, December 6, 2010 6:17 PM
    Moderator
  • Fun times.  Well, I just reimported the keys referring to the failed disk, rebooting now with fingers crossed.  Going to try and remove the disk again with it unplugged/plugged in/hotplug/any other combination I can think of.  In the event of total failure again, I suppose I'll start restoring from backups :(
    Tuesday, December 7, 2010 2:06 AM
  • I got annoyed and sat there trying to remove it over and over and suddenly it just worked after about the 20th time...weird.  Now I can still see the files but it doesn't appear to want to re-duplicate them :/  I'm manually restoring the files with issues from backups...Once I get things running and confirm that I didn't lose anything, I'm going ZFS, this makes the 2nd time I've had issues with WHS in less than two years.  The last failure required a reinstallation as well, and now that Vail appears to have been nuetered(no DE) I can't see any reason to keep my filer in a Windows environment any longer.

     

    Ken, thanks for the advice throughout this ordeal, I appreciate that you attempted to help me through this problem.

    Tuesday, December 7, 2010 4:50 AM