Netbios disable cannot connect to AD but DNS is turn on.Pls help RRS feed

  • Question

  • On my Windows Server 2003 R2, I have disabled NetBIOS according to procedure
    found in Technet:
    ------------------------------ Start
    procedure ------------------------------------------------
    To disable NetBIOS over TCP/IP
    1.From the Start menu, right-click My Computer , and then click Manage.
    2.Expand System Tools, and then clear the Device Manager check box.
    3.Right-click Device Manager, point to View, and then select Show hidden
    4.Expand Non-Plug and Play Drivers .
    5.Right-click NetBios over TCP/IP, and then click Disable.

    Note: This disables the SMB direct host listener on TCP/445 and UDP 445.
    This procedure disables the netbt.sys driver. The WINS tab of the Advanced
    TCP/IP Settings dialog box contains a Disable NetBIOS over TCP/IP option.
    Selecting this option only disables the NetBIOS Session Service (which
    listens on TCP port 139). It does not disable NetBIOS completely.
    ------------------------------ End
    procedure ------------------------------------------------
    After I restarted the Server , a message came up saying that at least 1
    service was not started. To lose this message I wenjt to services and
    disabled the NetBIOS Helper service.

    My domain is like xxx.local. It´s NetBIOS name was XXXLOCAL.
    When I now try to connect a Workstation to the domain, it cannot find a
    domain controller.
    It did before, but even then, it connected to XXXLOCAL and not to eee.local
    The workstation´s DNS Server is pointed to, so it should be able
    to find it

    My network setup:
    1 Novell server:
    1 adsl router (this is the only gateway in this subnet):
    1 Windows 2003 R2 SP2 server I have setup as follows:
    Configured as DC, DNS, DHCP and File Server
    Domain suffix: --
    IP address :
    DNS Servers:
    LAN2: Disabled

    Can anyone help, please?
    Thanks Calvin<input id="gwProxy" type="hidden"><!-- Session data--></input> <input id="jsProxy" onclick="jsCall();" type="hidden" />
    Tuesday, February 9, 2010 2:32 AM