locked
You do not have sufficient permission to perform the operation on the specified organization database- MS CRM 2011 RRS feed

  • Question

  • Hi All,

    I am gettingn the below error message while importing the organization from MS CRM 4.0 to MS CRM 2011.

    I am importing the organization using service account and the same account was added as db owner in the DB which I was trying to impot. It would be greate if you provide the solution. 

    Thanks

    Srikanth


    Wednesday, June 11, 2014 10:43 AM

All replies

  • The user who is installing CRM should be a user of SQL server with admin rights

    Regards Faisal

    Wednesday, June 11, 2014 2:32 PM
  • In SQL MGT Studio, connect to the Database Engine with an Admin user;

    Browse to the "Security" folder, open it up to reveal the "Logins" sub-folder;

    Right-click, "New Login" and add desired user

    You should be able then to clear up the error in CRM's installation.

    Tuesday, March 3, 2015 9:24 PM
  • The Import Wizard checks if the logged-on user is a System Administrator in SQL, and if not, throws this error. If you can get System Administrator rights, then this is the simplest solution.

    Alternatively, I think you can get around this without having System Administrator rights:

    • Add the IgnoreChecks registry value to allow you to get past the error in the wizard
    • The import process will check if the CRM Sql logins (SqlAccessGroup, ReportingGroup and PrivReportingGroup) exist. For this, your account will need to be a member of the securityadmin server role, or you could just have the VIEW DEFINITION object permission on each of these logins

    Microsoft CRM MVP - http://mscrmuk.blogspot.com/ http://www.excitation.co.uk

    Tuesday, March 3, 2015 10:45 PM
    Moderator