CRM 2013 - After Organization Import users receive - "Insufficient Permissions" error RRS feed

  • Question

  • Hi,

    I recently had to rebuild my CRM 2013 server and had to import my organization to the new server.  This organization had previously been a 2011 organization that had been imported into 2013 without problems.

    When going through the import, I chose to the user auto-mapping (some of the users exist in AD and mapped fine, others didn't and I left them).  The import when very quickly without issue.

    However, when I go to access CRM, I can view dashboards, view grids but when I click on a row in anything (i.e., security, accounts, contacts, etc) - I am presented with the following error message.

    "Insufficient Permissions" - "You do not have permission to access these records"

    Looking in the event log I see errors akin to - "Principal user (Id=GUID, type=8) is missing prvReadmsdyn_PostConfig privilege - which I gather is related to the Activity Feeds?  I've tried removing this role and re-adding it and still no luck.

    On this org, we haven't customized any of the permissions or change anything that they do so I'm not sure why this would be breaking.

    Any ideas how to fix this?

    Thanks - Greg

    Greg Thomas http://lync.openjive.com

    Sunday, May 4, 2014 1:27 AM

All replies

  • From the error log, the privilege missing is Read permission of Post Configuration.


    Sunday, May 4, 2014 2:33 AM
  • Yes, thank you.  I did check these permissions (located under the Custom security tab) and they were all checked, save for one role - delegate - where I added.

    This had no effect on the system.

    It seems as though my user has all the correct permissions but CRM does not see that?


    Greg Thomas http://lync.openjive.com

    Tuesday, May 6, 2014 2:13 AM
  • Can you check that the users are in the correct business unit, and that they are members of the correct security role(s)

    Microsoft CRM MVP - http://mscrmuk.blogspot.com/ http://www.excitation.co.uk

    Tuesday, May 6, 2014 8:29 AM
  • Hi,

    The users in question (5) all belong to the same business unit (and there is only one) and they belong to all roles which have Post Configuration set.

    The only difference between this org and my other orgs, is that this was an org that was upgraded from 2011.

    Not sure how big an impact that is.

    Greg Thomas http://lync.openjive.com

    Tuesday, May 6, 2014 11:57 AM
  • You may want to install the latest rollup on the CRM 2011 server prior to taking a new backup of the organization and importing it into CRM 2013. It is likely that the original org database is missing a column that was added by a rollup. I believe rollup 11 added a new column for the security roles.

    Jason Peterson

    Tuesday, May 6, 2014 4:24 PM