locked
OCS 2007 R2 Asterisk 1.6 Integration RRS feed

  • Question

  • Currently we have a 2 OCS2007 R2 servers one doing front end the other doing mediation.  Currently I am trying to work on getting MOC to dial to xlite and xlite to dial to MOC.  Could anyone point me to any resources to get this working.  I have tried muiltple articles and can not seem to get anything working.

    It does look like it is doing something.  When I make a call from MOC to xlite I get the following.

     == Using SIP RTP CoS mark 5
      == Using SIP VRTP CoS mark 6


    Any help would be great.

    Thanks in advance.
    Ray
    Monday, October 12, 2009 6:43 PM

Answers


  • Hi Ray,

    I'm guessing you left out the part that says you are using Asterisk 1.6 with X-Lite connect to it?

    So it looks like this?

    MOC -> OCS server -> OCS Mediation -> Asterisk -> XLite

    Correct?


    Try Geoff's blog - it's a good starting point.

    http://blogs.technet.com/gclark/archive/2008/10/09/asterisk-1-6-with-office-communications-server-2007.aspx



    There can be a few 'things' to watch out for, such as DNS & NAT settings - plus the gateway normalisation rules from OCS.

    Come back with specific questions if you cannot get this to work.  Please try to include some errors & details.


    I have this setup in a live environment - works great & has been extremly stable.


    Regards

    Paul
    Tuesday, October 13, 2009 9:10 PM

All replies

  • Sorry Xlite will not work direktly with an OCS Enviroment.

    You can use a SIP Gateway to translate the XLITE SIP Communication to the Mediation Server or you can use the SMARTSIP from Evangelyze.

    http://www.evangelyze.net/products.asp#SmartSIP

    With this solution, you can use every sip softclient or SIP Phone.


    regards
    Holger Bunkradt
    Tuesday, October 13, 2009 7:13 AM

  • Hi Ray,

    I'm guessing you left out the part that says you are using Asterisk 1.6 with X-Lite connect to it?

    So it looks like this?

    MOC -> OCS server -> OCS Mediation -> Asterisk -> XLite

    Correct?


    Try Geoff's blog - it's a good starting point.

    http://blogs.technet.com/gclark/archive/2008/10/09/asterisk-1-6-with-office-communications-server-2007.aspx



    There can be a few 'things' to watch out for, such as DNS & NAT settings - plus the gateway normalisation rules from OCS.

    Come back with specific questions if you cannot get this to work.  Please try to include some errors & details.


    I have this setup in a live environment - works great & has been extremly stable.


    Regards

    Paul
    Tuesday, October 13, 2009 9:10 PM