locked
.NET Runtime 2.0 Error Reporting RRS feed

  • Question

  • I used SyncToy so far without any problems. Since Dec 29th I get the following error (see below, one instance from application log). Once the error occurs it's nearly impossible to get SyncToy running again. The only way so far is to reboot and to use SyncToy before running other applications. I'm not sure if this might be a reason. But I couldn't figure out when the problem occurs. Are there any tools, logs to narrow down the problem?

    Any help is appreciated.

    TIA
    KJ




    Ereignistyp:    Fehler
    Ereignisquelle:    .NET Runtime 2.0 Error Reporting
    Ereigniskategorie:    Keine
    Ereigniskennung:    5000
    Datum:        29.12.2008
    Zeit:        22:59:04
    Benutzer:        Nicht zutreffend
    Computer:    VIENNE
    Beschreibung:
    EventType clr20r3, P1 synctoy.exe, P2 2.0.100.0, P3 48a0aad1, P4 system.windows.forms, P5 2.0.0.0, P6 4889dee7, P7 16e9, P8 e4, P9 system.componentmodel.win32, P10 NIL.

    Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.
    Daten:
    0000: 63 00 6c 00 72 00 32 00   c.l.r.2.
    0008: 30 00 72 00 33 00 2c 00   0.r.3.,.
    0010: 20 00 73 00 79 00 6e 00    .s.y.n.
    0018: 63 00 74 00 6f 00 79 00   c.t.o.y.
    0020: 2e 00 65 00 78 00 65 00   ..e.x.e.
    0028: 2c 00 20 00 32 00 2e 00   ,. .2...
    0030: 30 00 2e 00 31 00 30 00   0...1.0.
    0038: 30 00 2e 00 30 00 2c 00   0...0.,.
    0040: 20 00 34 00 38 00 61 00    .4.8.a.
    0048: 30 00 61 00 61 00 64 00   0.a.a.d.
    0050: 31 00 2c 00 20 00 73 00   1.,. .s.
    0058: 79 00 73 00 74 00 65 00   y.s.t.e.
    0060: 6d 00 2e 00 77 00 69 00   m...w.i.
    0068: 6e 00 64 00 6f 00 77 00   n.d.o.w.
    0070: 73 00 2e 00 66 00 6f 00   s...f.o.
    0078: 72 00 6d 00 73 00 2c 00   r.m.s.,.
    0080: 20 00 32 00 2e 00 30 00    .2...0.
    0088: 2e 00 30 00 2e 00 30 00   ..0...0.
    0090: 2c 00 20 00 34 00 38 00   ,. .4.8.
    0098: 38 00 39 00 64 00 65 00   8.9.d.e.
    00a0: 65 00 37 00 2c 00 20 00   e.7.,. .
    00a8: 31 00 36 00 65 00 39 00   1.6.e.9.
    00b0: 2c 00 20 00 65 00 34 00   ,. .e.4.
    00b8: 2c 00 20 00 73 00 79 00   ,. .s.y.
    00c0: 73 00 74 00 65 00 6d 00   s.t.e.m.
    00c8: 2e 00 63 00 6f 00 6d 00   ..c.o.m.
    00d0: 70 00 6f 00 6e 00 65 00   p.o.n.e.
    00d8: 6e 00 74 00 6d 00 6f 00   n.t.m.o.
    00e0: 64 00 65 00 6c 00 2e 00   d.e.l...
    00e8: 77 00 69 00 6e 00 33 00   w.i.n.3.
    00f0: 32 00 20 00 4e 00 49 00   2. .N.I.
    00f8: 4c 00 0d 00 0a 00         L..... 

    Monday, January 5, 2009 8:10 PM

Answers

  • Because I had troubles again when running command in the CygWin environment I searched the Web and found some hints to LogTech webcam software (especially service "Process Monitor"). Then I checked the installation date (Dec 28th!!!). Henc I think when this service should be the reason for the CygWin troubles it might also be the reason for SynToy failing from time to time. Currently I stopped the service and there was no problem running SyncToy. But I'll check this issue the next sync runs.
    The links I mentioned above may be found here:
    http://myutil.com/2007/10/14/cygwin-quickcam-fatal-error
    http://forums.logitech.com/logitech/board/message?board.id=quickcam_software&message.id=897

    I didn't reinstall SyncToy nor .NET 2.0 so far.

    Tuesday, January 13, 2009 11:11 PM

All replies

  • Did remember installing or upgrading anything just before that date? I would try re-installing the .NET Framework and then SyncToy to see if this resolves itself.

     

    Wednesday, January 7, 2009 6:35 PM
  • I always try to keep my software  up-to-date. But just before I created another (second) user with restricted access on my box and I installed Security Update for CAPICOM (KB931906) right on Dec 29th. But I'll also try to reinstall .NET Framework 2.0 as well as SyncToy. Is there a log where all updates have been logged? 
    Wednesday, January 7, 2009 10:24 PM
  • Control Panel -> Programs has a list of all the programs you install, and if you check the "Updates" option, it also shows you the stuff you have installed using Microsoft Update or Windows Update.
    Thursday, January 8, 2009 9:23 PM
  • I checked the update History of Windows Updates. The only Update installed was that CAPICOM update on Dec 29th.
    Today I noticed that even after 3 failures SyncToy worked. I had another session CygWin and running commands there I got a message like "can't allocate memory from heap". I've got that message never before and it seems as if this issues are related. I've 1GB of Memory and actually 850MB are being used. May be it's a memory allocation problem?
    Friday, January 9, 2009 10:41 PM
  • Because I had troubles again when running command in the CygWin environment I searched the Web and found some hints to LogTech webcam software (especially service "Process Monitor"). Then I checked the installation date (Dec 28th!!!). Henc I think when this service should be the reason for the CygWin troubles it might also be the reason for SynToy failing from time to time. Currently I stopped the service and there was no problem running SyncToy. But I'll check this issue the next sync runs.
    The links I mentioned above may be found here:
    http://myutil.com/2007/10/14/cygwin-quickcam-fatal-error
    http://forums.logitech.com/logitech/board/message?board.id=quickcam_software&message.id=897

    I didn't reinstall SyncToy nor .NET 2.0 so far.

    Tuesday, January 13, 2009 11:11 PM