Manually Removing CRM 3.0 crisis... RRS feed

  • Question

  • There is a lot of history to this post, so thanks for taking a look and reading through it. I am not sure what else to try to get things working. Here's the error whenever I try to install CRM on the machines in question: "There is already an incompatible version installed that needs to be removed before the CRM installer can continue."


    Here is the history:

    My company has undergone a domain switch from an old 2000 environment to a 2003 environment (thank god). This included transitioning our 03 exchange server and CRM 3.0 server. This also meant transitioning user profiles for all our desktops and laptops. The servers all switched over fine and any new CRM clients can get setup without any issues.


    The problem comes for those who had the off-line mode of CRM installed before the switch. "Online only" users we've been able to reg hack our way through to a solution, but no such luck with off-line mode. Basically, if we try to uninstall CRM from add/remove programs it acts as though it will remove, but then launches an installer instead of an uninstaller... This is where everything starts to break. Since then I've tried everything to get CRM removed so I can reinstall it from scratch, because it doesn't work and it won't uninstall/reinstall properly.


    The error during a reinstall says that; "There is already an incompatible version installed that needs to be removed before the CRM installer can continue."


    So far I've tried;

    - Removing from add/remove programs, which removes it from the list and then launches the crm installer somehow (which also doesn't work).

    - Deleting any and all MSCRM registry keys.

    - Uninstalling SQL Server 05 and deleting associated registry keys.

    - Stopping the indexing service.

    - Deleting CRM data files, pst files, and deleting the MSCRM and SQL Server folders left inside c:\program files

    - Ending and terminating any services that may be related to CRM or SQL Server. (That I'm aware of)

    - I went through two technet articles that went into registry stuff for sql server and GUID's and such.

    This is one of them:

    - I've tried removing under a different user account or reinstalling under a different user, it still fails.

    - I've tried all the same steps in a safe mode environment.


    What is worse, is each time I try, the installer brings back a lot of the registry keys and particular CRM files - even though it never gets past its initial system check... I know this has something to do with how the profiles were transitioned over to the new domain. It must have seriously broken something in the registry is my guess. I am hoping there are some gurus out there who might be able to point me the right way. Any similair experiences?


    If you've made it to the end of this, wow!! Thank you!

    - John (the frustrated CRM newbie)

    Friday, January 18, 2008 12:29 AM


All replies