none
VB .NET and ODP.NET RRS feed

  • Question

  • Hello, I am new to .NET and ODP.NET. I am required to use an Oracle Database for a project so that's why I am using ODP.NET. 

    I have my application finished and it works on my local machine but when I publish it and move the files to another computer that does not have Oracle tools installed, the application crashes before install because Oracle.DataAccess is not inside of the users GAC.
    I am using Visual Studio 2013 and VB .NET and I added the reference Oracle.DataAccess to my project (there is two, I have tried to v2 and v4). I also tried building the project for Any CPU, x86, and x64 to see if there was any difference, there wasn't. I also tried turning on "Copy locally" for the Oracle.DataAccess.dll and with that on, it installs on the computer with no Oracle tools installed but it immediately errors and crashes the program with an "unexpected error", the event logs for the errors when it crashes are below:

    Event 1026, .NET Runtime

    Application: Leather Store Application.exe
    Framework Version: v4.0.30319
    Description: The process was terminated due to an unhandled exception.
    Exception Info: System.InvalidOperationException
    Stack:
       at Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.DoApplicationModel()
       at Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.Run(System.String[])
       at cs425Project.My.MyApplication.Main(System.String[])

    ------------------------------------------------------------------------

    Event 1000, Application Error

    Faulting application name: Leather Store Application.exe, version: 1.0.0.0, time stamp: 0x53366fa2
    Faulting module name: KERNELBASE.dll, version: 6.1.7601.17514, time stamp: 0x4ce7c78c
    Exception code: 0xe0434352
    Fault offset: 0x000000000000a49d
    Faulting process id: 0xd30
    Faulting application start time: 0x01cf4b1d9fd48a8f
    Faulting application path: C:\Users\TLap\AppData\Local\Apps\2.0\ECYT016V.4E2\VRO01BRL.KCL\leat..tion_472d4007eddc08ab_0001.0000_42e67081ac33ffc5\Leather Store Application.exe
    Faulting module path: C:\Windows\system32\KERNELBASE.dll

    Is there a way to get DataAccess.dll into the users GAC, or somehow get around having it? Both my machines I am testing it on are Windows 7 Professional x64.

    • Moved by Amanda Zhu Monday, March 31, 2014 8:06 AM
    Saturday, March 29, 2014 9:10 PM

All replies

  • Hello,

    Thank you for your post.

    I am afraid that the issue is out of support range of VS General Question forum which mainly discusses the usage issue of Visual Studio IDE such as WPF & SL designer, Visual Studio Guidance Automation Toolkit, Developer Documentation and Help System and Visual Studio Editor.

    Because your issue is on Oracel DataAccess.dll which is third-party, it is out of support range of our forums, please consult on your issue on forums/community provided by Oracel for better support.

    Best regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, March 31, 2014 8:06 AM