locked
Crm VPC crm link not working after ip change RRS feed

  • Question

  • I am using the Crm VPC 2009 version to do me dev work. I changed the network connection's tcp/ip protocal's property to auto detect to enable myself to access the Internet. However since then the crm link http://crm/contoso/loader.aspx is not working any more. Just wondering why?

    Pretty sure there is some sort of mapping between http://[hardcoded ip]/crm and http://crm. But don't know where and how to change it.

    Thanks in advance
    Monday, February 8, 2010 8:32 AM

Answers

  • I had a same issue and you will need edit DNS settings or if it's easier for you hosts file to put information 127.0.0.1 crm
    after this everything will be working.
    My Dynamics CRM Blog: http://bovoweb.blogspot.com
    • Marked as answer by Jim Glass Jr Monday, February 8, 2010 4:09 PM
    Monday, February 8, 2010 9:29 AM

All replies

  • I had a same issue and you will need edit DNS settings or if it's easier for you hosts file to put information 127.0.0.1 crm
    after this everything will be working.
    My Dynamics CRM Blog: http://bovoweb.blogspot.com
    • Marked as answer by Jim Glass Jr Monday, February 8, 2010 4:09 PM
    Monday, February 8, 2010 9:29 AM
  • In the CRM VPC the network settings are fixed, and you can try setting up the network card to automatically get an IP-address and DNS Server. That should do the trick.
    Henrik Jensen Instructor / Consultant MCP, MCAD, MCSD, MCTS, MCPD, MCITP, MBSS, MBSP, MCT www.crmblog.dk (Danish only)
    Monday, February 8, 2010 4:06 PM
  • If you don't want to fiddle with DNS or hosts file. Just use http://localhost/ that'd work too.
    Sun - MSCRM Specialist @ Intergen, Sunny (slightly breezy)Wellington, New Zealand. http://sundium.wordpress.com
    Monday, February 8, 2010 8:04 PM
  • Thanks fellows! Thanks for all the support!

    Need to point out the 127.0.0.1 or localhost will NOT work until you remove the host header value for the site from the iis. I think that is because the iis try to use the DNS to resolve the host header.

    Cheers.
    Monday, February 8, 2010 11:04 PM
  • Hi

    I am having a similiar issue. I am connecting to CRM installed on a vpc. The development code that needs the connection is on my computer.

    in setting up base url property of CMSCRMDYNAMICENTITY object, I am getting a http 404 not found exception (Cannot connect to http:/vm-name/MSCrmServices/2007/CrmService.asmx). I used the same url for ie and got the same exception. then I used ip address instead of vm-name in url, that worked.

    Seeing that, I tried the following in host file (separately) but it did not work.

    192.168.12.12 http://vm-name/MSCrmServices/2007/CrmService.asmx

    192.168.12.12 http://vm-name/

    192.168.12.12  vm-name

     

    Any suggestions on how to resolve this?

    Monday, August 30, 2010 3:54 PM