locked
Windows phone connector issues in home network RRS feed

  • Question

  • I have issues connecting to my whs 2011 using windows phone connector in home WLAN. Remote access (outside home network) is working but in home network using WLAN it is not. My server url is https://"myserver".homeserver.com

    I have ADSL modem with nat and needed ports are forwarded to home server. My home server has fixed IP 192.168.255.x. Windows phone connector does not accept ("the specificed server could not be contacted") any server urls like 192.168.255.x. So, does windows phone connector support connection to home server in home network using WLAN? If yes, how to make that happen?

    Thank's.

    Monday, September 12, 2011 7:55 PM

Answers

  • To rephrase: your WP7 phone can connect to your server using 2G/3G (i.e. cellular data) wherever you may be, and can connect using wifi when away from home but not when it's running on your LAN?

    Assuming that's correct, I'd tend to think it's your "router" (your ADSL modem is acting as a router), which probably doesn't properly support loopback connections. Best bet is probably going to be to configure your ADSL modem to act as a transparent bridge (turning off NAT is probably all it will take) then install a router as the next device in line. You'll need to make sure thye router you buy supports a loopback connection; many consumer routers do, but not all. (Most low end business class routers do as well.)


    I'm not on the WHS team, I just post a lot. :)
    • Proposed as answer by Ken Warren Monday, September 12, 2011 8:10 PM
    • Marked as answer by -vesku- Tuesday, September 13, 2011 4:57 AM
    Monday, September 12, 2011 8:10 PM

All replies

  • To rephrase: your WP7 phone can connect to your server using 2G/3G (i.e. cellular data) wherever you may be, and can connect using wifi when away from home but not when it's running on your LAN?

    Assuming that's correct, I'd tend to think it's your "router" (your ADSL modem is acting as a router), which probably doesn't properly support loopback connections. Best bet is probably going to be to configure your ADSL modem to act as a transparent bridge (turning off NAT is probably all it will take) then install a router as the next device in line. You'll need to make sure thye router you buy supports a loopback connection; many consumer routers do, but not all. (Most low end business class routers do as well.)


    I'm not on the WHS team, I just post a lot. :)
    • Proposed as answer by Ken Warren Monday, September 12, 2011 8:10 PM
    • Marked as answer by -vesku- Tuesday, September 13, 2011 4:57 AM
    Monday, September 12, 2011 8:10 PM
  • Yes, that's exactly the case.

    I have ADSL modem with integrated WLAN (+ separate switch) so modem is acting as router as you wrote. I'll check my modem settings first. Thank's very much for your valuable answer and suggestion!

    Tuesday, September 13, 2011 5:05 AM
  • Update.

    Problem solved. After enabling (hidden) loopback feature in ADSL modem/router, everything works as expected.

    Tuesday, September 13, 2011 6:53 PM
  • Which ADSL modem do you have?
    I'm not on the WHS team, I just post a lot. :)
    Tuesday, September 13, 2011 8:06 PM
  • Zyxel P-660HW-D1

    Here are instructions for enabling loopback: http://cmalton.me.uk/node/219

     

    Wednesday, September 14, 2011 6:22 PM