none
MS-MPI Install Failed (Error Code 2) RRS feed

  • Question

  • Summary:

    1-Had MS-MPI v6 installed

    2-Uninstalled MS-MPI v6 via "Programs and Features" in Windows

    3-Downloaded MS-MPI v7 installation files (MSMPISetup.exe , and msmpisdk.msi from official Microsoft downloads)

    4-First, executed msmpisdk.msi (no errors. installation files installed successfully to C:\Program Files (x86)\Microsoft SDKs\MPI)

    5-Second, executed MSMPISetup.exe

    - Error occurs (shown below).

    Notes:

    -Everything run from command prompt, running as administrator

    -Windows 10 Home x64

    -Ran MSMPISetup.exe with " -verbose -log <logfile> -force -temp <temp_dir> " flags (paths obviously present). No error log is recorded, same error pop-up appears.

    -

    Friday, December 4, 2015 5:23 PM

All replies

  • If you run MSMPISEtup.exe in interactive mode, does the same error happen?

    Thanks

    Anh

    Wednesday, December 9, 2015 6:10 AM
  • I have same issue.

    1. MS-MPI v6 was installed (redist, SDK, debugger)
    2. I have uninstalled both redist and SDK
    3. Downloaded v7
    4. SDK installed successfully, redist (MSMpiSetup.exe) - error code 2.

    I tried logout/reboot, downloaded several times..

    So I tried to install v6, and.. same thing happened.

    I am feeling lucky I could do system restore.

    Any suggestions?

    My guess it's something v6 uninstalled did..

    Monday, January 11, 2016 4:49 PM
  • Hi Jmennius,

    Is this error happening with running MSMPISetup.exe in interactive mode or command-line mode?

    Monday, January 11, 2016 9:07 PM
  • Hi Anh,

    It happens in both modes.

    Sorry for delay. Unfortunately site doesn't provide me with alerts.. (I have them enabled)

    Friday, January 22, 2016 2:43 PM
  • Hi Jmennius,

    Can you run (from an admin console) msmpisetup.exe -log c:\msmpi_install.log and provide us with the installation log ?

    Thanks

    Friday, January 22, 2016 6:56 PM
  • Hi Anh,

    Unfortunately it doesn't create a log file.

    I have created log with process monitor, but I can't attach it here.

    Maybe you can provide your email address so I can send it to you?

    Thanks.

    Saturday, January 23, 2016 2:33 PM
  • Hi,

    You can just copy and paste the log content here

    Thanks

    Anh

    Monday, January 25, 2016 10:44 PM
  • It's a file, about 500KB, and probably in binary format..
    Monday, January 25, 2016 10:46 PM
  • Hi Ievgen,

    We have already responded to the email you sent to our external alias (askmpi at microsoft.com) but I am re-posting the answer here in case others find it useful.

    The v6 uninstall for some reason did not cleanly clean up the registry key and thus the v7 installation could not proceed due to the assumption that the registry key was corrupted. If you remove this key v7 installation should work fine

    HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{8499ACD3-C1E3-45AB-BF96-DA491727EBE1}

    Thanks again for providing us with the useful log. This will help us make sure similar issues will not exist in future releases of MS-MPI


    Wednesday, January 27, 2016 2:24 AM
  • Hi Anh,

    Thank you and MS-MPI team!

    Wednesday, January 27, 2016 7:53 AM