locked
Why isn't latest WHS update KB961030 being installed? RRS feed

  • Question

  • Ok, now I'm really ticked off! I had one of my HTPC Vista Premium machine refuse to boot last week. So naturally I turned to my WHS machine to restore a backup. So I went through the motions of sticking in the restore CD with the latest restore software only to get to a point where my Vista machine just refused to restore. I could see the backups ok over the network but no amount of encouragement would let me restore the backup. Kept getting ' P { FONT-FAMILY:Tahoma; FONT-SIZE:10pt } DIV { FONT-FAMILY:Tahoma; FONT-SIZE:10pt } TD { FONT-FAMILY:Tahoma; FONT-SIZE:10pt } an unknown network error has occurred during pc restore'. So I figured I'd cut my losses and try and at least recover some files I had on the drive by jumping onto my WHS machine and opening the backup.

    I get to 79% and whammo! It stops every time. I do some research and discover it was a problem that was resolved with KB961030. I go looking for KB961030 and it hasn't been installed. I have Power Pack 1 already installed, before anyone asks. I go to Windows Update and the update doesn't come up. It can't be downloaded from the Microsoft site either. I finally track down a copy someone had on a torrent site and it refuses to install telling me it doesn't apply to my version of WHS or something similar.

    What the hell is going on? I just can't win a trick! WHS was supposed to be my knight in shining armour and instead cost me a day of my life without getting me anywhere.

    Can someone please help me install this damn update? I've checked the installed updates about a dozen times now and unless I'm blind, I can't see it. Is there an easy way to verify if it has been installed or not?

    Please help or I'm tossing the WHS machine into the dumpster and buying a Mac!
    Sunday, March 15, 2009 11:37 AM

All replies

  • What are the versions shown in the Console, Settings page, Resources tab?
    I'm not on the WHS team, I just post a lot. :)
    Sunday, March 15, 2009 12:31 PM
    Moderator
  • Hi Ken. Versions as follows.

    Windows Home Server Console: 6.0.1800.0
    Windows Home Server Backup & Restore: 6.0.1800.0
    Windows Home Server Drive Extender: 6.0.1800.0
    Windows Home Server Remote Access: 6.0.1800.0
    Windows Home Server Storage Manager: 6.0.1800.0
    Monday, March 16, 2009 12:09 AM
  • BigRizz said:

    Hi Ken. Versions as follows.

    Windows Home Server Console: 6.0.1800.0
    Windows Home Server Backup & Restore: 6.0.1800.0
    Windows Home Server Drive Extender: 6.0.1800.0
    Windows Home Server Remote Access: 6.0.1800.0
    Windows Home Server Storage Manager: 6.0.1800.0


    You are not up-to-date.  What happens when you click the Update Now button in the Console?
    Monday, March 16, 2009 12:27 AM
    Moderator
  • I hit 'update now' and it installed a couple of security updates (960225 and 958690) and the malicious software removal tool - March 2009 (890830).
    Monday, March 16, 2009 1:02 AM
  • BigRizz said:

    I hit 'update now' and it installed a couple of security updates (960225 and 958690) and the malicious software removal tool - March 2009 (890830).


    Although it shouldn't make any difference, did you reboot the server then check for more updates?  (I'm assuming you won't find any more.)  What add-ins/apps have you installed on your server?  You could try filing a bug report on Connect.  Otherwise, your only option is Server Reinstallation.

    Monday, March 16, 2009 1:30 AM
    Moderator
  • Yep, I rebooted the server and it didn't find any more updates.

    I've got a bunch of add-ins installed.

    WHS disk management
    uTorrent
    Lights Out
    Whiist
    OnTheFlyUnzipper
    PhotoSync Beta2
    Media Connect Controller
    WHS Toolkit
    ASoft AutoExit 2008
    WebGuide4
    Jungle Disk for WHS
    WebFolders4WHS

    So are the versions incorrect for Power Pack 1 or have their been subsequent updates that should have changed these versions?
    Monday, March 16, 2009 2:01 AM
  • BigRizz said:

    Yep, I rebooted the server and it didn't find any more updates.

    I've got a bunch of add-ins installed.

    WHS disk management
    uTorrent
    Lights Out
    Whiist
    OnTheFlyUnzipper
    PhotoSync Beta2
    Media Connect Controller
    WHS Toolkit
    ASoft AutoExit 2008
    WebGuide4
    Jungle Disk for WHS
    WebFolders4WHS

    So are the versions incorrect for Power Pack 1 or have their been subsequent updates that should have changed these versions?



    6.0.1800.0 is Power Pack 1.  However, you are missing up to 4 WHS-specific updates that have been released since then (which did change the version numbers on some components).  You could try uninstalling all of those add-ins, then reboot the server and search for updates again (although I can pretty much safely rule out Disk Management, Jungle Disk and the WHS Toolkit v 1.1 as being the root cause of the problem because I use those as well).  I would start with WebGuide 4 (I know that has not been in development for some time - pre PP1 as I recall).
    Monday, March 16, 2009 4:49 AM
    Moderator
  • Hey Kariya21. Did as you suggested and still no joy. I uninstalled PP1, rebooted then reinstalled and rebooted. And again, no joy. I'm thinking reinstalling WHS is looking like the only option. A noob question that might save me a lot of time, if I simply reinstall the operating system over the current install, I'm guessing all my data will be preserved? My major concern is that a couple of the drives are connected to a SATA PCI card that won't immediately be recognised by the OS and will need drivers to be installed. I just hope WHS doesn't do anything screwy and blow away any data.

    Any hot tips, people? Anyone else had a crack at reinstalling WHS?

    Thanks in advance.

    S.
    Monday, March 16, 2009 9:35 AM
  • When you reinstall you will need to supply drivers for that SATA controller during the initial graphical part of setup. Windows Home Server won't offer you the option of reinstallation if it can't see your storage pool drives.

    I'm not on the WHS team, I just post a lot. :)
    Monday, March 16, 2009 11:45 AM
    Moderator