locked
CRM 4.0 email router - display name RRS feed

  • Question

  • Dear All,

    Just installed CRM 4.0 and hooked it up with our exchange 2007 server via the email router, my problem is when I send an email from CRM to an email address outside our organisation, the display name is missing so the name comes up as name@domain.com instead of First Name Last Name.

    I have tried various different account configurations in the email router config tool, but with no luck.

    Does anyone know how to solve this?

    Many thanks

    Dave
    Thursday, August 14, 2008 2:39 PM

Answers

  • This is more of an issue with Exchange 2007 and how is sees the SMTP email from CRM 4.0.  Read up on "ResolveP2" to learn more.

     

    The solution is to create an "Externally Secured" Receive Connector for CRM.  This will open it up and allow Exchange to trust the CRM email, and it will resolve the name correctly.

     

    Cool features, but I wish Microsoft CRM documentation detailed this better!!!

     

    Sam

    Saturday, November 8, 2008 12:49 AM

All replies

  • Do you have it set to the email of the crm user or the email of the forward mailbox?

    Thursday, August 14, 2008 4:30 PM
  • Hi Will,

    Currently I have setup an outgoing SMTP profile on the email router, using the users credentials (with windows auth), but I’ve tried the administrative user and password but with the same results. Im not using a forward mailbox.

    Also in CRM, on the options>email page I have ticked the box (allow email router to use my credentials to send and receive email on my behalf) and entered the crm users email account credentials.

    In the settings>administration>users> I have the ‘email router’ set as the email access type outgoing.

    Thanks

    Dave

    Thursday, August 14, 2008 6:51 PM
  • If anyone else has this problem I have been in touch with microsoft support and after many tests on our crm server just got this back:


    The issue has been identified as a bug. And that bug has been opened three weeks ago, actually the dev team is working on it.Your contact has been pushed also on that issue to make an efficient business case to get the Hotfix.

    I just want to let you know that Hotfix request can be a very long process and take more or less time to get the released of that: it is because we followed a long process of testing to make sure we didn’t leave in that Hotfix any regression path and any wrong code which can be a benefit for malicious code.



    Friday, August 29, 2008 2:50 PM
  • This is more of an issue with Exchange 2007 and how is sees the SMTP email from CRM 4.0.  Read up on "ResolveP2" to learn more.

     

    The solution is to create an "Externally Secured" Receive Connector for CRM.  This will open it up and allow Exchange to trust the CRM email, and it will resolve the name correctly.

     

    Cool features, but I wish Microsoft CRM documentation detailed this better!!!

     

    Sam

    Saturday, November 8, 2008 12:49 AM
  • Hi.

    I have made a connector with "externally secured" authentication and "exchange servers" as permission group. I have configured a forward mailbox with "send-as,receive-as,ms-exch-store-admin" rights and I am using that accounts credentials in the e-mail router setup. I have also tried with anonymous, but no matter what the sender is just the e-mail address, no display name. Does anyone know what I am doing wrong?

    Regards
    Thomas
    Monday, November 24, 2008 10:20 PM
  • Hi,

    Sorry for the late response but i saw this queury after 4 years now.. :)

    you can the user display name in the Active Directory then the problume got resolved

    Thanks

    Wednesday, May 23, 2012 3:20 PM