Synchronization failure after downloading database RRS feed

  • Question

  • I am puzzled.  I am doing load testing a new product feature which supports synchronization of databases across multiple systems.  One system servers a central repository or master.  Each satellite uploads changes to the master and downloads changes from the master using the sync framework.  Each satellite is provisioned to access the master.

    I performed one set of tests where I started with all empty databases and gradually added new records on the satellitles.  The satellites would download changes from the master.  This worked fine.

    I next wanted to perform tests starting with a non-empty database.  I delete all the databases (including the database on the master), created new empty databases and synchronized them to the master.  If I added a record via one of the satellites, it appeared on the master and was downloaded to the other satellites as expected.

    I then loaded a populated database onto one of the satellites.  I upload this to the master.  I then downloaded the database to each of the satellites via sync framework.  In some cases, it took several tries to complete the download

    I then started my test, adding records to each satellite.  To my dismay, none of the new records were uploaded to the master (and hence not distributed across the satellites).  After the call to SynchOrchestrator.Synchronize returns, the statistics table reports no upload or downloads.  I can see the new records in the database on the satellite systems via SQLServerManagementeStudio. As noted above the upload/download worked fine before I uploaded/downloaded the large database. Why did this happen?

    I thought, perhaps, there was a problem with the provisioning.  I am in the process of reprovisioning the satellites against the master. It took approx an hour when to download from the master to an empty satellite database.  Now that the satellite databases are populated, the synchronization is extremely slow.  If I examine the tables in one of the satellites, each tracking tables has the same number of rows as corresponding tracked table.  

    Howard P. Weiss

    Sunday, August 3, 2014 10:18 PM

All replies

  • are you doing a restore of a fully populated database that's been previously provisioned and synchronize?
    Wednesday, August 6, 2014 1:42 AM
  • Yes

    Howard P. Weiss

    Monday, August 11, 2014 1:19 PM
  • you might be running into conflicts and you should run performpostrestorefixup right after you restored and before you sync the restored database for the first time.

    you can confirm it by enabling Sync Fx tracing in verbose mode

    Tuesday, August 12, 2014 1:49 AM