locked
Homeserver domain expired? RRS feed

  • Question

  • This evening, I got the following message:

     

    Windows Home Server has been updated. To enhance your Web site security, go to the Windows Home Server Settings, Remote Access page, click Configure, and complete the wizard to update your domain name settings.

     

    Doing so, I have the choice of either releasing the current domain or choosing another one. Not much web security enhancement there. I'm quite happy with the homeserver domain that I've got, so can I just ignore this one?

    I can't test if it's still working on my home network as http resolves to the router but with https I get a 404 (I guess) - page not available.

    • Moved by Ken WarrenModerator Wednesday, August 25, 2010 12:23 PM software question (From:Windows Home Server Hardware and Installation)
    Tuesday, August 24, 2010 11:38 PM

Answers

  • This evening, I got the following message:

    Windows Home Server has been updated. To enhance your Web site security, go to the Windows Home Server Settings, Remote Access page, click Configure, and complete the wizard to update your domain name settings.

    Doing so, I have the choice of either releasing the current domain or choosing another one. Not much web security enhancement there. I'm quite happy with the homeserver domain that I've got, so can I just ignore this one?

    I can't test if it's still working on my home network as http resolves to the router but with https I get a 404 (I guess) - page not available.

    You can still keep the same domain name.  Just choose "choose another domain name", then go through the set up process.  You'll get to a point where you can select the one you're already using.
    • Proposed as answer by kariya21Moderator Wednesday, August 25, 2010 4:43 AM
    • Marked as answer by Crash2975 Thursday, August 26, 2010 4:39 PM
    Wednesday, August 25, 2010 4:43 AM
    Moderator

All replies

  • This evening, I got the following message:

    Windows Home Server has been updated. To enhance your Web site security, go to the Windows Home Server Settings, Remote Access page, click Configure, and complete the wizard to update your domain name settings.

    Doing so, I have the choice of either releasing the current domain or choosing another one. Not much web security enhancement there. I'm quite happy with the homeserver domain that I've got, so can I just ignore this one?

    I can't test if it's still working on my home network as http resolves to the router but with https I get a 404 (I guess) - page not available.

    You can still keep the same domain name.  Just choose "choose another domain name", then go through the set up process.  You'll get to a point where you can select the one you're already using.
    • Proposed as answer by kariya21Moderator Wednesday, August 25, 2010 4:43 AM
    • Marked as answer by Crash2975 Thursday, August 26, 2010 4:39 PM
    Wednesday, August 25, 2010 4:43 AM
    Moderator
  • Thanks, I should have remembered that from when I installed it back in the day, but those options surprised me. All sorted now.

    Thursday, August 26, 2010 4:41 PM
  • I've performed these steps but the error message comes back about every 24 hours.  Then about 5 minutes later the error clears and I get

    Windows Home Server was unable to update Windows Live Custom Domains with your current IP address. Your Web site may not be available on the Internet.

    Also was unable to access server via the web (certificate revoked) after update.  Certificate was updated but not deployed.  Had to manually replace certificate.

    So, I went to the server with remote access, then control panel->admin tools->ISS manager.

    In the ISS dialogue box I opened up the {server name} ->Web sites ->Default Web Site ->{Right click} ->properties ->Directory security ->server certificate ->replace current certificate (there was a certificate with the same date as the day I did the domain reconfigure)

    Exit remote acces -> Now able to get to site via the web again.

    • Edited by doug2h Tuesday, August 31, 2010 11:15 AM added certificate issue resolution
    Monday, August 30, 2010 11:57 AM
  • Thanks for the hints.

    I was able to "reconfigure your domain name" by clicking "Configure", selecting "choose another domain name", signon with my LiveID, select my existing domain name and then continuing on to get an 80000190 error. Repeating the entire process several times yielded the same error before it finally succeeded.

    I think the error and wizard messages and process should be improved to clarify that the "reconfigure" and "change" of your domain name is really to upgrade the certificate from 1024 bits to 2048 bits without actually changing the domain name at all (see KB 979453 issue 2) -- a cumbersome and unintuitive method hindered by poorly explained 80000190 errors.

    Nor is this process obviously the "renewal" referred to in 979453: "After you install this update, you are asked to renew Website certificates if you have already registered the live domain for the websites. After you finish the renewal process, the website certificates are upgraded to 2048-bit."

    Perhaps the wizard could be updated with a "renew website certificate" option in addition to the "release" and "change" of the domain name?

    Addressing the cause of the 80000190 errors would help too, since they are apparently caused by something other than a user error in the wizard and the wizard could notify the user to just try again later.

    Greg

    Monday, August 30, 2010 5:13 PM
  • After the installation of KB 979453, my certificate does not get updated. When surfing to my domain https://xyz.homeserver.com and looking at the certificate it still shows the 1024bit certificate. In the meantime IE reports that the certificate for this site has been revoked.

    Yesterday, i tried this:

    • Uninstall KB 979453
    • Manually trigger update
    • KB 979453 was being re-installed
    • After restarting the server, the red icon and the balloon re-appeared to ask me to configure my domain.
    • After completing the wizard (without releasing my domain name) the certificate is still the 1024bits version.

    Now what?

    Thx in advance,
    StBus

    Tuesday, August 31, 2010 9:00 AM
  • st_bus

    Here is what I had to do:

    Also was unable to access server via the web (certificate revoked) after update.  Certificate was updated but not deployed.  Had to manually replace certificate.

    So, I went to the server with remote access, then control panel->admin tools->ISS manager.

    In the ISS dialogue box I opened up the {server name} ->Web sites ->Default Web Site ->{Right click} ->properties ->Directory security ->server certificate ->replace current certificate (there was a certificate with the same date as the day I did the domain reconfigure)

    Exit remote acces -> Now able to get to site via the web again.

    Tuesday, August 31, 2010 11:20 AM
  • doug2h,

    Thank you very much!.
    You solved my problem!

    Thanks,

     

    Tuesday, August 31, 2010 6:58 PM
  • I'm having this problem as of last night as well.

     

    I first tried the "choose another domain" path above, reusing my current domain, and I got a "Domain Name Setup Failed" window with a "Cannot find object or property 80092004" error.

     

    Then I followed doug2h's instructions and things still don't work.  I still can't run through configuration without the error above.

     

    Ideas?

     

    Should I follow the instructions here?

     

    EDIT:  Looks like those registry keys listed in the Server 2003 section don't exist in WHS.

    EDIT 2: Just checked my DynDNS domain, and it still works (as I assumed). Just wanted to eliminate the router, which hasn't changed. I'm frustrated.
    Monday, September 20, 2010 2:01 PM