locked
[hpc2012r2] Tasks are still split on multiple nodes RRS feed

  • Question

  • According to the HPC 2012 new features: " A job can run on a single node without reserving all of the resources on the node. You now can run a job on a single node without reserving all the cores of the node. For example, prior to this release, if you specified that a job should run on a minimum of 2 cores and a maximum of 4 cores, the job could run on 2 cores, each located on a different node. You can now specify that a job should run on a minimum of 2 cores and a maximum of 4 cores, but still must run on a single node."

    How do you specify this behavior? I have a job that uses cores as resources, some tasks have 4 min, 4max some other tasks have 8 min, 8 max. For the tasks that do have 8 min and 8max, I still do see the same behavior as HPC 2008 with tasks split on 2 nodes (with 4 + 4). I tried making the job and tasks exclusive but no change...

    Tuesday, May 27, 2014 3:22 PM

All replies

  • Did you check on "Run the entire job on a single node"?

    BR, Yizhong

    Wednesday, May 28, 2014 1:48 AM
  • No, indeed... I was hoping that there was an option like that for each individual task to prevent a task to be split onto multiple nodes but I suppose it only exists at the job level.
    • Edited by CadErikWork Wednesday, May 28, 2014 2:16 AM
    Wednesday, May 28, 2014 2:16 AM
  • There are two settings in job level.

    1. "Run the entire job on a single node". With this setting enabled on your job, all tasks will be executed on one node.

    2. "Use assigned resources exclusively for this job". If you want to share unallocated cores to other jobs, please disable this setting.


    BR, Yizhong

    Wednesday, May 28, 2014 3:13 AM
  • So in HPC 2012, there is still no way to prevent a task within a job to be split onto multiple nodes? I tried 1. and as described, the job ends up running on a single node. I tried 2. as well but it doesn't affect the way nodes/cores are shared within a job.

    Wednesday, May 28, 2014 1:50 PM
  • If your requirement is all tasks in a job running in a single node, I think setting 1 (introduced in HPC 2012) is already the way to get it. I agree setting 2 doesn't help on this.


    BR, Yizhong

    Thursday, May 29, 2014 1:55 AM