locked
"Backup Service is not running" RRS feed

  • Question

  • I am getting an alert that the Backup Service is not running. I tried "try to Repair the Issue" without success. I rebooted the Server. I have gotten this advice: "To repair the computer backup database, open the Server Dashboard, and then click the Computers anmd Backup tab. In the Computer Tasks pane, choose Repair the Backup Database."

    After opening the Computers and Backup tab, I do not see anything relating to Repair the Backup Database. What am I missing?

    Also, I seem to be able to MANUALLY complete back.

    Friday, May 14, 2010 6:20 AM

Answers

  • Backup service is designed to stop if storage is unavailable or if there are problems with storage. You should first try to fix the storage issues before fixing backups.

    The wizard to run repair for the backup database did not make it to this release however you run it through commandline.

    On the server

    1) Open an administrator elevated command prompt and go to C:\Program Files\Windows Server\Bin

    2) run backupcontroller.exe /sg. Run repair and repair status are options 11 and 12.

    Let me know how that goes.

     


    Bodhi Deb - MSFT
    Friday, May 14, 2010 9:38 PM
  • I could swear I replied to this earlier...

    Could both of you please submit bug reports on Connect ? Include logs from your server, and please read the instructions for using the log collector tool carefully.

    That said, xploitd appears to be talking about a different issue than Rosemont60. Most likely Rosemont60's issue will be solved in a future release, because there are missing interfaces in the area of backups and restore in this build.


    I'm not on the WHS team, I just post a lot. :)
    Friday, May 14, 2010 4:12 PM
    Moderator

All replies

  • I had the same alert yesterday. The alert stated that the backup service was not running and my storage drives were showing offline in the dashboard.  I looked through the event viewer and found a bunch of errors stating that on of my storage drives had an error and needed to be repaired.  I performed a detect and repair which then informed me that the only way to get the drive working was to format three of the drive shares [R:], [T:], and [V:].  This of course wiped out the information stored in those folders.  The strange thing is that the only folders and information I didn't lose, were the shares that were not being duplicated.

    The problem now, is that after the repair process I can get to the information going through windows explorer on the Server, but I can't get to them from any of my clients and the drives no longer appear in the dashboard.

    Friday, May 14, 2010 1:57 PM
  • SOrry to ask again- xploitd mentions that he perfrormed a detect and repair. ANd I asked After opening the Computers and Backup tab, I do not see anything relating to Repair the Backup Database.

    I must be blkind- could someone take a sec and tell me where this function is located?

     

    Thanks

    Friday, May 14, 2010 2:55 PM
  • I could swear I replied to this earlier...

    Could both of you please submit bug reports on Connect ? Include logs from your server, and please read the instructions for using the log collector tool carefully.

    That said, xploitd appears to be talking about a different issue than Rosemont60. Most likely Rosemont60's issue will be solved in a future release, because there are missing interfaces in the area of backups and restore in this build.


    I'm not on the WHS team, I just post a lot. :)
    Friday, May 14, 2010 4:12 PM
    Moderator
  • I could swear I replied to this earlier...

    Could both of you please submit bug reports on Connect ? Include logs from your server, and please read the instructions for using the log collector tool carefully.

    That said, xploitd appears to be talking about a different issue than Rosemont60. Most likely Rosemont60's issue will be solved in a future release, because there are missing interfaces in the area of backups and restore in this build.


    I'm not on the WHS team, I just post a lot. :)

    Thanks for your reply- I just submitted bug report
    Friday, May 14, 2010 8:40 PM
  • Backup service is designed to stop if storage is unavailable or if there are problems with storage. You should first try to fix the storage issues before fixing backups.

    The wizard to run repair for the backup database did not make it to this release however you run it through commandline.

    On the server

    1) Open an administrator elevated command prompt and go to C:\Program Files\Windows Server\Bin

    2) run backupcontroller.exe /sg. Run repair and repair status are options 11 and 12.

    Let me know how that goes.

     


    Bodhi Deb - MSFT
    Friday, May 14, 2010 9:38 PM
  • This is an absolutely horrible screenshot taken by a spare camera- my daughter has borrowed my Nikon. Sure miss not have Windows 7 Snipping Tool!

    Anyway, you can probably figure out that the Repair option is Number 8, Stop Repair is Number 9, and Get Repair Results is Number 10.

    Unfortunately, pressing any of these keys produces nothing- immediately the screen resets to Enter Your Choice

    Friday, May 14, 2010 10:35 PM
  • hmmm.. just looked at VAIL- and the warning is no long there. Even though I received an instant Enter Your Choice message, and even though I did not get a report, maybe something was fixed. I had just added a 2Tb drive, and removed the 300Gb that preceeded it, so there is planty of storage room. Do you want logs- or anything else?

     

    • Edited by Rosemont60 Friday, May 14, 2010 10:53 PM typo
    Friday, May 14, 2010 10:52 PM