locked
#27938 - An error occurred while checking for e-mail messages RRS feed

  • Question

  •  

    I am getting the following error in the event logs. The Server is SBS 2008

    64bit, CRM 4.0, have installed Rollup 1 - 4. When testing the email router

    everything comes up as succeeded. The errors are happening every few

    seconds. Seems to be happening on all users that are using the email router.

     

    Any suggestions would be helpful.

     

    #27938 - An error occurred while checking for e-mail messages to process in

    mailbox User@Domain.com. System.Net.WebException: The operation has timed out.

    at System.Net.ConnectStream.Read(Byte[] buffer, Int32 offset, Int32 size)

    at System.IO.StreamReader.ReadBuffer()

    at System.IO.StreamReader.ReadToEnd()

    at

    Microsoft.Crm.Tools.Email.Providers.HttpDavRequest.SubmitXmlCommand(HttpWebRequest httpWebRequest, String body)

    at

    Microsoft.Crm.Tools.Email.Providers.HttpDavRequest.RetrieveMessage(ServiceLogger serviceLogger)

    at

    Microsoft.Crm.Tools.Email.Providers.ExchangePollingMailboxProvider.RetrieveNextMessageInternal()

    at

    Microsoft.Crm.Tools.Email.Providers.CrmPollingMailboxProvider.RetrieveNextMessage()

    at Microsoft.Crm.Tools.Email.Providers.CrmPollingMailboxProvider.Run()


    Chris
    Wednesday, May 27, 2009 4:48 PM

Answers

  • so when you load users, queues, etc in the E-mail Router Configuration Manager and you test all the users, the test returns successful for all users including the forward e-mail user?  The errors above are generally related to connectivity or rights which should show as unsuccessful tests in router Configuration Manager.


    Best Regards, Donna
    • Marked as answer by Jim Glass Jr Tuesday, June 2, 2009 9:11 PM
    Tuesday, June 2, 2009 6:08 PM

All replies

  • so when you load users, queues, etc in the E-mail Router Configuration Manager and you test all the users, the test returns successful for all users including the forward e-mail user?  The errors above are generally related to connectivity or rights which should show as unsuccessful tests in router Configuration Manager.


    Best Regards, Donna
    • Marked as answer by Jim Glass Jr Tuesday, June 2, 2009 9:11 PM
    Tuesday, June 2, 2009 6:08 PM
  • I have the same issue

    any suggestions ?

    the server is w2k2003 ent, mail server is exchange 2003, crm is at rollup 5! (tried yesterday), in the E-mail Router Configuration Manager all tests went ok.


    it seems that there are certains e-mail contained in the mailbox that cause this error and the e-mail router stops checking other mails.

    is there a way to log which mail is actually processing the e-mail router ?

    thanks



    Friday, July 17, 2009 10:12 AM
  • Not sure what login you are using for the E-mail Router service, but if you are not, try logging into the service with a domain admin account and see if that helps.  I was able to resolve a similar issue in one network by using the crm admin account to log into the Service
    Best Regards, Donna
    Friday, July 17, 2009 12:41 PM
  • Thanks for the answer.

    The E-Mail Router service is running using the crmadmin user.

    The system worked fine for about 6 months, and nothing changed in these latest days, but actually the crm queue for that mailbox doesn't receive any email.

    We have 9 queues active in the organization, and the other queues works correctly*. same user (crmadmin) and same security policies on the different mailboxes.

    At the moment i'm trying to convince the customer to empty that mailbox, that contains more than 13000 emails, but this is an hard job! :)


    thanks for the help


    *we have also another minor issue on all queues, that cause e-mail router to ignore certain emails, but i think that is related to multiple smtp addresses configured in the exchange mailboxes
    Friday, July 17, 2009 1:06 PM