locked
Microsoft ! Please *TURN OFF" auto correcting HTML tags RRS feed

  • Question

  • Hello Microsoft.

    I translating large webpages in HTML, and I sending to Microsoft Translate source in HTML

    Because of limit of 10 000 chars in one sending I must sending webpage in parts, then join parts to each other.

    But... in mode text/html and in text/plain I have:

    Part1:

    <html><body>text to translate...

    text to tra... </body></html>     // <--- Microsoft adding this

    at end of first part, because it see in begining of the file <html><body>


    Part2:

    nslate... text to translate...

    nslate... text to translate...

    </body></html>   // <--- Microsoft *deleting this* from end of the file,

    because in the begining of the file, it was no <html><body>.... but was in first part...


    So, my translated webpage from part1 and part2 looks like this Microsoft:

    <html><body>text translated...

    text tra... </body></html>

    nslated... text translated...


    Okay with the </body> and </html> tags, but Microsoft - you deleting also <div> from parts of websites, so

    users can't read anything.

    When you will add option, that HTML input not must be well-formed HTML?

    OR - please give option to send larger data than 10000 characters - so you can encode page with your stardards.

    I saw this issue in december 2011 -

    http://social.msdn.microsoft.com/Forums/nl-NL/microsofttranslator/thread/775fd592-9d40-4ca5-85a4-32ac39967c98

    and it is still an issue.

    When you will repair this Microsoft?

    Thursday, May 24, 2012 8:07 PM

All replies

  • I'm working on a little tool that will allow you to translate larger pages.

    If you want to try it out before it's released more widely, drop me a line v-lamo - at - microsoft - dot - com

    Laurence

    Wednesday, May 30, 2012 2:49 PM