locked
My iMac loses connection to my WHS every night. I need to find a solution or the WHS has to go. RRS feed

  • Question

  • I have a problem that is severely limiting my joy with my WHS EX485. I set it up on my network (DLink DIR-655 router) hardwired to the router. Out of the router I also hardwire to a laptop, an iMac, and XBox and a Sonos music system.

    Every morning I wake up and my connection to the WHS has been killed. I can remote desktop in no problem, but Finder cannot see the WHS. The moment I reboot the connection is re-kindled and all is well again. If I go check my laptop sometimes the connection is also killed but most of the time it's still fine. The other morning I checked the Sonos and the connection was killed there too.

    I tried adding login items to connect to the server with links to music, video, & pictures but that didn't change anything.

    I do have on for my WHS to sleep from 4am to 9am. I just turned that off to try it and see if that fixes the issues. My feeling is that I should be able to use that functionality to try and save a little wear and tear on the WHS.

    Any pointers, tips, solutions?
    Sunday, June 28, 2009 6:48 PM

All replies

  • What happens, if you run a permanent ping to the server from another system (or from a remote desktop session within your server)?
    To do that open a command prompt and type
    ping hpserver -t
    (replace hpserver with the name of the machine)

    Such issues is hard to deal with, since each home network environment is different. There could be the power save settings in device manager on the server for the network card causing this, but could also be the router or the Mac. So any diagnostics attempt would have to include all components, starting with driver updates and firmware updates and changing the above mentioned power save setting.

    Best greetings from Germany
    Olaf
    Sunday, June 28, 2009 7:40 PM
    Moderator
  • Okay so I can confirm that when I set my WHS not to sleep that it does not lose connection. So, any ideas if I can get sleep to work as well as not lose connection?

    Keith
    Tuesday, June 30, 2009 5:12 PM
  • Okay so I can confirm that when I set my WHS not to sleep that it does not lose connection. So, any ideas if I can get sleep to work as well as not lose connection?

    Keith

    You can try turning off the Power Management settings on the NIC for the HP MediaSmart; HOWEVER, and I give this my strongest warning possible, your server is a headless device. If this does not work and something goes wrong while you are making this change, you will be locked out of your server. The only way to fix this is a server recovery.  Once the settings for the NIC are incorrectly set, they cannot be fixed without a recovery because you cannot access the server.

    With that warning (sorry it's a bit like happy fun ball), turn off Power Management for the NIC, by doing the following:

    RDP into the server using mstsc.exe on a Windows machine or the equivalent on a MAC.

    On the Server:

    Start>My Computer>manage>device manager>network adapter>expand>right click>properties>Power  Management> Uncheck “Allow the computer to turn off this device to save power”

    Click “OK”

    I did this on my HP MediaSmart and I’m still able to log in. The first login was slow but it appears to be okay. I do not have this machine set to sleep so I cannot verify what the behavior will be for you when the machine wakes.


    Lara Jones [MSFT] | Program Manager
    Community Support and Beta | Windows Home Server Team
    Windows Home Server Team Blog
    Connect Windows Home Server
    Windows Home Server
    Tuesday, June 30, 2009 8:28 PM
    Moderator
  • Okay so I can confirm that when I set my WHS not to sleep that it does not lose connection. So, any ideas if I can get sleep to work as well as not lose connection?

    Keith
    My expectation is that when you put your server into sleep state you will continue to lose your connection to it. It seems as though your Mac Mini isn't able to re-establish a connection when your server wakes, however.

    If you decide to change the settings for your NIC, the only power management setting you should change is the one labeled Allow the computer to turn off this device to save power. (You don't need your NIC waking your server because of network traffic, which will happen fairly frequently if you check that option.)

    Finally, I'll note that Microsoft doesn't support putting your server into low power states. Some OEMs include additional software that helps you to do that, but for help with that functionality you would need to seek assistance from the vendor, in this case HP.

    I'm not on the WHS team, I just post a lot. :)
    Tuesday, June 30, 2009 9:46 PM
    Moderator