locked
Remote Desktop from website works behind router but not outside network RRS feed

  • Question

  • Just as the title says, I cannot RDP from outside my network. I can access the website, but when I try to connect to a specific computer I get a pop up saying that an error occured on the computer I am trying to connect to or on the server . The only time it works is if I connect directly using RD or if I use the web site on another computer in my network. I have checked and ports 80 and 443 are fowarded correctly. My time zone is set to PSTand I am able to stream music and video with no problems.  I am using a Linksys WRT610N. I have no problems remoting into WHS1 and it is not currently on  the network.
    METHODMAN
    Wednesday, May 12, 2010 6:39 PM

All replies

  • What operating systems are your home computers running?
    I'm not on the WHS team, I just post a lot. :)
    Wednesday, May 12, 2010 7:17 PM
    Moderator
  • Windows 7 ultimate 32bit. I also have a Static IP address and the router is configured correctly.
    METHODMAN
    Wednesday, May 12, 2010 7:23 PM
  • Have you tested your external connectivity using e.g. Shields Up! to see if your ISP is blocking ports?
    I'm not on the WHS team, I just post a lot. :)
    Wednesday, May 12, 2010 7:55 PM
    Moderator
  • No ports are blocked. Could it be a setting that needs to be corrected on the server itself.
    METHODMAN
    Wednesday, May 12, 2010 8:46 PM
  • Just as the title says, I cannot RDP from outside my network. I can access the website, but when I try to connect to a specific computer I get a pop up saying that an error occured on the computer I am trying to connect to or on the server . The only time it works is if I connect directly using RD or if I use the web site on another computer in my network. I have checked and ports 80 and 443 are fowarded correctly. My time zone is set to PSTand I am able to stream music and video with no problems.  I am using a Linksys WRT610N. I have no problems remoting into WHS1 and it is not currently on  the network.
    METHODMAN
    What is the exact error message you get?  What OS is on the remote computer?
    Thursday, May 13, 2010 3:55 AM
    Moderator
  • the error " an error occured on the computer I am trying to connect to or on the server contact adminstrator" The computer I was trying to connect on is XP pro sp3. I am going to take my laptop today and try with windows 7 to see if I get the same error.
    METHODMAN
    Thursday, May 13, 2010 11:28 AM
  • New error on the XP machine today.

     " an error occurred while sending data to the Remote Gateway Server. The server is temporarily unavailable or a conection is down. Try again later or contact administrator".

    Tried windows 7 32bit was able to remote into the server but when I clicked on the Vail Dash Board the remote window closed but not the window with the home screen. I was successful at reconnecting with no problems but got the same problem with the dashboard. I tried again and this time I was able to connect to both of the client computers and was able to open programs and documents and so on. I am concluding that it has something to do with Windows XP. I had a friend try the same from a vista 64 and a vista 32 machine and he had the same results. Now I have another issue with the Dashboard closing down or crashing. 


    METHODMAN
    Thursday, May 13, 2010 3:17 PM
  • New error on the XP machine today.

     " an error occurred while sending data to the Remote Gateway Server. The server is temporarily unavailable or a conection is down. Try again later or contact administrator".

    Tried windows 7 32bit was able to remote into the server but when I clicked on the Vail Dash Board the remote window closed but not the window with the home screen. I was successful at reconnecting with no problems but got the same problem with the dashboard. I tried again and this time I was able to connect to both of the client computers and was able to open programs and documents and so on. I am concluding that it has something to do with Windows XP. I had a friend try the same from a vista 64 and a vista 32 machine and he had the same results. Now I have another issue with the Dashboard closing down or crashing. 


    METHODMAN
    I submitted a bug for something very similar about a week ago.  See if this sounds like your issue...
    Friday, May 14, 2010 3:35 AM
    Moderator
  • Thats pretty much the same thing I can't connect to the server or clients with an XPsp3 machine. I get to the home page where you can see the shared folders, media, server and the clients. When I try to connect to any of them I start getting that error. I have no problems connecting with Vista or Windows 7. The only other problem that I run into is that when I connect to the server remotely the Dashboard disappears and the remote session closes down as soon as I click on the Dash board. I also cannot intall the connector software on XPSP3 machine as well.


    METHODMAN
    Friday, May 14, 2010 9:43 PM
  • Thats pretty much the same thing I can't connect to the server or clients with an XPsp3 machine. I get to the home page where you can see the shared folders, media, server and the clients. When I try to connect to any of them I start getting that error. I have no problems connecting with Vista or Windows 7. The only other problem that I run into is that when I connect to the server remotely the Dashboard disappears and the remote session closes down as soon as I click on the Dash board. I also cannot intall the connector software on XPSP3 machine as well.
    METHODMAN
    Please note that I was able to find a fix for my problem.  I added it to my original post I linked to above.
    Saturday, May 15, 2010 5:12 AM
    Moderator
  • Will this help solve the problem with installing the connector software also?

     


    METHODMAN
    Saturday, May 15, 2010 10:09 PM
  • Will this help solve the problem with installing the connector software also?


    METHODMAN

    No, it only fixes the remote logon issue from XP.  If you are having problems installing the Connector software on an XP client in your LAN (note that you cannot do it remotely), you should file a bug report on Connect.
    Sunday, May 16, 2010 3:24 AM
    Moderator
  • Just as the title says, I cannot RDP from outside my network. I can access the website, but when I try to connect to a specific computer I get a pop up saying that an error occured on the computer I am trying to connect to or on the server . The only time it works is if I connect directly using RD or if I use the web site on another computer in my network. I have checked and ports 80 and 443 are fowarded correctly. My time zone is set to PSTand I am able to stream music and video with no problems.  I am using a Linksys WRT610N. I have no problems remoting into WHS1 and it is not currently on  the network.
    METHODMAN

    I assume you are using a Microsoft RDP client rather than the Built-in Website's Remote Desktop.  If so, the Vial UPnP setup doesn't take care of forwarding port 3389.  It only takes care of ports 80 and 443.  Port 3389 is the default RDP port.  You will need to access your router and manually forward port 3389.
    Wednesday, May 26, 2010 6:17 PM